Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Black screen after updating Radeon software.


New here but not to the AMD scene, so yesterday i attempted to update my drivers from radeon crimson 17.2.1, (for some reason this version doesn't do auto updates??), so i downloaded 19.1.1, and did the usual AMD cleaner and DDU clean in safe mode, rebooted started the driver install all went well, promoted to restart so hit restart, on start-up was normal with the windows loading screen then when it transitions to the login window the screen stays blank, left it for awhile in hope that it might comeback, restarted a few times just to be sure, tried all ports currently using DVI as i always have. long story short had to turn off the computer and force safe mode and use the AMD and DDU cleaner to remove, when the computer restarts all is working well.

Then attempted version 18.12.2, 18.7.1, 18.6.1, 18.2.2, same for all these, and yes between each try i used the AMD cleaner and DDU cleaner (i also opted for DDU claner to remove the C:AMD folder, and have windows not install device drivers)

So currently i have Radeon Crimson 17.2.1 installed once again as it works, computer has been on and off heaps of times to test.


ASRock FM2A88X+ Killer

AMD A10 7850K

MSI RX 480 8GB (waiting for the new RX series)

HyperX Savage 2133 DD3 4x8GB

BenQ XL2720Z (yes drivers are installed)

Any help would be appreciated, up until now i have had no problems it games perfect, never blacked out blue screened not a single issue.

33 Replies
Adept II


Tinight I was able to install Crimson 17.9.1 over 17.2.1. I should also add that I have ensured that all windows updates are done.

However I'm still left with an driver that is over  a year old, I would like to update this to one of the latest adrenaline series drivers. I am also concerned that even if I did get one of the new cards coming that I will not be able to install the appropriate driver without windows black screen on startup.

Yes I have tried installing an adrenaline series driver after getting the crimson 17.9.1 driver to install.

I wish I had a solution for you but unfortunately all I can say is that I also have this issue. Driver v 17.1.1 seems to be the only driver that works for me.I have tried multiple other versions with same issue. Once I restart I get black screen after the windows logo. I have to force shut down computer until I can access recovery mode and then disable, remove and reinstall v 17.1.1. There are others who have experience this issue, but I have not found any solution that works for me. Some suggested an issue with hdmi but I see you are using DVI. 

My next step is to contact AMD support to see if it is an issue with my card, when I have some free time. 

One thing I see in common, is that I also have an older APU chip, but mine is an AMD A8-7600. That may be part of the issue, I think I remember reading someone else having one of these chips who had the same issue. There were suggestions about something becoming messed up and the computer thinking the internal APU GFX was set back to primary. I checked my Bios and I have the internal APU GFX disabled.

AMD A8-7600


8 GB DDR3 GSkill PC3-12800

ASUS VH236H connected via HDMI

Adept II

Hey Methvenc

Since my post i have installed windows 10 pro twice, installed every update i possibly could and still the Adrenalin series drivers don't work. i have contacted AMD support and am currently trying to resolve the issue with them and do any suggestions they have if i haven't already.

so i have noticed after searching a lot of people are having trouble with windows 17.1.1, this seems to be the base driver for Win10 that has been supplied and certified, now the ONLY way i have been able to install 17.9.1 is downloading every update possible for windows including the latest security drivers, restart your computer in safe mode i always do this with networking off, use the AMD cleaner- dont restart yet, use the DDU Cleaner tell it to delete the AMD folder also and disable windows from installing drivers, select it to restart on completion, whilst it is restarting disconnect your network cable this helped a lot stopped windows from doing anything about the drivers. before you install drivers may i suggest you follow this walk through to delete AMD and ATI drivers from the compter and registry i had heaps that AMD and DDU cleaners didn't do:

Guide to fully removing ATI drivers | guru3D Forums 

After that and you restart your computer (with no network cable or connectivity) install 17.9.1, once installed allow it to restart like normal and plug in your network cable. This should be all good, this version has worked for me every time and no problems as yet, and i will say my FPS with 17.1.1 was between 45-70 with 17.9.1 its 70-120 depending on whats happening and what game (as a reference in War Thunder i get 100fps) 

I run a 144hrz BenQ monitor and noticed a big difference when drivers are installed so if you haven't done so i suggest even with HDMI install drivers for the screen from the manufacturer, have seen a few posts both AMD and Nvidia that if the drivers aren't installed that can also cause black screen on startup.

I have been getting my old drivers from:

AMD Radeon Crimson Edition Graphics Driver 17.9.1 Hotfix Driver - TechSpot 

lots to choose from as they are not supplied on the AMD website anymore:

i should also point out that for some reason on start up the installer for windows 17.9.1 began popping up after install, if you have this issue check startup through msconfig and task manager, then check task scheduler, if it still pops up download this driver from windows and run it autoruns (its a back door of sorts for task scheduler really good) run it as the administrator and there is a section for task scheduler there will be an AMD or ATI task in there un-tick or delete it.

Autoruns for Windows - Windows Sysinternals | Microsoft Docs 

I really hope this helps you or someone with similar issues. I will keep updating this as information becomes available in the hope i can help anyone with the same issue, or until i get a RX600 series or the new RX vega series hopefully the issue does not follow me into that endeavor.

Just wanted to thank you for your response on this. I had read it previously but never got around to responding. I still have not installed 17.9.1 but will get around to doing it eventually, that or just sell the 560 and get a new card considering the prices have been dropping recently. I do appreciate the tip using autoruns, I also had a pop up to install new AMD software on every reboot. I saw something hidden in task scheduler. 

You mentioned you had submitted a ticket to AMD support, did you get anywhere with that?


Sorry for replying so late. Ticket with AMD continued for a few weeks but they just kept asking me to do the same things over and over adding something different to the mix each time, basically anything you can google and find out yourself and diagnose.

I did finally find a fix, see my latest comment on this thread.


hey bro. made an account just to say i love you so hard right now omg. rolling back to 17.9.1 did the trick with the steps you provided. thanks a bunch

edit: nvm, intermittent crashing even on 17.9.1. upgraded back to 19.5.2, won't touch any games until this issue is fixed

edit 2: went back to 17.9.1 after jumping between different versions. i also upped my DRAM voltage to 1.65 from 1.50 and changed speed from 1600 to 1333. so far the issue seems to have gone away now; got to play Dark Souls III for 3 hours uninterrupted at last. i don't know what the issue is here -- whether it's either that my hardware is crap or the software just doesn't mesh well with my parts at all, i can't tell. i should add that my GPU fan doesn't spin so damn fast like before; max RPM was recorded at 1287, card at 73C, whereas before it'd spin close to 3000 at the same temps. 

specs as follows:

Asus A55BM-E

Athlon II X4 870K

HIS RX 560 2GB

Kingston KVR16N11/8


Hey Hermitdeluxe

Thanks for the reply and letting me know what you have done and tried. 

Hope all is still working?

If you are still having issues try my latest comment on this thread i hope it helps.


Going to sound strange, but maybe try enabling the CSM module / mode in the bios. That's the compatibility support module.

Apparently this was an issue for the R VII in early release, but still might be of interest since it required a gpu bios update to fix.


jdrobinson314‌ I checked my bios and that option was already enabled. I think it's time for a fresh install of windows anyway so I am going to test from scratch and see how it turns out.


Did you have any luck with the updates?

Journeyman III

exact same issue, 

Windows 10 home, retail (Version 10.0.17134 Build 17134)

asus M5A 97 LE R2.0  AM3+ ATX motherboard

AMD FX 6300 processor

Radeon R7 370 graphics card 

as soon as i update to radeon drivers i get a black screen.

either using windows update, downloading the driver directly from amd's website (radeon adrenalin 2019 driver install), install just the driver striped out of the adrenalin package, from the device manager, old version or new, all end in the same black screen.

it looks like the driver finishes loading, there is a flash/blink where things look fine for a split second, then black screen

Journeyman III

Hello ,

I have Sapphire Pulse Vega 56 and had the same problem and none of the fixes you can find on forums helped me. BUT I FINALLY FOUND A SOLUTION FOR ME.

Computer>Manage>Device Manager>Display adapter>Vega(or whatever card you have)>Properties>Driver>Roll Back Driver

Do that and then restart pc and then update the drivers back from the same Properties>Driver tab with Update Driver button.

I should mention that i had a clean windows 10 retail edition installed and i use 144hz monitor but i switched from DP to HDMI thinking it would solve the problem, but it didn't i was still getting black screens, only after the driver thingy was done black screens stopped, i didnt switch back to DP to use 144hz yet,so i only use 120 Hz(HDMI) atm and its working for 3 days no black screen. I hope it helped some1.


I also tried doing the roll back driver to no end, but its definitely worth a try, unfortunately for me it was all about the on-board graphics getting windows nickers in a knot and then installing the display driver for that even though it wasn't being used as the primary display.

if you are using a 144hrz monitor make sure you have the latest driver installed form the company, and i would high;y suggest going with the DP port with a v1.4 cable as the HDMI just doesn't cut it as your probably aware.

See My latest reply to this Thread.


How were you able to roll back if the monitor is showing black screen??  I can't do anything with a black screen?



I have been having a very similar issue for as long as I have had my RX 480 GPU, however the most recent version I can update my drivers to is 17.9.3. When installing any new driver version, the progress bar freezes, my screen goes black and then my computer tries to reboot. This reboot then results in a black screen and I have to boot into safe mode to uninstall the faulty drivers. I can use version 17.9.3 just fine but I want to update my drivers so I can play some of my newer games. Has anyone actually found a fix for this and is able to update their drivers without issue? It would be greatly appreciated.


Try doing my last comment, it may help.

What are your PC specs?

Adept II

Hello Everyone



First off let me say i'm sorry its taken me so long to reply i have been smashed at work.


So i have been able to finally fix my issue and its an odd one indeed, but an easy fix luckily.


The problem isn’t so much with the Radeon Driver, its actually Windows and its anxious need to install drivers even when they aren’t needed. That driver for me being the on-board graphics that is a part of the AMD A7850K R7.

I tried a number of different ways to try and stop the driver from installing including removing the LAN cable prior to doing the DDU cleaner then installing the Radeon software after start-up, but as soon as then LAN cable is reconnected  Windows goes ahead and reverts and installs ye ol faithful 17.1.1 as the primary display driver even thought the primary display card is my RX480.


Clearly the problem for me is the on-board graphics driver, but I did the following and it works, after doing these steps I was able to install 19.8.2 I think it ways and have since updated (more on that at the end) but don’t fear if you get stuck because you have decided to overclock your GPU and its now had a catastrophic mental breakdown and black screened you will still be able to use the on-board graphics chip-set but it will just be working using the windows display adapter driver, more than enough to get you to what you need to do.


Thankfully after a lot of searching I found a few things and did those, I cannot find the original link I followed to do these, but I will do my best to walk you through the process that helped me, as well this link should also help guide you to where you need to go, and also do his suggestions along the way (it will save me a lot of writing or making a video)

Stop Windows From Automatically Installing Drivers - YouTube 


So the things we need to do are in Edit Group Policy:


Computer Configuration>Administrative Templates>System>Device Installation>Device Installation Restrictions

Then we need to make changes to (for me no.7 on the list): Prevent Installation of devices that match any of these ID’s

Double click on that and it will bring up a new window.

In the new window you will need to enable it, then click on “show” in the dialogue box that appears you will need to paste the display driver in there and click ok then apply in the settings.


This link showing and Intel driver doing the same will help: Stop Windows from installing drivers for specific devices - gHacks Tech News 


Go ahead now and use the DDU cleaner  to remove all traces of AMD drivers, and restart and do the install of the Radeon Driver, I would start with the very latest driver available from AMD for your particular chip-set and go from there as that’s what I did and it worked.

Now the exiting thing is i have just 2 days ago built a new PC, i did buy an MSI RX5700XT when they came out only for it to catastrophically bottleneck my CPU that being the A10-7850k (don't make my mistake).

New Specs

MSI X570 Gaming Pro Carbon 

AMD Ryzen 7 3800X 


Corsiar Vengeance 3600 DDR4 4x8gb

Samsung 970 Pro M.2 NVMe 512GB SSD

Old PC is in its box but i left the original SSD with it with windows 10 pro still installed on it if i need it at any point.

Please don't hesitate to still ask questions on this post, i know how hard it can be and frustrating. I will endeavor to help.

Journeyman III

Hello SpeedBleeder

My system:

  • Ryzen 5 3600
  • Sapphire Nitro+ vega 64
  • Asrock wifi x570

I have tried the group policy editor and now it doesn't black screen but it gives general error everything but the display driver will install. I've done everything over with a new install of windows and blocked the microsoft basic display adaptor.

Though after i close the error window and open policy editor again and disable the restriction. The screen goes back to its native resolution and stays on for a moment and flickers until it black screens. I dont know whether it is a hardware or a software issue as I know that my PSU is not the recommended wattage currently 550watts bronze. Pls help


Hello Troubledsoftware

What driver series are you trying to install?

What program/device did you ask it not to install? was it specific or vague? because if it was to vague and not like eg: 'AMD Radeon RX 5700 XT" (this being my primary, as i no longer have a supported on-board graphics).

Have you tried allowing it to install just the Microsoft basic display adapter? and blocking everything else? it needs a driver and it could be a conflict with Microsoft causing the failure.

When you disable the restriction it sounds like what ever you had blocked worked but maybe you weren't specific enough with the actual display adapter driver details?

Display adapter Driver Details.PNG

Correct me if i"m wrong but the 3600 series like the 3800 series doesn't support on-board graphics? its only the 3200/3400 that support on-board. and if your blocking your primary card then the Radeon software wont install correctly or at all and throw up an error.

After doing some research, and pondering your problem, it could also be that yes, your PSU is greatly under powered, the recommend PSU for a Vega 64 is 750W, so after the Radeon software is installed it would be taking control of the card and adjusting all parameters ram, mhz, including power. I would suggest purchasing the corsair RM850i or RM850x, i have the RM850i and its fantastic, supplying enough power to the GPU is just as important as the board and CPU required power. 

Let me know how you go? and ill try and help with any questions you have.


Thanks for relpying

My approach was different I blocked the microsoft basic display adapter which stop my screen from flickering and going black but it then gave me error 1603. The version that I am trying to download is amd 19.10.2. And Yes the 3600 doesnt have onboard graphics. So based on the problems do you know if it is a hardware or a software issue. Currently im doing another install of windows and repeating the steps.


Also am i not suppose to block microsoft basic diplay adapter?


Hey Troubledsoftware

I would not be blocking the Microsoft display adapter, windows needs a driver to work and display the screen, that shouldn't be causing the screen to black out and flicker other than its initial install, its the installation of 17.1.1/17.1.2 that you want to stop Microsoft from installing as its the "go to" driver that Microsoft selects from the AMD line-up.

After you finish this current windows install, don't install the Radeon software, just let it idle does it flicker or black out?

Software is not your issue, i believe your issue is your power supply, its under powered by 200w you need a new power supply. With all the things running in your system HDD SSD, case fans, water cooler?, motherboard power, CPU power, and finally your vega 64.

let me know how you go with this.


Thanks for replying again 

My screen only flickers and then goes black when im in the process of downloading drivers 19.10.2 if running on microsoft drivers it doesn't black out. Also when using pcpartpicker and other wattage calculators there predicted wattage is just under 550 which i know it is a bad thing to have it under load


Hey Troubled software

The current AMD software recommended is 19.9.2 for the Vega 64 and 19.11.2 for optional. I would be trying 19.9.2 instead of 19.10.2. there may be issues with the Vega 64 with driver 19.10.2, there are issues for the RX5700xt GPU with the new optional 19.11.2 driver so i haven't installed that driver.

Hopefully you can get a driver installed that will work for you system.


Hey Troubledsoftware

Are you auto detecting the software or going to the AMD website and selecting your VGA and downloading the driver?


I have a question

Today I was installing the amd drivers of my friend's new pc, ryzen 3600 + rx 5700, monitor hdmi port, but suddenly the screen just go black but the pc was still working, i don't know what happened, so i searched and is a common problem in amd lately. My problem sounds like yours, but its a new pc, everything is new. The mb dont have on board video and i can't try new ports because her monitor has only hdmi/vga (that the gpu dont support). I can access the bios, but not the windows. I don't know what to do, i can try to clean the drivers with DDU and install again (but I read that just doing it probably dont fix the problem...) but idk what else to do... Do you know if I do your steps to disable windows update from installing drivers can solve my problem?

Journeyman III

I manualy select the driver 19.9.2 from  and paste it on a usb drive. I did the express install but it black screen at 40% then flickered back on with native resolution. During this time my mouse and keyboard was turned off then turn back on when the screen went black. This makes me believe that there isn't enough power for the system. I get back onn  in a few weeks once i get a higher wattage psu and let you know if anything has changed


Good news!!! I switched out my gpu and now it works

Journeyman III

AMD MSI r9 290

Windows 10 pro

Now just recently I was playing Overwatch (a game that has never given me or my friends any trouble at ALL) and out of nowhere (I was in a lobby, not even playing the game so no stress on my system whatsoever) my screen goes black. It didn't turn off my screen as I saw it still lit up, but black. I couldn't use any of the controls and had to use the button to turn it off.

After that, any time I boot I see my BIOS from msi like normal, I see the windows 10 icon with thr spinning loading dots under it and then black screen again. I've tried reinstalling windows on both my HDD and SSD which did not help. Safe mode would not start. Settings to prioritize the internal motherboard gpu didnt do anything. It was when I took off my external gpu (amd r9 290 from MSI) that I got the normal windows login screen. I uninstalled my amd drivers using their own uninstaller and ddu. Now i can boot with my amd gpu as primary gpu but there is a greenish virtical stripe on the left side of the screen. Windows auto updates the drivers and causes the same problem again. I turned off the autoupdate, download new drivers, unplug ethernet, install drivers. Sometimes while updating, sometimes after the following reboot, I get the black screen again and I have to start all over. I've tried version 20.1.1, 19.12.2, 19.12.1 and 19.7.3 but none work and I keep getting the same problem. I'm not sure what to do at this point.

i have R9 290 Sapphire also have same problem. Cannot play any game. Also giving black screen while browsering now. It's getting worse

Journeyman III


Journeyman III

ok guys so heres my issue i have an AMD Radeon 570 RX 4 gig. when i launch a game and get a few seconds to minutes into the game the screen will go black but i can still hear the active audio then it pops back on and i can see again. it will also do this at random while i am on a browser. sometimes she really goes hard and changes my screen aspects and ratios to a lower res and smaller screen aspects. it will also on occasion knock me out of full screen mode. i have updated all of the bios and software has also been updated so im not sure as to what it could be that is causing all of these issues but i am out of ideas and would love to get back to gaming as soon as possible so if you guys could help me out a chick would really appreciate it!


Hey  Hypnofrog00

Those symptoms sound very familiar to a cooked card, have  you OC the card at all in its life like with something other than the Radeon programme? If you have try resetting the card to factory sometimes using  MSI after burner works great for this card manufacturer isn't a problem to use this.

If you can do you have a friend that you can test take out and test the card in another machine?

Hope this helps and let us know what the results are.