Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

AMD Radeon Software doesn't open with most recent drivers

Hi, i need some help with a problem that i just can't seem to get around. After upgrading my amd drivers to 21.10.2, Radeon Software stopped opening. It doesn't appear on the system tray and if I try to run it manually, it seems like it's trying to load but ultimately it doesn't boot. The driver itself works fine, i can play games and whatever, but i'm unable to access any feature within the software which sucks.

What i found out is that, if i try to unistall drivers and install an old version ( i tried 20.11.2), the software works normally. If i update to 21.10.2 (and beyond, not even this month release changes anything), the program stops working.

What i tried so far:


1) Unistalling and reinstalling current drivers, using either DDU or AMD cleanup utility.

2) Updating Windows with all the latest updates.

3) Tried editing the registry key

4) Tried deleting the CN folder and reboot. Something that i noticed is that, if i do i clean install of the latest drivers, the CN folder in AppData is empty. If i upgrade drivers from 20.11.2 to 21.10.2, the content of the folder stays there. I don't know if it is supposed to do that.


My System:

Motherboard: MSI h97 Gaming 3 

CPU: Intel i5 4590

GPU; Sapphire rx 480 Nitro 4GB

8 GB DDR3 Ram

OS: Windows 10 64 bit

I really want to fix this issue without being forced to use a more than 1 year old driver.

12 Replies

Is your OS build current, and check device manager to see if MS installed its own driver (instead of 21.10.2) ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..

My Windows build is 21H2, it should be the latest one available. About the device manager thing i checked but i don't know what i'm supposed to look for exactly. Under display drivers, my gpu only appears. I've attached some screenshots for reference (sorry that they are in italian but the images should be pretty self-explanatory anyway).screen3.jpgscreen2.jpgscreen1.jpg 


Perhaps you have disabled the Amd service, there are 3 pcs and they should be in automatic mode. Win + x => Computer Management => Services and Applications and with Service rights. see photo, 3 services. You can also use the Ccleaner utility, in the Tools => Startup section and the Scheduled Tasks tab, all dedicated services should be enabled (Yes) see photo 1photo 1photo 2photo 2


I checked and, as you can see in the images below, i lack some of the AMD services that you have, both from Computer Management and CCleaner. The services that i have are enabled but it seems that i'm missing some of them?screen4.jpgscreen5.jpg


Try to go to the registry editor (win + r), write regedit and input, go to the HKEY_LOCAL_MACHINE \ SOFTWARE \ AMD \ CN and then in the photo you need to delete the driver value, just leave an empty space, everything works for me, so the value of the driver version, see the photo.amd 2.jpg


Tried both with leaving it empty and using the version number in your screenshot, doesn't work either way. I'm probably going to switch to Nvidia for my next gpu, amd drivers are really a mess.


And reboot after Trying to remove the driver through DD or through AMD Cleanup Utility, try using it to remove. 1) download the driver to the video card in advance, then turn off the Internet! run DDU or AMD Cleanup Utility, perform the removal, then restart the PC, do not turn on the Internet! Install the downloaded driver, reboot again, and only after the second reboot turn on the Internet (otherwise Windows itself will start installing something) I hope this guide will help you))


I followed all the steps listed in your post and still nothing. At this point I think that there is something wrong with my OS, maybe something that could be diagnosed through the event viewer but I'm not an expert on that so i don't know.


I had such a problem once, but I deleted the CN folder and the problem was solved, you can of course try to go to the device manager, the video card section, and make a display of hidden devices, there you will have a hidden Intel ® HD Graphics 4600, it seems to delete this device this video card (Intel ® HD Graphics 4600) is an embed in the processor. And try to restart or reboot and restart again)

Well, I had the same issue couple of days ago. The AMD Adrenalin suddenly stopped working and I couldn't bring it to open again.

I tried keyboard shortcuts and the right-menu on the desktop - both didn't work.

I ended up using DDU to remove the software completely and just reinstalled it again.

I am on Windows 10.


BTW thank you i been trying everything in here and the only thing work was like you said i deleted the cn folder that worked now 

my system 5900x 64gigs ahora master elite 570x mb amd r9 390x card

Journeyman III

for windows, I like to use a utility like Glary to clean the registry. My experience, do the Win10 updates, run Glary registry clean, Run the AMD update, run Glary again to check if any junk left in registry. Seems driver changes go smoother this way for me.

Asus Carbon gamer MB PCI 4

16G mem

5600 Ryzen

R580X MSI 4G