Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

AMD Chipset Installer Stuck at 0% + Error 1720

Hi, after a lot of problems trying to install this drivers; 1720 error, stuck at 0% and so on(although it seems to have installed anyway)

I noticed a weird thing when going thru my system and the installer package.

The installer says it installs AMD GPIO Driver But driver in package is Is this an error?

And can we get to choose where to extract the drivers before installing.. I hate it when it forces itself unto C:

Oh, and how can I check what AMD Ryzen Powerplan is installed. Would be nice if the installer told what is already installed.


Checking the GPIO INF file, it says *124 aswell. Only the user is told its *126

1 Solution
Community Manager

This issue should now be resolved in the updated Chipset driver v2.04.04.111 which you can download here

If you continue to experience the same issue with the updated driver, please provide the following information. 

  • • Motherboard make & model: ASUS Prime X370-Pro
    • BIOS version: 5220
    • Graphics card and driver version: Radeon Pro WX 7100 | Driver Radeon Pro Software for Enterprise 20.Q1.1
    • Windows version and build number: Windows 10 Pro build 18363.720
    • Anti Virus installed: Windows Defender
  • Did you uninstall the previous Chipset driver version > restart system > before installing the new Chipset Driver version?
  • A screenshot or description of the error received
  • Please also attach the log output file from the Chipset installer

View solution in original post

100 Replies

Yep, tried that too to no avail, also tried with defender disabled, didn't work, tried using AMDCleanUp in safe mode (the one that comes with Adrenalin drivers) ... Setup_eEVR22oRdJ.jpg

• Motherboard make & model: ASUS Zenith Extreme
• BIOS version: 2001
• Graphics card and driver version: Asus Strix RX580 / Adrenalin 2020 Edition 20.3.1
• Windows version and build number: Windows 10 Pro 1909 build 18363.752
• Anti Virus installed: Windows Defender


Dunno what else to say, maybe if you guys need any kind of log files just tell and I will upload

Adept I

AMD, how long do you need to fix a simple Installer? Are you serious? This says a lot about your "company" omegalul

I also have an error !!! 

Error in amd_software_2.03.12.0657

I have the same problem. The installer stops at 0%. Hope this will be fixed in next version




  • Motherboard: ASRock Fatal1ty AB350 Gaming K4 ||  AMD Ryzen 5 3600 6-Core Processor || Amd socket am4 B350
  • BIOS version : 6.30
  • Graphic Card : Radeon RX 580 GAMING X 8G  ||  Radeon Software ver 20.3.1 (17.03.2020)
  • OS : Windows 10 Pro build 18363
  • Antivirus : Windows Defender(all up to date)
Journeyman III

Suggestion to AMD: provide drivers without installer, just the .inf and correlated drivers to manual installation.

So totally agree... Would probably cut the installer in half or even more size as well.

Journeyman III

I also have an error!!!



System: Windows 10 Pro X64 v1909, Build 18363.752

Anti Virus: Windows Defender

AMD Ryzen 5 3600X 

16 GB Crucial Ballistix 3000MHz ( 2x8GB)

X470 AORUS GAMING 5 WIFI (rev. 1.0) (Bios Version: F50)

GALAX GeForce® RTX 2070 EX White (1-Click OC)


I have a 990FX Chipset motherboard but downloaded the X570 Chipset to see if it will install or not.

Actually, I was trying to locate the Installation .INI file to see if something in there was causing the issue. But this version doesn't use an .INI file after I extracted the AMD CHIPSET.exe file using 7zip.

I remember a couple of years ago, The Chipset was not installing and AMDMATT found that by altering a couple of lines in the .INI file fixed the issue. I thought this would be similar until I found out it doesn't have an INI file. At least one that is visible.

So, I decided to installed the X570 Chipset. The worst, I figured, will be an error saying the X570 Chipset isn't compatible with my 990FX Motherboard. Plus I could always do a Restore Point or restore a System Backup if my computer bricks or Windows has problems.

But to my surprise, it ran without any problem and it showed it updated my AMD SMBUS to the one everyone else has. But like everyone else it showed 0% being installed.

I clicked on the Installation logs once it finished installing the Chipset and it showed this as its final entry:

=== Logging stopped: 3/28/2020  1:52:39 ===
MSI (c) (08:B4) [01:52:39:784]: Note: 1: 1707
MSI (c) (08:B4) [01:52:39:784]: Product: AMD_Chipset_Drivers -- Installation operation completed successfully.

MSI (c) (08:B4) [01:52:39:785]: Windows Installer installed the product. Product Name: AMD_Chipset_Drivers. Product Version: Product Language: 1033. Manufacturer: Advanced Micro Devices, Inc.. Installation success or error status: 0.

MSI (c) (08:B4) [01:52:39:788]: Grabbed execution mutex.
MSI (c) (08:B4) [01:52:39:788]: Cleaning up uninstalled install packages, if any exist
MSI (c) (08:B4) [01:52:39:789]: MainEngineThread is returning 0
=== Verbose logging stopped: 3/28/2020  1:52:39 ===

After I rebooted, My computer booted into Windows without any issues. I then downloaded the correct 990FX CHIPSET and ran that.

While it was installing, it showed a progress bar moving as it installed a USB Filter driver. It reached about 30% of the length of the progress bar before changing the image to tell me the driver was installed successfully. Unfortunately, no Installation log was shown.

I believe if everyone turned in their Installation logs to the Moderators they might be able to see what the problem is. Mine was quite detailed and long. 

I agree with Billy72 that it is a bug in showing the progress of the installation but the actual installation is installing correctly as per the Installation log.

This log appears after the Chipset is successfully installed. My old 990FX showed the progress bar working normally, no bug.

Adept II

this is sad. i'm quickly losing faith in AMD here...

Adept I

Same here. I got the problem in my PC.

Motherboard: ASUS TUF Gaming X570-Plus

Bios : 1405

Graphic Card : 2x Sapphire Radeon RX580 Nitro+ 8 GB Special Edition

OS : Windows 10 Pro 19592.1001

Antivirus: 360 Total Security Essentials ( and Comodo Firewall (121.0.6914)

Adept I

On my system the installer does not even recognize the AMD HW but closes with an error message which says. The precious version of the chipset driver installer works fine.

Adept I

10 Days now without a solution from AMD or a update. Give up your jobs! 

guys 11 days release it's


Release Date


Adept I

AMD released a working fix YEAH!!

xD April fools joke xD

aaahhhhhhhhhhhhhhh  you ruined my day

Journeyman III

Same problem here, stuck at 0% B450

Journeyman III

The road to hell is paved with good intentions...

Same problem.

MSI B450 Gaming Plus (non MAX) + r5 3600


Everyone with this issue needs to report this to AMD: 

Journeyman III

16 DAYS W/O any fixes? Really? Comon guys

Adept II

So for the heck of it, I decided to reinstall one of my computers with the problem, my second rig.

All fresh, first to be installed; mb drivers(0657)... Didn't install at all. Stuck at 0% on 8hours.. Rig is as follows;

Motherboard : MSI Tomahawk B450

Bios (Latest) 7C02v1D - AMD ComboPI1.0.0.4 Patch B (SMU v46.54)

Graphic Card AMD 480

No drivers installed...

Why is the driver install there at all?

Adept I

just an advice: Never, ever buy a AMD Product again and they have to listen! For me, that was the last chance i gave AMD.

I bought an RX 5700XT and it never works, ive changed it to a Nvidia RTX 2070 Super without Problems and so i will do with my CPU!

Its not like nVidia is perfect. I have both and both have given me problems. But by all mean go over to Intel.. I hear they are superb. No security flaws no power hogs etc.. Or wait their filled with security problems and require huge amount of power..


omegalul in a time the government is controlling and watching us you speak of security omegalul 15 Years of Intel and Nvidia Stuff and never got a Problem. 3 Days after i bought AMD it isnt working xD AMD is crap so they are in drivers and single core performance^^ 


Any news? Any AMD representative care to comment on this? 

Journeyman III

I have the same problem. In fact, since the purchase of a new ryzen 3000 processor, I have never been able to properly install or update chipset drivers. Without any problems. Each time an error: "Error opening installation log file. Verify that the specified location exists and is writable." I am very tired of all this. Why they can't make a normal installer?


7 April AMD release fix to chipset driver. Hurray xD


Where did you get that information from?


Not the previous version either? (2xxx)


I didn’t have the previous Ryzen. 3XXX is my first AMD CPU in ~15 years.


I werent thinking on ryzen, last driver had version something ending on 2xxx. Me bad for not making that clear (


Yes, the previous version too. You need to create a new user account and then install the driver. Otherwise installer gives an error "Error opening installation log file. Verify that the specified location exists and is writable."

But when I updating the Nvidia GPU driver there are no such problems, I do not need to create a new account.

Also, games, software, other drivers are installed and updated without any problems. The only problem is updating the AMD chipset drivers.


Wait, what.. What user account?


User account on Windows 10. You need to create new one, then login to this new user account and then update a chipset driver. I read about this method on Reddit and then checked by myself - it works.


For drivers.. So if you have another USER, this user will not have the drivers?


Drivers are installed on the system so they are installed for all users. But for update AMD chipset driver, you need to create a new user account on your system, login to this new user account and then updateOtherwise you get an error "Error opening installation log file. Verify that the specified location exists and is writable."

You can google "amd chipset error opening installation log file" and read about this problem on reddit or even on this forum. So the problem is not only on my system.

Adept I

Is it fixed now ? 


no and they dont will fix it cause they are too noob for it

Journeyman III

The new driver is available :)

Small question, you uninstall the old driver before installing the new one? Or is it not necessary?

If so, how do you uninstall the old driver?


Yeah! Installed Successfully)


I can confirm the new chipset drivers installation worked flawless for me. No uninstall no nothing, just run the installer!

A quick check in the device manager showed no problems, every checked component, e.g. PCI and GPIO drivers, showed the expcected "new" version number installed.

I would give this a careful "good work" AMD for fixing the installation, but with a grain of salt, as the stability of the drivers themselves need to be seen in the next few hours/days. 


Worked fine on my new installed computer. Gonna test it on my main as fast as I'm done watching Awesome Hardware #0222