cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

njackson
Journeyman III

viewport shading

Hi,

I have just installed the latest Blender and the ProRender plugin; however, when I switch to Viewport Shading my meshes only show with grey?

Eevee:

Screen Shot 2019-07-31 at 20.31.37.png

ProRender:

Screen Shot 2019-07-31 at 20.31.47.png

Wondering if I have missed a setting somewhere, tried googling round the problem but no luck as yet.

Hardware and Software:

MacPro 2016 15" i7 2.9Ghz 16 GB ram

Razer Core eGPU

Saphire Radeon Vega 64

Mojave 10.14.6

Blender 2.8 (Official not RC)

ProRender - Latest release (today)

0 Likes
7 Replies
bsavery
Staff
Staff

Re: viewport shading

Can you attach the scene?  

0 Likes
njackson
Journeyman III

Re: viewport shading

Hi, I tested this with the default scene in 2.8, the material is a simple Principle BSDF.

Please find below a link to the blender file

https://drive.google.com/file/d/1dcJOTNQhXi90N49uSflqxy9P6gCNqGwV/view?usp=sharing

Eevee:Screen Shot 2019-08-05 at 08.42.17.png

ProRender:

Screen Shot 2019-08-05 at 08.42.05.png

0 Likes
bsavery
Staff
Staff

Re: viewport shading

Is there any error if you open the Window menu -> Show system console.

0 Likes
njackson
Journeyman III

Re: viewport shading

Hey,

Sorry for the late reply please see the error message below when I switch to the ProRender engine

bpy.data.screens["Layout"].shading.type = 'MATERIAL'
bpy.data.screens["Layout"].shading.type = 'RENDERED'
bpy.ops.transform.translate(value=(-0.0949295, 0.175391, 0.401287), orient_type='GLOBAL', orient_matrix=((1, 0, 0), (0, 1, 0), (0, 0, 1)), orient_matrix_type='GLOBAL', mirror=True, use_proportional_edit=False, proportional_edit_falloff='SMOOTH', proportional_size=1, use_proportional_connected=False, use_proportional_projected=False)
bpy.context.space_data.context = 'MATERIAL'
bpy.data.node_groups["Shader Nodetree"].nodes["Principled BSDF"].inputs[0].default_value = (0.8, 0.0493712, 0.22105, 1)
bpy.data.node_groups["Shader Nodetree"].nodes["Principled BSDF"].inputs[0].default_value = (0.8, 0.0493712, 0.22105, 1)
bpy.context.space_data.context = 'TOOL'
bpy.context.space_data.context = 'RENDER'
bpy.context.scene.render.engine = 'RPR'
Traceback (most recent call last):
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/__init__.py", line 81, in view_update
self.engine.sync(context, depsgraph)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/engine/viewport_engine.py", line 277, in sync
use_gl_interop=config.use_gl_interop)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/properties/render.py", line 361, in init_rpr_context
rpr_context.init(context_flags, context_props)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/engine/context.py", line 45, in init
self.context = pyrpr.Context(context_flags, context_props)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/pyrpr.py", line 327, in __init__
self)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/pyrpr.py", line 65, in wrapped
raise CoreError(status, f.__name__, argv, module_name)
pyrpr.CoreError: RPR call CreateContext(1061889, [0], 1, 1058, <cdata 'void *[]' owning 24 bytes>, b'/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/.core_cache/0x103401', <pyrpr.Context object at 0x11ed78cf8>) returned error code <-23> with error message: ''

location: <unknown location>:-1

Traceback (most recent call last):
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/__init__.py", line 88, in view_draw
self.engine.draw(context)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/engine/viewport_engine.py", line 455, in draw
viewport_settings.export_camera(self.rpr_context.scene.camera)
AttributeError: 'NoneType' object has no attribute 'camera'

location: <unknown location>:-1
0 Likes
njackson
Journeyman III

Re: viewport shading

I tried something else, I completely removed everything Blender, ProRender, Application Support Blender folder and tried this again. It worked the first time I tried to use ProRender with the default cube. However as soon as I went into edit mode things broke again. Below is another trace output.

bpy.data.window_managers["WinMan"].addon_search = "amd"
bpy.context.space_data.context = 'RENDER'
bpy.context.scene.render.engine = 'RPR'
bpy.context.area.ui_type = '<UNKNOWN ENUM>'
bpy.data.screens["Layout"].shading.type = 'RENDERED'
bpy.context.space_data.context = 'MATERIAL'
bpy.data.window_managers["WinMan"].rpr_material_library_properties.materials = '35'
bpy.data.window_managers["WinMan"].rpr_material_library_properties.copy_textures = True
bpy.data.window_managers["WinMan"].rpr_material_library_properties.copy_textures = False
bpy.context.space_data.context = 'RENDER'
bpy.context.space_data.context = 'SCENE'
bpy.context.space_data.context = 'VIEW_LAYER'
bpy.context.scene.enable = True
bpy.ops.object.editmode_toggle()
Traceback (most recent call last):
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/__init__.py", line 81, in view_update
self.engine.sync(context, depsgraph)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/engine/viewport_engine.py", line 277, in sync
use_gl_interop=config.use_gl_interop)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/properties/render.py", line 361, in init_rpr_context
rpr_context.init(context_flags, context_props)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/engine/context.py", line 45, in init
self.context = pyrpr.Context(context_flags, context_props)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/pyrpr.py", line 327, in __init__
self)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/pyrpr.py", line 65, in wrapped
raise CoreError(status, f.__name__, argv, module_name)
pyrpr.CoreError: RPR call CreateContext(1061889, [0], 1, 1058, <cdata 'void *[]' owning 24 bytes>, b'/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/.core_cache/0x103401', <pyrpr.Context object at 0x120243390>) returned error code <-23> with error message: ''

location: <unknown location>:-1

Traceback (most recent call last):
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/__init__.py", line 88, in view_draw
self.engine.draw(context)
File "/Users/nicj/Library/Application Support/Blender/2.80/scripts/addons/rprblender/engine/viewport_engine.py", line 455, in draw
viewport_settings.export_camera(self.rpr_context.scene.camera)
AttributeError: 'NoneType' object has no attribute 'camera'

location: <unknown location>:-1

0 Likes
njackson
Journeyman III

Re: viewport shading

As a side note, I also added a texture from the Material Library, again this did display until edit mode.

0 Likes
njackson
Journeyman III

Re: viewport shading

Ok, so I have figured how to temporarily fix this, the first image below has ProRender working correctly in the viewport. I had to select the built in GPU on my mac in addition to my eGPU to get this to work. It will work with just the built in GPU but not just the eGPU. You can see from activity monitor that changes to the viewport are using both GPUs. However the built in card is much less powerful and when both are enabled it actually slows the rendering down. Note: Using separate viewport preview devices or main settings for the render devices does not make a difference. I was just experimenting here.

Screen Shot 2019-08-09 at 08.21.46.png

This image shows the same scene but with only the eGPU enabled, as you can see nothing is rendered in the viewport.

Screen Shot 2019-08-09 at 08.22.09.png

Changes to the GPU settings int he render tab only take effect after toggling between Solid and Shaded

Kind regards,

Nic

0 Likes