cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

fcgrreat
Adept I

Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

Dear all, I have an external EGPU Vega64 with my MacBook Pro (with discrete graphics AMD560X).

in blender 2.8 ...If I try to render (or viewport rendering) only on my Vega 64, the view port remains transparent. no rendering at all.

If I enable the rendering both on my Vega64 and on my 560X it works fine, and both GPU works at 100%.

I'd like to exclude the discrete graphics from rendering in order not to warm too much my Mac.

Is this a bug or something intended?

best regards

0 Kudos
1 Solution

Accepted Solutions
bsavery
Staff
Staff

Re: Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

Hey, good question.  The issue here is actually where the OpenGL viewport is being displayed.  For viewport rendering we send the viewport directly from RPR (rendering in OpenCL or Metal in this case) and then sends it directly to OpenGL for display.  If you're rendering on you eGPU and display is on the internal GPU for the viewport this gets weird.

If you look in the addon folder there is a file there called config.py.  You want to change the line in there:

use_gl_interop = True

set that to 
use_gl_interop = False

View solution in original post

0 Kudos
6 Replies
bsavery
Staff
Staff

Re: Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

Hey, good question.  The issue here is actually where the OpenGL viewport is being displayed.  For viewport rendering we send the viewport directly from RPR (rendering in OpenCL or Metal in this case) and then sends it directly to OpenGL for display.  If you're rendering on you eGPU and display is on the internal GPU for the viewport this gets weird.

If you look in the addon folder there is a file there called config.py.  You want to change the line in there:

use_gl_interop = True

set that to 
use_gl_interop = False

View solution in original post

0 Kudos
fcgrreat
Adept I

Re: Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

Yes, that fixed the problem, in my humble opinion by default if I select only one GPU it should tweak automatically that parameter!

great work!

0 Kudos
bsavery
Staff
Staff

Re: Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

It's hard to say really.  IF that one GPU selected is the OpenGL device or not is the question.  We have no way of detecting that though...

0 Kudos
fcgrreat
Adept I

Re: Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

It doesn't work anymore in blender 2.81 and RPR 2.1... it crashes instantly after switching to rendering viewport (OS X Catalina) 😞

0 Kudos
bsavery
Staff
Staff

Re: Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

Thanks.  We have a fix.  If you want to edit a quick file to change it for now here's a workaround if you can edit a python file:

in engine/viewport_engine.py
line 590 should be something like
def _get_render_image(self): return self.rpr_context.get_image()
change that to
def _get_render_image(self):
   with self.render_lock:
      return self.rpr_context.get_image()
0 Kudos
j3s
Adept I

Re: Vega 64 egpu macOS blender. Not rendering alone

Jump to solution

fix doesn't work ;( 

0 Kudos