cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

xrendr
Journeyman III

Support for Blender 3.0+ with HIP FOR RX580

I want Blender HIP FOR RX580 ! I can't use Blender 3.0 with RX580, such a shame, if they do not support HIP for RX580 i will never buy and AMD GPU again.

0 Likes
5 Replies
ripcord
Adept II

Re: Support for Blender 3.0+ with HIP FOR RX580

Sorry to hear that, keep in mind that the RX 580 is 5 years old now but still not an unreasonable request. As I use Blender from time to time, it would be nice to be able to use the most current version with my RX 580 as well.

Ryzen 5 2600x, Radeon RX 580, MSI B450 Tomahawk Max II 32Gb.
0 Likes
arozghon
Challenger

Re: Support for Blender 3.0+ with HIP FOR RX580

Hi, that's so interesting decision and talk about shame to AMD for not supporting new technologies for old GPU, do you make the same request for Nvidia about dlss support for 1080GTX or 980GTX?

Now AMD working on support for more architectures, not only RDNA or RDNA2, and for this need to hard work not from the AMD side, also need to update HIP from the Blender side.

if you need the same performance as HIP have, pls, use Radeon Pro Render - almost the same performance and quality, also supported almost all Cycles features. 

Have a good day and happy renders

0 Likes
arozghon
Challenger

Re: Support for Blender 3.0+ with HIP FOR RX580

Nvidia support all GPU with CUDA cores, DLLS - with RT cores only, HIP is a new technology, and support for elder GPUs will be available later when it renders will be stable on GPU without hardware ray tracing support and this process not for a few days or weeks, so follow to the update

0 Likes
piradian
Journeyman III

Re: Support for Blender 3.0+ with HIP FOR RX580

10 years old graphic cards from NVIDIA still get support but a 5 years old card from AMD is a no?

0 Likes
undeadbobop
Journeyman III

Re: Support for Blender 3.0+ with HIP FOR RX580

AMD doesn't control blender, you will have better luck with telling nvidia to try to get opencl back in blender since they cut it to kill off the amd prorender to promote Nvidia.  Blender is very pro-nvidia and spouts what ever is popular for the fan boys to state about AMD GPU's. Nvidia has more control over blender than AMD and Intel does and its pretty closed off from both in its current state with the complete cutting of OpenCL and killing off dozens and dozens of opencl based renders from years past. Even on 6000 GPU's there is a plethora of issues due to blender cutting support from opencl and rushing out HIP, which doesn't even work on all 6000 gpu's not to mention linux, not to mention now you have no render on oddware hardware running linux. AMD Has no control over the lack luster control of HIP implementation that the blender foundation is doing, and the person in charge of HIP in blender is a diehard nvidia fanboy spouting fallacies left and right. So good luck getting anything good out of blender while he is incharge of implementing HIP, He is litterally telling people to wait for HIP-RT and that he won't implement it unless AMD fix their drivers, when he can't come up with a single issue other than blaming all his software development issues on AMD.

0 Likes