cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

KyleNap
Journeyman III

ProRender & Blender 3.0

Screen Shot 2021-12-09 at 2.18.48 PM.png

Has anyone received this message in Blender 3.0 when trying to render with ProRender in the viewport or Rendering tab? ProRender still works completely fine in Blender 2.93. I’m using version 3.3.0 of ProRender. Nothing seems to render at all in Blender 3.0 with ProRender. I'm using macOS 12.0.1. 

0 Likes
3 Replies
threVerht
Journeyman III

Re: ProRender & Blender 3.0

I get the same error. The render is not working.

0 Likes
FireAngel
Adept I

Re: ProRender & Blender 3.0

Currently Pro Render works in Blender versions up to 2.93.x

Work is underway to make it work in Blender 3.0.x and you can download a pre-release version from the Pro Render Weeklies page, link below.  As it is a pre-release version it may be unstable, but if you don't mind helping the developers you can download it and report any bugs through the usual process.

https://github.com/GPUOpen-LibrariesAndSDKs/RadeonProRenderBlenderAddon/releases

futurefaxer
Journeyman III

Re: ProRender & Blender 3.0

I have found that RPR works perfectly with 3.0 as long as you're using an RDNA2 GPU. Using the Ampere GPU on my work computer, I had to roll back to Blender 2.8 because of the need for OpenCL.

0 Likes