cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

Highlighted
Adept I
Adept I

Mac eGPU Blender 2.9 constant crashing

Jump to solution

I just set up a new 5700 XT in a Razor Core X Enclosure and I'm not able to use Prorender with it at all. It Crashes shortly after launch. Sometimes, I'm able to navigate with viewport render (which is nice and fast), and then it goes down. I'm never able to use it for more than 1 minute. I have the external 5700 set up as the only render hardware. I've tried other combinations and there wasn't a change. I tried the latest 2.8.x and the Prorender beta with similar or even worse results.

I've tried loopback with the internal displace and only though the GPU with my monitor connected to the card directly. 

There are no issues with the internal GPU (5500m) in either Mac or Windows. I'm not able to get my egpu working in Windows, so I can't test there.

Here's the MacOS error log from the last crash a few minutes ago blender-prorender-egpu-crash.txt · GitHub 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Staff
Staff

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

Are you crashing in final renders or viewport?  If you're using the viewport render with eGPU you need to disable the "GL Interop" setting in the viewport settings.

View solution in original post

0 Kudos
16 Replies
Highlighted
Adept I
Adept I

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

I tried to use Optane X for Mac/Blender and it crashes as well. I'm starting to think I have a defective card.

0 Kudos
Highlighted
Staff
Staff

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

Are you crashing in final renders or viewport?  If you're using the viewport render with eGPU you need to disable the "GL Interop" setting in the viewport settings.

View solution in original post

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

Same here. 5700 XT/ Razor Core X Enclosure. Can't even get to final renders because it crashes so quickly.  GL interop is disabled everywhere I can find it.  RPR is unusable.

0 Kudos
Highlighted
Staff
Staff

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

Which version of the plugin do you have?  (There is no 2.8.X version of the blender plugin, should be somethingl like 2.5.X)

Also if you can start Blender from the terminal by running 

/Applications/Blender.app/Contents/MacOS/Blender

and grab the crash output from there that would be helpful.

Thanks

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

RPR 2.4.11., Blender 2.90.0.

Output from blender.crash.txt:

# Blender 2.90.0, Commit date: 2020-08-31 11:26, Hash 0330d1af29c0bpy.context. - Pastebin.com 

0 Kudos
Highlighted
Staff
Staff

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

Sorry, that wasn't exactly what I was asking for, can you paste the test readout from the terminal if you run the above command?  Also there are updated builds here:  Releases · GPUOpen-LibrariesAndSDKs/RadeonProRenderBlenderAddon · GitHub 

0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

installed 2.5.1. Still crashing. This is everything from the terminal.

2020-09-14 16:11:53.948 Blender[43721:519164] apply_selection_policy_once: prefer use of removable GPUs (via org.blenderfoundation.blender:GPUSelectionPolicy->preferRemovable)
found bundled python: /Applications/Blender.app/Contents/Resources/2.90/python
Registered Animation Nodes
2020-09-14 16:11:55,229 INFO rpr.engine.init [4896071104]:  RPR Core version: 1.35.4 build 0x5f0522b2
2020-09-14 16:11:55,305 INFO rpr.engine.init [4896071104]:  Image Filters version 1.5.4 build 0x5d31e03
2020-09-14 16:11:55,322 INFO rpr.default [4896071104]:  rprsdk_bin_path: /Users/mpm/Library/Application Support/Blender/2.90/scripts/addons/rprblender
2020-09-14 16:11:56,628 INFO rpr.material_library [4896071104]:  Material library located at /Users/Shared/RadeonProRender/MaterialLibrary/2.0.0/Xml
Writing: /var/folders/7z/3592vmhx0hx35jpnz580fq_80000gn/T/blender.crash.txt
Segmentation fault: 11

0 Kudos
Highlighted
Adept I
Adept I

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

My crashes are happening in the Viewport

Blender 2.9.0

ProRender 2.4.11

GL Interop disable in the render sidebar

Crash log - prorender-crash.txt · GitHub 

From the terminal

2020-09-14 16:32:16.011 Blender[64749:629392] apply_selection_policy_once: prefer use of removable GPUs (via org.blenderfoundation.blender:GPUSelectionPolicy->preferRemovable)
UpdateRecents: about to call HIS_XPC_GetApplicationPolicyForURLs with seed 1115540851
UpdateRecents: received results from HIS_XPC_GetApplicationPolicyForURLs
UpdateRecents: ignoring results because menu isn't open
UpdateRecents: about to call HIS_XPC_GetApplicationPolicyForURLs with seed 1115540851
UpdateRecents: received results from HIS_XPC_GetApplicationPolicyForURLs
UpdateRecents: ignoring results because menu isn't open
UpdateRecents: about to call HIS_XPC_GetApplicationPolicyForURLs with seed 1115540851
UpdateRecents: received results from HIS_XPC_GetApplicationPolicyForURLs
UpdateRecents: ignoring results because menu isn't open
UpdateRecents: about to call HIS_XPC_GetApplicationPolicyForURLs with seed 1115540851
UpdateRecents: received results from HIS_XPC_GetApplicationPolicyForURLs
UpdateRecents: ignoring results because menu isn't open
TIFFFetchNormalTag: Warning, Incompatible type for "RichTIFFIPTC"; tag ignored.
objc[64749]: GFX10_MtlComputeCmdEncoder object 0x7fd9c74ab400 overreleased while already deallocating; break on objc_overrelease_during_dealloc_error to debug
objc[64749]: GFX10_MtlComputeCmdEncoder object 0x7fd9c7aeac00 overreleased while already deallocating; break on objc_overrelease_during_dealloc_error to debug
objc[64749]: GFX10_MtlComputeCmdEncoder object 0x7fd94685b800 overreleased while already deallocating; break on objc_overrelease_during_dealloc_error to debug
objc[64749]: GFX10_MtlComputeCmdEncoder object 0x7fd8f56a8200 overreleased while already deallocating; break on objc_overrelease_during_dealloc_error to debug
objc[64749]: GFX10_MtlComputeCmdEncoder object 0x7fd9a53c4200 overreleased while already deallocating; break on objc_overrelease_during_dealloc_error to debug
[1] 64749 segmentation fault

0 Kudos
Highlighted
Adept I
Adept I

Re: Mac eGPU Blender 2.9 constant crashing

Jump to solution

The scene I've been trying is the BlenderGuru donut tutorial were I've been moving the materials to ProRender. So it has a mix of RPR shaders/materials and native Blender ones. It does work fine on the 5500m dgpu, but not on the egpu. 

I installed the latest ProRender 2.5.3 from the github repo and have made a simple scene with materials from the ProRender material library and it hasn't crashed yet. I'm starting to think that it's something in my scene from the mix of material types. Is that a possibility?

0 Kudos