cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

gelert
Elite
Elite

Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

macOS 10.13.6

Blender 2.79b

RPR 1.7

Single eGPU set as rendering unit: WX 9100 in 650W eGPU

Production render = blank.

Viewport Render = all black.

Sample file and screenshot attached.

0 Kudos
1 Solution

Accepted Solutions
gelert
Elite
Elite

Re: Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

In version 1.7.239 Denoise Rendering is working on GPU very well. I've not had any black screens or crashes related to Denoise so far. I'm weary of it but I rendered a whole animation with it turned on no issue at all.

View solution in original post

6 Replies
bsavery
Staff
Staff

Re: Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

Is there any error to go along with this?

0 Kudos
gelert
Elite
Elite

Re: Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

No Errors whatsoever just a black render like the screenshot.

Still does it today - I just tested it.

Doesn't matter how many eGPUs or dGPUs I throw at it. I've tried it with just dGPU and just a single eGPU and dual eGPU - black box instead of a render.

Denoise on = black render with no error and no crash.

0 Kudos

Re: Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

I'm getting the exact same result. I have the same software/OS setup except a Vega 64 in my Sonnet 650W box. One thing I've noticed is that when Denoise is ticked, RPR uses all available GPU's to render - even if they're not ticked in the 'Final Render Device' box. I can see this when I monitor the GPU activity. When I untick Denoise, it uses only the selected GPU's and renders out an actual image.

0 Kudos

Re: Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

I've just opened up the Barcelona Pavilion test scene to test out the latest RPR 1.7.212

I simply opened the scene and hit the render button, and it works.

Then I turn on RPR Denoise and it still doesn't work - except I haven't got a black screen anymore - slight improvement, but still obviously a bug.

I get no error messages.

See attachment.Barcelona_Pavillion.jpgBarcelona_Pavillion_Denoised.jpgScreen Shot 2018-09-01 at 12.55.58.png

0 Kudos
gelert
Elite
Elite

Re: Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

In version 1.7.239 Denoise Rendering is working on GPU very well. I've not had any black screens or crashes related to Denoise so far. I'm weary of it but I rendered a whole animation with it turned on no issue at all.

View solution in original post

admin
Adept II
Adept II

Re: Denoise Rendering All Black scenes in RPR v1.7 Mac

Jump to solution

the same here, on Blender for Windows, denoiser is giving a black result in the viewport test.

0 Kudos