cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

rhuber423
Journeyman III
Journeyman III

Blender world background covering model

Issue rendering with RPR in Blender 2.8.75.

ProRender ver  2.0.112

Windows 10
pastedImage_1.png

I have no idea what other information I can/should supply.

I made no changes to the settings at first but did start making changes in settings

without success of fixing this issue.

As you can see in the images below, the world background (HDRI) is covering the model. 

This happens while rendering and viewport rendering.

This also happens when not using an image for the background. 

pastedImage_3.png

pastedImage_4.png

Here is an incomplete render showing how the model starts getting covered up with the background.

If I let the render complete, the entire model gradually gets covered up.

pastedImage_5.png

pastedImage_7.png

0 Kudos
6 Replies
arozghon
Challenger
Challenger

Re: Blender world background covering model

Hi! Could you add a scene for the current bug? And also will try to reproduce with the current bug with RPR 2.0.153, you can download the latest RPR plugin here: Full Spectrum Rendering in Radeon ProRender for Blender  . Thank you

0 Kudos
rhuber423
Journeyman III
Journeyman III

Re: Blender world background covering model

By asking me to "add a scene for the current bug" do you mean a .blend file? I would but, I have this issue with every file I open. Also, this issue happens with a new file. But if you really need a .blend file after reading the following, you're going to have to tell me how to attach a file since I do not see a button for attaching a file in a comment.

So, after going through the headache of uninstalling RPR v 2.0.112 first than trying to install v 2.0.153 I find out that the new version cannot be installed because it wants to uninstall the old version but can't.


Learning this info after uninstalling the old version is not fun. I had to do a system restore which took forever until I realized that my antivirus was keeping the system restore from working properly. After getting the system restore to actually restore, I had to uninstall my antivirus and reinstall it because the system restore messed it up.(Don't ask my how.)

Now that my system is back to right after installing RPR v2.0.112 I can install RPR v2.0.153.

So I did that.

  • Installed RPR v2.0.153 (Clean install)
  • Launched Blender
  • Opened Blender Preferences
  • Clicked to activate RPR addon
  • Blender immediately crashes...

I uninstalled all user addons except RPR and Blender still crashes upon activating RPR addon.

I don't know if this has anything to do with this but, I am not using an "installed" Blender. I am using the version that is downloaded as a Zip file.

0 Kudos
arozghon
Challenger
Challenger

Re: Blender world background covering model

Thank you for your answer. All new information about your issues with RPR will be transferred to developers. Could you add system information (OS version, AMD Driver version, CPU and GPU name, antivirus name)? And if you get background issue with all scenes .blend file not necessary. Thank you

0 Kudos
arozghon
Challenger
Challenger

Re: Blender world background covering model

Also, please try to install the latest AMD drivers to activating RPR 2.0.153 in blender

0 Kudos
rhuber423
Journeyman III
Journeyman III

Re: Blender world background covering model

Installed latest AMD drivers.

pastedImage_1.png

pastedImage_5.png

pastedImage_6.png

pastedImage_7.png

Can now activate addon but background issue still persists.

pastedImage_4.png

Let me know if you need any more information.

0 Kudos
arozghon
Challenger
Challenger

Re: Blender world background covering model

Thank you for details. That's will help devs fix this issue 

0 Kudos