cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

esbuser
Journeyman III

Blender 2.80 (Latest Official Release) crashes when I try to Activate ProRender (Latest Official Release)

Operating System:

Edition:  Windows 10 Home 64-bit

Version:  1903

Installed on:  8/8/2019

OS build:  18362.267

Hardware:

Acer Aspire TC-885

CPU:  Intel Core i5-8400 2.80GHz

GPU:  Radeon WX 4100 (Installed yesterday morning)

HD:  Toshiba 2.0T

RAM:  12.0 GB

Software:

Blender 2.80?:  (latest official release as of yesterday)

ProRender version:  ? (latest official release as of yesterday two hours ago , no "about" section that I can find on Blender Plug-in)

Ok, this is a two part story, the 1st being a separate issue, but I'll cover it as briefly as I can in case it has bearing on the 2nd (Blender crashes when I try to activate the ProRender Add-in).

TIMELINE:

(Pre Windows 10 update)

Day before yesterday pm I received and installed a new Radeon WX-4100, downloaded what I thought was the appropriate Radeon Pro Software and drivers.  The drivers loaded, but the software would not.  After several attempts of uninstalling and reinstalling the Enterprise version and standalone version, no success, no way to setup the GPU.  To take a break, I downloaded and installed ProRender for Blender Add-in (latest version) to see if the GPU made a difference in rendering.  With the GPU and drivers installed, I opened a file in Blender 2.80 (Latest Official Version), everything worked as expected using ProRender for several renders, but then I initiated a render and the working indicator continued unusually long and Blender had stopped responding, so I had to ctl alt del out.  It was late so I quit.

Yesterday, I resumed uninstalling and reinstalling the Radeon Pro Software, finally calling customer support for help.  I received instructions on updating the system Bios, Chipset and uninstalling the Radeon Pro Software with a 3rd party app and finally, updating Windows 10 to the latest release.

(Post Windows 10 update)

I completed all of the updates and completed a clean install of the ProRender for Blender Add-in (latest version).  I opened Blender again, attempted to activate the add-in and Blender instantly closes (see video clip).  Numerous attempts after uninstalling and reinstalling ProRender for Blender Add-in (latest version) yield the same result.  (definition of an idiot proven here).

I did as a last resort download the Beta version of the Radeon Pro Software and drivers, which I found as a footnote hyperlink on the download page, and viola, the GPU setting software installed and everything on that end is now fixed, but Blender is still an issue, even today, up until a couple of hours ago, after multiple uninstalls and re-installs of ProRender and Blender (idiot again), I still get the crash, so I'm lost....

I guess the big question is, is the latest official release of ProRender for Blender Add-in (downloaded Friday, ‎August ‎9, ‎2019, ‏‎1:42:01 PM) compatible with the latest official release of Blender 2.80 (downloaded 8/6/2019, 7:07 PM)??

Footnote:  The Radeon WX-4100 GPU is NOT supported in ProRender for Blender Add-in.  Could that be the problem?  It seems a lot of other people are having issues with supported GPU's as well.

Also, about every 1/2 hour or so, a ProRender for Blender install error message keeps popping up on the screen (see attachment).  Message appears with or without Blender being open, Add-in installation finished 2 hours ago, I thought.

Any help would be appreciated.

ESBuser

0 Likes
3 Replies
anyeos
Journeyman III

Re: Blender 2.80 (Latest Official Release) crashes when I try to Activate ProRender (Latest Official Release)

I have Ubuntu 19.04 and it crash too with SIGSEGV when I try to use ProRender engine in Blender 2.80 final downloaded from official site.
I have the OpenCL gpu part installed and working on cycles without apparent crash.

0 Likes
bsavery
Staff
Staff

Re: Blender 2.80 (Latest Official Release) crashes when I try to Activate ProRender (Latest Official Release)

Hi John.   I don't want to shift the blame but this sounds like a driver problem.  If you were doing a few renders that worked and it isn't know...

One thing you could try doing is launching Blender from the command terminal and see if there's some error reported there.

0 Likes
esbuser
Journeyman III

Re: Blender 2.80 (Latest Official Release) crashes when I try to Activate ProRender (Latest Official Release)

I have worked through the problems I experienced and everything is working correctly now.

Here is what I figured out.  Although the installation instructions say you need to install the material library, it doesn't indicate that the Add-in will not work if you don't install it before you attempt to register the add-in in Blender.  After many hours of trial and error, again, installing and reinstalling, as a last resort I installed the material library and attempted to activate the add-in, this time I registered without a problem.  I must have initially installed the library when I had it working earlier.  When the render that hung up blender and I had to Ctl Alt Del to get out, Blender would no longer start.  After a fresh install of Blender, I was then able to open it and use it as intended, but in my haste to install ProRender, I failed to re-install the Material Library, which triggered the series of not activating the add-in and causing Blender to crash everytime I attemped it.  The guys at AMD need to point out in the instructions that the Material Library MUST be installed prior to activating the ProRender Add-in for novices like me.

Corrections to my 1st Post:

Although the Radeon Pro WX 4100 GPU is not listed, the compatibility listing states that the WX family is.

There is an "about" section for the ProRender Add-in in the Add-in Dropdown.  My novice status prevails again.

Hope this helps anyone experiencing simular problems.

Thanks to all that replied.

ESBuser

0 Likes