cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

allesdings
Journeyman III

Anyone having an error when rendering with ProRender in Blender with the Blackmagic egpu for Mac? It doesn't create anything. It says Check error log for details.

Using egpu from Blackmagic with blender. It has the amd radeon pro 580.

0 Likes
5 Replies
bsavery
Staff
Staff

Re: Anyone having an error when rendering with ProRender in Blender with the Blackmagic egpu for Mac? It doesn't create anything. It says Check error log for details.

Can you go to the log and check the error?  You might have to click on the window menu -> Show System console

0 Likes
allesdings
Journeyman III

Re: Anyone having an error when rendering with ProRender in Blender with the Blackmagic egpu for Mac? It doesn't create anything. It says Check error log for details.

I run blender from the terminal. I don't know if it is this what you need.

2018-08-23 23:18:03,731 INFO rpr.core_image_cache [123145359495168]:  CoreImageCache(original): image_size=None, contexts number=0

2018-08-23 23:18:03,731 INFO rpr.core_downscaled_image_cache [123145359495168]:  CoreImageCache(downscaled): image_size=None, contexts number=0

libc++abi.dylib: terminating with uncaught exception of type FrException: TahoeContext: compile failed //// TAHOEERROR: BVH GPU memory allocation failed

Abort trap: 6

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

[Prozess beendet]

0 Likes

Re: Anyone having an error when rendering with ProRender in Blender with the Blackmagic egpu for Mac? It doesn't create anything. It says Check error log for details.

I have two eGPU's of which one is the Blackmagic eGPU and it 'works fine' with the other one which is a Vega 64. I say 'works fine' because at the moment RPR for Blender is a bit temperamental to say the least. Blender sees the BM 580 and during renders it plays a part according to my GPU activity monitor. When you say "It doesn't create anything", do you have a black image in your image editor after the render? I have had that happen a few times the past few days, but if I click the red, green and blue colour channel buttons, I actually see the individual RGB channels... just no combined image.

0 Likes
bsavery
Staff
Staff

Re: Anyone having an error when rendering with ProRender in Blender with the Blackmagic egpu for Mac? It doesn't create anything. It says Check error log for details.

Can you attach the scene so we can test it?

0 Likes

Re: Anyone having an error when rendering with ProRender in Blender with the Blackmagic egpu for Mac? It doesn't create anything. It says Check error log for details.

I just want to say that I think my Blackmagic eGPU is working fine with RPR in Blender. I think the issues I've been bumping into aren't related to the BM eGPU. I'm not getting any error messages when I render using the BM eGPU like @allesdings is experiencing. I'll run a few tests later and report any weird behaviour with specific scenes.

0 Likes