cancel
Showing results for 
Search instead for 
Did you mean: 

Blender Discussions

vitos23
Journeyman III

AI Denoiser doesn't work

OS: Windows 10 Pro 2004

Software: Blender 2.82

ProRender Version: 2.4.11 (same error with 2.13)

Hardware: RTX 2080 + Ryzen 2700X

Issue: AI Denoiser cause an error so denoising doesn't work. With RPR 2.13 and AI Denoiser Blender crashes after rendering (when denoising).

Log from Blender console:

[ERROR@RIF]: File not found: C:\Users\╨Т╨╕╤В╨░╨╗╨╕╨╣\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\data\models/denoise_c3_hdr.pb at file C:\JN\WS\RadeonProImageProcessor_Build\src\AIFilters.cpp line 214
2020-05-14 14:51:56,263 ERROR rpr.init [17460]: RIF call ContextExecuteCommandQueue(<pyrprimagefilters.ContextOpenCL object at 0x00000194A8F71748>, <pyrprimagefilters.CommandQueue object at 0x00000194A8F71588>, <cdata 'void *' NULL>, <cdata 'void *' NULL>, <cdata 'void *' NULL>) returned error code <-22> with error message: '' EXCEPTION: Traceback (most recent call last):
File "C:\Users\╨Т╨╕╤В╨░╨╗╨╕╨╣\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\__init__.py", line 130, in render
self.engine.render()
File "C:\Users\╨Т╨╕╤В╨░╨╗╨╕╨╣\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\engine\render_engine.py", line 300, in render
self._render()
File "C:\Users\╨Т╨╕╤В╨░╨╗╨╕╨╣\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\engine\render_engine.py", line 147, in _render
self.image_filter.run()
File "C:\Users\╨Т╨╕╤В╨░╨╗╨╕╨╣\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\engine\image_filter.py", line 105, in run
self.command_queue.execute()
File "C:\Users\╨Т╨╕╤В╨░╨╗╨╕╨╣\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\pyrprimagefilters.py", line 347, in execute
ContextExecuteCommandQueue(self.context, self, ffi.NULL, ffi.NULL, ffi.NULL)
File "C:\Users\╨Т╨╕╤В╨░╨╗╨╕╨╣\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\rprblender\pyrpr.py", line 78, in wrapped
raise CoreError(status, f.__name__, argv, module_name)
pyrpr.CoreError: RIF call ContextExecuteCommandQueue(<pyrprimagefilters.ContextOpenCL object at 0x00000194A8F71748>, <pyrprimagefilters.CommandQueue object at 0x00000194A8F71588>, <cdata 'void *' NULL>, <cdata 'void *' NULL>, <cdata 'void *' NULL>) returned error code <-22> with error message: ''

Tags (2)
0 Likes
6 Replies
arozghon
Challenger

Re: AI Denoiser doesn't work

Thank you for request. Few questions: do you use a single device or CPU+GPU with AI Denoiser? Did you try to denoising with RPR ML\EAW\LWR\Bilateral denoiser? did that issue reproduce with all scenes or with specific scenes? Thank you

0 Likes
vitos23
Journeyman III

Re: AI Denoiser doesn't work

Well, I use only GPU. Other denosing algorithms work fine. This issue reproduces with all scenes, even with "initial cube"

0 Likes
arozghon
Challenger

Re: AI Denoiser doesn't work

Thank you for the additional information.

0 Likes
vitos23
Journeyman III

Re: AI Denoiser doesn't work

I solved the problem! This error occurs if path to AI model (denoise_c3_hdr.pb) contains cyrillic symbols. It will be awesome if you fix this bug. Thanks in advance.

0 Likes
hardcoregames_
Big Boss

Re: AI Denoiser doesn't work

vitos23 wrote:

I solved the problem! This error occurs if path to AI model (denoise_c3_hdr.pb) contains cyrillic symbols. It will be awesome if you fix this bug. Thanks in advance.

Lots of problems with RU users of a ton of other programs that are not Unicode aware

Georgiy
Journeyman III

Re: AI Denoiser doesn't work

Please test it one more time. It should works now.

0 Likes