AnsweredAssumed Answered

r9 290 bricked after 17.2.1 update?

Question asked by elodea on Feb 25, 2017
Latest reply on Feb 27, 2017 by elodea

Hi, hoping someone can help me with this issue i'm having.


Been using an r9 290 for ~3 years with no problems. Usually when I update drivers I do so manually by downloading from the support page etc. This time it popped up randomly with a prompt for me to update and so I did. Once completed, I left the pc on for a few hours, then manually restarted. On booting up however, nothing would show up on the monitor as if i had never turned it on. The motherboard error codes showed that everything was posting fine, and the gpu fans were running like normal.


Tried switching the bios from unlocked to locked with no luck.


Put an old 5870 into the same pci-e slot and it boots up fine to windows with stuff showing on monitor so it doesn't seem to be a bad slot.


When I put both cards in and ran the output from the 5870 to see what was going on, gpu-z and device manager only showed the 5870. Also tried using atiwinflash -i [slot] to see if the 290 was being recognised and it would return a "no adapter" error. As such, I can't seem to even flash it with a backup bios to see if it's a bios issue.


Any ideas? This has had me pulling my hair out for an hour now. Even if a driver install somehow borks up, it shouldn't brick the gpu should it?