cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

vugino
Journeyman III

Troubleshooting a new setup: won't power up when CPU plugged in

I am building a new setup. This is the fourth setup I have ever built, and my second AMD setup. (Find setup specs below) All pieces are brand new.

I was very happy when after doing the whole installation I saw the following: all fans rotating, including case fans, power supply fans, radiator fans, graphic card fans. All RGB functioning, including water-cooling pump, power supply, fans, and RAM RGB.

However, there was no post, and computer didn't stop by holding power button, so I stopped at the power supply and went ahead with troubleshooting. I've followed the steps I found here to try troubleshooting: Troubleshooting Guide on Tommshardware Forum 

I immediately noticed that the no CPU connector was plugged in. I plugged the 8-pin connector in, and read everywhere that there was no point plugging the additional 4-pin connector (furthermore I don't owe one so didn't try). At that point I put the power supply switch back on, and tried turning the computer on again. I have nothing turning on now, no post, no RGB, no fan, no nothing.

Tried unplugging the 8-pin CPU connector, and after like 30 seconds the fans and RGB can be started again (with the little red LED next to the connector on the motherboard then lighting up to warning me that it is not on).  Each time I try plugging the 8-pin connector, won't turn on, unplug it it works.

I did already check, the processor is properly put, with the little arrow in the corner matching the little arrow in the corner in the socket, the processor slides in easily, I put the little lever back down, and the water-cooling pump is screwed in nicely and tightly on top of it with the factory thermal compound sheet there.

Does anyone have any idea that might help me? I don't know where to go from here. Thank you for your help.

Setup:

Case: Xigmatek Aquarius Plus Queen

Motherboard: ASUS ROG STRIX B550-A GAMING

Graphics card: Nvidia GeForce RTX 3080 Ti

CPU: AMD Ryzen 9 5900X Wraith Stealth

Water-cooling : Corsair iCUE H150i ELITE CAPELLIX Watercooling

RAM: G.Skill Trident Z Neo 4*16Go

SSD: M.2 NVMe PCIe 4.0 2To Samsung 980 Pro

Power supply: Enermax MARBLEBRON 850 Watts RGB - White

0 Likes
4 Replies
vialli100
Miniboss

If you have 4 x ram try it with 1 x in each slot, then try with 2 in the dual channel setup..

If you only have 2 ram then try taking one out and trying the other..

You could also download the latest bios to USB, That board has bios flashback I believe..

It could well be just flash the bios works..

AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb Corsair Vengeance 3000mhz, Samsung 970 EVO Plus 1tb NVME, Samsung 960 EVO 500gb NVME, Lian Li Galahad AIO 240mm, Seasonic X850 PSU.
0 Likes
Vynski
Elite

The first thing I see on the ASUS B550 board is that you may need to flash the bios for the 5000 series CPU's.

Some boards also suggest that you plug all 3 power cables in (24 pin, 8 pin, and 4 pin).

I have a Corsair RM850, Ryzen 9 3900X on an MSI MEG ACE board and have all 3 plugged in (24 pin, 2 x 8 pin) recommended by manufacturer.

From what you described I would first suspect the BIOS. 

Make sure you connect the power cables to the proper ports on the PSU.

 

0 Likes

Enermax are fickle so ensure that you've distributed the load across multiple rails or the PPC will trip every time.  Also leave no power plug on the mb open so give them all power.

0 Likes
Hedkey007
Journeyman III

Very Helpful, Thank you for sharing with us.

SITHUB is known for excellence in quality and delivering results in computer education and training. SITHUB does not provide only computer knowledge, it develops personality as well. SITHUB provides the best Digital Marketing Course in Delhi.

0 Likes