Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Ryzen 7 2700x freezing on Windows 10


My new AMD Ryzen 7 2700x is freezing on Windows 10 x64.

CPU: 2700x

MB: Biostart B350GTN (with latest bios - B35AK417.BSS AGESA Pinnacle PI update)

RAM: Corsair Vengeance LPX 8GB 2400MHz DDR4 Non-ECC DIMM CL14 (2x4GB) Black (CMK8GX4M2A2400C14)

GPU: Nvidia Geforce GT 610

PSU: Plenty Superblack 3 550W (Dec 2016)

I've just finished installing Windows 10 on this new build and I've noticed that Windows hangs randomly. Sometimes during boot, sometimes a few minutes in.

I've read through the forums, tried disabling C-State in the BIOS, didn't help.

Any ideas?

38 Replies
Big Boss

ethaniel, you look way short on power.  I suggest 750 Watts.  Hopefully you can borrow one for testing.  Enjoy, John.


I don't know if it makes a difference, but on some boots I manage to run Prime95 (the cpu stress test) on all 16 threads for 5-10 minutes. I'll try to borrow a 750w though.


Thanks, ethaniel.  Please see this thread.  Enjoy, John.


PS Calculator shows 319w for me which means that my 550w PSU should be OK.

Screen Shot 2018-06-21 at 23.55.38.png


Thanks, ethaniel.  I hope you will still try to borrow a 750 and let us know if it corrects the problem.  Enjoy, John.

EDIT:  Is your memory on the Vendor MB Qualified List?


My memory isn't on the qualified list. So I downloaded memtest86 v7.5, put it on a usb stick and booted from it.

48 tests ran for 2 hours with 0 errors. I guess this rules out the possibility of a RAM problem.

Looking for a 750w PSU to play with.

2018-06-22 04.17.34.jpg


Thanks, ethaniel.  I am no memory expert, but your's seems OK.  We await the 750 test.  Enjoy, John.

EDIT: Is the W10 install a fresh one and not a clone from another system?  If a clone, please do a fresh install and please ask if you need help.


I'm still looking for the 750w power supply, however I made some progress.

I downsized the number of cores in the Zen options of the BIOS to 4 (4+0). And now the system boots and doesn't freeze.

When I choose 6 (3+3), the system starts to freeze. When I disable downscaling and use all 8 cores, it freezes as well.

You think this is a power issue? Not a motherboard one?


Thanks, ethaniel.  I would should think so.  I am certainly not stuck to 750 Watts.  More than 600 Watts may work, 800 Watts would surely work.  It may be that your 550 Watt has a problem - can you get another one of those?  Sounds good!  Enjoy, John.


I've got myself a new Corsair SFX-600 (that's the maximum that I can get for my Mini-ITX case).

Windows 10 still hangs on boot if all cores are enabled.

Biostar (the motherboard company) sent me a June beta BIOS, it didn't help either.


ethaniel, does your board have all three processor power connections - 24 pin, 8 pin and 4 pin?  If not, I doubt it is capable of supporting your processor.  If your power supply does not have all three and if you want to fully use your processor, I suspect you may need to get a larger PS for outside your box.  You should ask your MB vendor directly if your board supports the AMD model you are running.  The CPU VRM (Voltage Regulator Module) may not be strong enough.  Enjoy, John.


misterj   I think you are on to something here...

ethaniel  According to the Biostar motherboard web page, that motherboard only supports processors of up to 95w TDP.

Even though you have the latest BIOS update for the Pinnacle Ridge processors maybe its only meant to run the lower wattage processors like the Ryzen 7 2700 which has a TDP of 65W and not the Ryzen 7 2700X which has a TDP of 105W.  You may want to check with Biostar to be sure...       


arcticwind, misterj I have only 24 pin and 4pin connectors on my motherboard.

But according MB's CPU support page (B350GTN Ver. 5.x AMD Socket motherboard gaming-Biostar ), they support 2700X:



ethaniel‌ we have very similar problem but in my case I have ryzen 7 2700 non . I'm able to get my computer to boot if I set the cores to (4+0) so for this setting I only get 4 cores/8 threads with no problem on high load. please let me know if you're able to solve this problem this is very strange problem..


The problem is not overall wattage--it's usually an issue of amperage on the 12v rail--that rail feeds your cpu, and if it's not high enough, especially if the rail is shared in the PSU, you are going to have problems with the CPU that occur when when the shared rails subtract amps from the 12v rail to feed a temporary spike on another voltage rail in the system..  I don't know why people get these really low wattage psu's and think that wattage is everything--actually, you might say that amperage is actually more important.   As a rule, the higher the wattage rating the higher the amperage on the 12v rail--cheap psu's however, often scrimp on the 12v rail amperage. 

Off hand I would not think that a 95W TDP would be a problem for a 105W TDP cpu, as some leeway is always designed into the better mboards.  That said, I've never owned a Biostar mboard--and always thought of them as relatively "budget" in terms of cost and components used.  And if you are planning to overclock the 2700X then there's a good chance you'll have trouble, either with the mboard or the PSU or both--so I would advise strictly staying at default cpu clocks!  I have a 95W TDP motherboard and an R5 1600 clocked @3.8GHz  (from the stock clock of 3.2 GHz--a whopping 600MHz overclock achieved by simply upping the multiplier)--but my cpu has a TDP of 65W, so there is plenty of room to spare for cpu overclocking--and my PSU is a 750W  Corsair, with a *single* 12v rail of 62Amps.  Never have trouble with it.  If your PSU is any good at all should have the 12v rail amperage listed in a label on the PSU itself.  Check it out.

My advice would be the following three steps in order:

1) Set all of your clocks in the system back to stock settings--cpu, gpu, etc.  If that doesn't work...

2) Replace your PSU as recommended with one that has at least 60 Amps on the 12v rail (if single) or if multiple rails, when added together.  If that doesn't work...

3) Replace the motherboard with a better brand that supports a higher TDP

But all else being equal, you'll likely correct the problem by step 2, above, I should think.   


I've got Corsair SFX-600, according to it's manual it can deliver 50A on it's 12V rail.


Given that I don't overclock, and i have a mini-itx motherboard with a basic GPU, I highly doubt that amperage is a problem in my case.


ethaniel, have you broached RMAing the board with Biostar?  Enjoy, John.


Yep, talking about it already.  But there's just too much results on google for "2700x hang" or "2700x freeze" that makes me believe that it's AMD's design flaw.

ethaniel, have you opened an e-mail Support Ticket with AMD?  If not, please do.  Enjoy, John.

Journeyman III

I had this same problem, I enabled wi!n 10 support and disabled c state in bios on my X470 msi gaming pro fixed it.


losschris​ what's the "win10 support"? I heard about the "disable c-state", but not "win10 support".


For me it was on my MSI X470 Gaming Plus Pro called Win 10 WHQL Enable.  It seemed to help with the issues of hardware, not sure every motherboard manufacturer has it though.  Another thing I found is putting your power options into High Performance and turning off PCI link state to disabled. 


losschris, I have never heard of "wi!n 10 support".  All W10 x64 drivers must be WHQL (Windows Hardware Quality Laboratory) signed.  Only signed drivers should be used on W10 systems.  Non-signed drivers must be forced installed in W10 x64, so do  not get there easily.  I don't know what corrected your problem,  but signing - probably not - maybe c-state.  Enjoy, John.

EDIT: ethaniel, how goes the 750 Watt test?


What he's talking about is UEFI mode secure boot--that's what some motherboards--like the MSI mboards--call that option.  Turn off the "Windows 10WHQL support" in the bios and secure boot is turned off.  Frankly if you are going to turn off secure boot you might as well not be using UEFI mode at all, as secure boot is the whole purpose behind UEFI...;)  I cannot see how turning secure boot off would benefit anyone, unless they are trying to boot Win10 with something they shouldn't be running that secure boot doesn't like, and so in that case the system will simply refuse to boot until you turn off secure boot.  But then you are booting with something that may be compromising your system, etc.

Journeyman III


Are you installed the latest windows release? Few days ago I bought a ryzen config with 2700x to replace the old Intel. I moved the old system disk into the new machine. The windows worked well, but I read that recommended to reinstall on a new machine especially in the case of Intel-Amd platform change. I had 2 older Windows 10 iso (both were approx. 2 year old). I installed both, and faced same issue. The machine randomly freeze totally. Usually in this case I take the machine to rma, because it seems to a hardware error but I remembered I used to work with the old (but updated) windows half a day without any problems. Finally I made a windows installer on a microsoft site with the mediacreation tool which uses the latest version and installed. Since then it is works well. I hope it solve your problem too

This needs to be a STICKY.....

Just putting together my 2700x/Asus Rog Strix x470/G.Skill 3200 build and I had all kinds of random freeze/crashes which occurred especially when installing windows update builds.  I messed with Ram Voltage, tried different video cards, reseated the Artic Freezer 33 & nothing helped stability.

I got a janky OEM copy of 10pro with a legit key off the bay, but I think the disk was old.

I pulled down the 1803 build from MS site reformatted & I've been up and running for 2 hours without issue since.  I've been hammering it with loading my apps and prepping for gaming ever since.

AMD REALLY needs to put out a bulletin about this, cause I'm sure A LOT of builders have returned their hardware and went Intel without realizing what the issue really was.  There are hundreds of forum post with people losing it over their windows freezes & if it's literally the build of windows you are installing AMD needs to Tell people.

Journeyman III

Hi all.

Just want to share my experience. Last Friday I bought a Ryzen 2 2600 + MSI B450M Mortar + 2x8GB GSKILL Ripjaws V DDR4 3000MHz CL15 to upgrade my system and it took me 1.5 days to get the system stable.

The problem was some incompatibility between this bundle and Windows 10 Pro v.1705 (the version I had in a USB Stick) that freezed after a few minutes, not even allowing me to update Windows to the latest version using Windows Update.

The solution was to use a different PC to download the latest Windows 10 Pro Media Kit, put it in a clean USB Stick and perform a clean install. No problems whatsoever and running smoothly - and FAST, since my previous rig was a Phenom II X6 1075T + 12GB DDR3 RAM.

Hope it helps.

Best from Lisbon.

It's a real issue with 450 & 470 boards and Win 10 1705, it seems like the crashes occur randomly, but they really hose the system when windows trys to pull down the 1709 Update???

The media created by the MS Creation tool automatically installs 1803 which has been 100% stable for me for 2 weeks.

As I stated AMD needs to get this info out to consumers because I guarantee you people are taking by Ryzen Chips & Board and going Intel due to this issue.

Journeyman III

Thank you jcollector, vbecas, vzolli for bringing this up! You guys saved me from becoming crazy about this topic.

Just to share my experience:

New rig

- ASrock x470 Master SLI

- AMD Ryzen 2700x

- Corsair DIMM 16 GB DDR4-2666

Had a fresh Windows 10 Enterprise System set up that caused random freeze with critical Kernel erros in the event log. I tried everything starting with BIOS settings, voltages, exchanged single hardware parts to identify the source of that error. NOPE!

In the end it was this thread that helped me out. I created a fresh Windows 10 Prof. stick using the media creation tool. The machine is running stable now.

Thank you!


I had the same problems with my Ryzen 7 2700.

Windows 10 x64 hangs (freezes for a while) randomly on idle.

Disabeling c-states in BIOS changed nothing.

Only change Ryzen balanced mode to high performance resolved my problem.

Journeyman III

I struggled for a good 2 days with this, turns out the Windows 10 Build I was using for the install wasn't compatible with the new Ryzen Architecture. I downloaded the latest one and boom, no issues.

It would constantly freeze on me during install, and about 2 -5 minutes after log in.

I tried different voltages, clock speeds, game boost on, tightened up my liquid cooling to make sure the CPU was getting even heat dispersion. Drove my frickin insane.

Just for anyone else who comes across this, get the latest version of Windows downloaded, worked like a charm.

Journeyman III

I had the same problem now im trying this and it seems ok

My build:

Gigabyte B450-M DS3H

AMD R5 2600X

AMD Radeon FX570 8GB

Corsair ValueSelect 8GB 2666Mhz

SSD WD Green 240GB

Sentey xPlus 725w

I will post if this works later, wish me luck 


It worked, im writing from the new PC with an actualized W10 so that, for me, was the problem.

WP Windows e.e

Journeyman III

I faced this same issue with a newly built PC. This is my build 

To fix it, I had to install windows 10 enterprise and disabled windows update when it starts up. You'll have to google "Windows 10 1903 Download"

Journeyman III

mezzieaustin yes only windows 1903 work nicesly to new ryzen 7 no more random freeze or BSD ,allways new bios to motherboard new chip update and all work like a charm

Journeyman III

Ok fella's... im stumped on this...

Recently upgraded from intel to a Ryzen 7 2700X and a TUF Gaming 470 Plus MBU... 

I also have Corsair LPX DDR4 RAM 3000mhz, 650W Power supply, MSI 1070 ti, 1 TB HDD and 250 GB SSD. 

I did a reinstall of windows (newest version) etc. and everything is working incredibly except for one program. I am a sim racer and my pedal software hangs and lags for significant amounts on time making the pedals unusable. I have tried changing USB ports etc. 

Any help is appreciated I am super stuck. Its just one program!


I think your problem is that the device work as an older usb device and laging with new system.Maybe if you update all drivers  of the pentals device .I think is incompatible with your system

Journeyman III


My actual PC config: MSI B450 Mortar MAX / Ryzen 2700X / 2x 8GB DDR4 / 500GB m.2/ Silentium Vero 600W Modular

GPU nvidia GTX 960 4GB

Windows 10 Pro x64 (with all new updates)

BIOS updated AMI BIOS7B89v2H2022-08-11

My computer freezes one time in a week, sometimes one time in a month,i other words i cannot move mouse or keyborad

i changed gpu, memory, power supply, hard drive, update bios, downgrade bios, update again, reinstall system,

i run lot of benchmarks, stres test, prime95 - work ok

but for some time it freezes