cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

qwertz88
Journeyman III

Ryzen 3900X Temperature and Voltage Problem in idel

Hi guys and girls,

I've already read a lot of forum articles and reddits about the mentioned problems, and also tried some of the workarounds.

I updated the BIOS / UEFI to the current version before installing Windows 1903.

I'm using a MSI X570 motherboard with the Ryzen 3900X with the stock Wraith Prism cooler.

It is connected to the correct CPU Fan 4PIN slot, without the RGB control cables.


In the BIOS hardware monitor (fan control) all values are displayed correctly (CPU temperature 38° - 40°) and the fan behaves normally.
As soon Windows booted up, it seems as if wrong temperature values would be transferred to OS. In idle state the values are jumping between 55° - 65° which causes the CPU fan to turn up and down every second. And Sometimes its stuck at ~80° in idle. And of course it gets very loud.

The CPU also has the known problem that in idle the voltage is much too high.

I don't know if the high voltage values are related to the wrong temperature values, but in my opinion 80° in idle is little high.
In addition there is the strange behavior of the cooler which is very annoying while working.

Unfortunately I am not 100% sure whether the problem is caused by the mainboard / BIOS / UEFI the CPU or Windows.


I hope you can help me. 

52 Replies
resonator79
Adept I

Re: Ryzen 3900X Temperature and Voltage Problem in idel

I can't offer a solution, only say that I am seeing the exact same thing happening on my system with similar parts - MSI X570 Gaming Pro Carbon Wifi w/ 3900X.  Supposedly the AMD Balanced power plan that's installed with the latest AMD X570 chipset drivers will allow the CPU to scale down voltage and clock speed to help it run cooler, but I've had difficulty getting that working as well.  Quite frustrating...

Matt_AMD
Community Manager
Community Manager

Re: Ryzen 3900X Temperature and Voltage Problem in idel

Please could you try changing the Windows Power Profile to Balanced and let me know the outcome?

0 Likes
resonator79
Adept I

Re: Ryzen 3900X Temperature and Voltage Problem in idel

amdmatt‌ I tried that last night, and it did indeed help a bit, but also had an odd side effect.  After reboot, with no changes in BIOS at all whatsoever, the CPU was locked at 3.8 GHz/1.1 V and would scale neither up or down from there.  I removed and reinstalled all the AMD power profiles, tried all the stock MS profiles, reset the CMOS (twice), all to no avail.  Some combination of things did finally get it working again (I honestly have no idea what), but now I'm stuck back at the CPU constantly running at boost (4.1-4.4GHz) and super high temps.  I'm a bit hesitant to mess with it again for fear it'll end up in that highly throttled state.

It's currently using the stock Windows Balanced power plan.

0 Likes
Matt_AMD
Community Manager
Community Manager

Re: Ryzen 3900X Temperature and Voltage Problem in idel

Are you running the latest BIOS using the default CPU BIOS settings?

0 Likes
resonator79
Adept I

Re: Ryzen 3900X Temperature and Voltage Problem in idel

Yes.  I am using the latest BIOS from MSI.  I cleared CMOS and loaded default values.  The only setting I changed was enabling the XMP profile on my RAM to get it running at the proper frequency (3466).  I closed all monitoring software except Ryzen Master OR CPU-Z (didn't run both simultaneously).  The other odd thing - if I reset the CPU to defaults using the Reset feature in Ryzen Master, it appeared to run as it should (scaling up/down and hitting reasonable temps and frequencies).  As soon as I'd reboot, it would revert to the 3.8/1.1 setting.  All this without doing anything in the BIOS.  Certainly seems like something in the Windows power plan was causing this?  I tried all Ryzen power plans as well as the stock High Performance plan to see if any of that would have an effect - it didn't.

It seems to be running at the constantly-boosted frequency now.  I'm never seeing voltages much below 1.396, but I did manage to avoid the 3.8/1.1 somethow.

Could the virtualization setting have any effect on this?  That was one setting I tried turning off/back on last night that seemed to break things free.  I left everything else alone or reset it to default.

0 Likes
resonator79
Adept I

Re: Ryzen 3900X Temperature and Voltage Problem in idel

amdmatt‌ just saw something on Reddit referencing MSI's Dragon Center causing issues by overriding Window's power plan settings.  I did indeed remove that software, but people are reporting remnants causing persistent issues.  I'm going to take some additional steps suggested there when I get home from work and see if that resolves the problem.

0 Likes
qwertz88
Journeyman III

Re: Ryzen 3900X Temperature and Voltage Problem in idel

Hi amdmatt,

I've made some comparisons between the different energy saving plans.

So the AMD plans don't really work out very well in my opinion because I have about the same situation with all three of them.

It's the same with the standard Windows plans (Balanced and High Performance).

The only plan that works for me right now and the CPU really goes "true idle" is the standard Windows Power Saving plan.

Under full load all plans show the same behavior. The CPU slowly starts to clock down to keep the temperature under control.
For me this is a sign that AMD may have miscalculated a bit with the Wraith Prism and the 3900X. My CPU can do about 10 seconds 4.3GHz until it starts to clock down. At 4.6GHz the CPU with the Wraith Prism would probably just evaporate along with the motherboard.

Here are my values:

AMD High Performance Idle:
Temp:     49°C - 64°C
Volt:     1.4625V - 1.46875V
Clock:     ~600MHz - ~4.3GHz
Cooler: Revving up and down constantly

AMD High Performance Stressed:
Temp:    90°C increasing
Volt:    1.31875V - 1.34375V
Clock:    4GHz decreasing
Cooler:    Revvs @ 100%

AMD Balanced Idle:
Temp:    52°C - 62°C
Volt:    1.4625V - 1.46875V
Clock:    ~600MHz - ~4.3GHz
Cooler: Revving up and down constantly

AMD Balanced Stressed:
Temp:    90°C increasing
Volt:    1.31875V - 1.34375V
Clock:    4GHz decreasing
Cooler:    Revvs @ 100%

AMD Power Saver Idle:
Temp:    52°C - 62°C
Volt:    1.4625V - 1.46875V
Clock:    ~600MHz - ~4.3GHz
Cooler: Revving up and down constantly

AMD Power Saver Stressed:
Temp:    90°C increasing
Volt:    1.31875V - 1.34375V
Clock:    4GHz decreasing
Cooler:    Revvs @ 100%

Windows Power Saver Idle:
Temp:    44.2°C - 44.5°C
Volt:    0,95V fix
Clock:    ~400MHz - ~2.2GHz
Cooler:    Running constantly @ lowest speed

Windows Power Saver Stressed:
Temp:    90°C increasing
Volt:    1.34375V
Clock:    4GHz - decreasing
Cooler:    Revvs @ 100%

Matt_AMD
Community Manager
Community Manager

Re: Ryzen 3900X Temperature and Voltage Problem in idel

I recommend that everyone reads the post by Robert Hallock on Reddit as it explains what is going on. Robert will make a new thread about this subject soon with an additional update. Please check the thread linked below periodically for updates.

https://www.reddit.com/r/Amd/comments/cbls9g/the_final_word_on_idle_voltages_for_3rd_gen_ryzen/

lucamoser
Journeyman III

Re: Ryzen 3900X Temperature and Voltage Problem in idel

Hey

I'm another MSI MPG X570 Gaming Pro Carbon Wifi owner with a Ryzen 3700X.

I am running into the same issues as OP: Using CPU-Z, I see the voltage being constantly at 1.4V while I have no other program open. The fan constantly ramps up then goes down again and then ramps up again (doing any lightweight task). Idle temps seem also to be way too high with 50-68 °C. Room temperature is around 27°C. I am using the stock Wraith Prism cooler.

I started to search on Reddit and found a post highlighting some fixes (https://www.reddit.com/r/Amd/comments/cbls9g/the_final_word_on_idle_voltages_for_3rd_gen_ryzen/).

  • I enabled the AMD Ryzen balanced power plan
  • I disabled precision boost overdrive in the BIOS

This makes the CPU voltage go down to ~1.25V max, which is still too high, as I saw other's CPU voltage drop down as low as 0.3V. If I use the Windows Balanced plan with a 99% "Maximum processor state", the voltage drops max to ~0.970V. All in all, the voltage is still too high and the CPU doesn't clock down below 3,49Ghz.

Hardware:

  • AMD Ryzen 3700X
  • MSI MPG X570 Gaming Pro Carbon Wifi (BIOS version 7B93v11 2019-07-02)
  • HyperX Fury 2x 16GB @3200 (XMP is enabled)
  • Asus ROG Strix GeForce RTX 2070 Super Advanced Edition
  • Corsair RM750x (750 watts)
  • Fractal Meshify C Dark TG

CPU-Z report: https://pastebin.com/zf1TjMim

I am using Windows 10 (Build 1903). Note that I am really only running CPU-Z when measuring the voltage, this, because I've read that apparently running multiple monitoring tools causes the voltage to stay high constantly.

Any ideas what I could do?

0 Likes