Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Newer chipset update won't install for my 2700X, Chipset is stuck at 17.12

I have a Gigabyte Aorus X470 Gaming 7 WiFi MB (Win 10 Pro ver 1803) with a Ryzen 2700X CPU and I went to Gigabytes site and saw that there is a chipset update to so I downloaded the zip file and extracted all the files and ran the setup.exe. The program starts and say's that the current chipset is 17.12 and on the other side of that window it has 17.12 showing as an update. When I click on it, it runs and then ask's for a reboot, which I do. The problem is that it's not updating to anything higher than 17.12 which I already have. What am I missing???

I don't even know where to look to see what chipset is installed!!

Thanks for any help.

5 Replies
Journeyman III

I have the same issue. I would like to flash my BIOS and on the Gigabyte website they say that in order to flash the F3 version you have to update your AMD chipsets to the version but I can't find that version on the AMD website and the one provided by Gigabyte is the 17.12.

Anyone else with the same issue ?


lumpy95 and cacxius, both of you should contact your MB vendor.  The AMD Driver Download Site offers 18.10.1810 and it is an .exe file not a .zip file.  In general, I always recommend that users get their AMD drivers ONLY from the AMD Driver Download site.  MB vendor drivers are usually down level and in this case unexplained.  Good luck and enjoy, John.


Unfortunately, all the responses that I am getting from Gigabyte tech support leads me to believe that they really don't know much about any of this situation.

The only firm answer that they have given me (and keep repeating) is that I have the correct Chipset Driver for my MB which is 17.12, they don't seem to know anything about update. They don't know where to look to see if it ever installed when I tried it. I'm losing confidence in Gigabyte FAST.


I went to Gigabyte's Tech support and asked them about this and was told that the 17.12 driver version is correct and the is a chipset "Package Driver" which is evidently different than the chipset driver. I asked what the difference was and they never would tell me, they just said that if I ran the install it was installed and I was good to go!!! is listed on the Gigabyte MB site as a pre requisite for updating BIOS to F6 and above. At the time, F6e was listed so I updated the BIOS to that and wish I wouldn't have. I now see that F6e is no longer listed on their site, just F6.


Just a followup, was pulled from Gigabytes site (although they show it is needed for BIOS F7)??

I downloaded/unzipped/installed the chipset driver 17.40 from their site and as it was installing it checked for updates and downloaded/installed 18.40.22 chipset which isn't listed anywhere on Gigabytes site.

NOTE: Gigabyte replaced my MB because the wireless wasn't working correctly and the sound had problems. The new MB still has wireless problems but the sound/audio works now.

Just my opinion but Gigabyte Tech agents do not seem to know much about their own MB's and can't seem to give any descriptive answer's to many questions that I have asked them.