cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Hikidebu29
Adept I

With the display off, the RX590 spins the fan at maximum speed.

Hello

I have it set from the power options (pls see image and sorry for the Japanese language controlpanel) to turn off the display after 3 minutes without touching the Computer.

It turns the display off with no problem, but after a few seconds ~ a few minutes (seems random...) The RX 590's fan spins at maximum speed for a few seconds.
Once it starts spinning, it will continue to spin every few minutes until the display is turned on.
As long as I don't turn off the display, my RX 590 works perfectly fine.

I suspected overheating, but the task manager shows 47°C~53°C, which is within the range where Zero RPM is enabled.

I have not ever used AMD Radeon Software or any third party software to control the RPM at all.
I've tried downgrading and updating drivers, initializing Windows and BIOS, but it's still the same.
This problem has been going on for almost two years, and I can't solve it by myself, so I'm asking. Does anyone know of a solution?

Thank you in advance.

CPU: AMD Ryzen 5 2600
M/B: MSI B450M MORTAR TITANIUM
MEM: Corsair CMK16GX4M2A2666C16
GPU: Sapphire NITRO+ RX 590 8G G5 SE

controlpanel.JPG

0 Likes
2 Solutions

And it only does this when it tries to bring the display back from sleep?

Can't be 100% from the video.. But it definitely looks like the case fans ramp up as well.. (Little hard to tell as can only see them on the edges of the video.. Which is similar to an initial boot where all fans run @ 100% for 1 - 2 seconds while the BIOS runs P.O.S.T and starts the fan controller and drops the power back to the pre-configured RPM V Temp.

Does it work normally if you Put the entire PC to Sleep. I.E  Win Key, Power, Sleep. and then attempt to wake it again..?

Also have you tried turning off Zero RPM Fan mode or setting a manual fan curve for it..? When it does, what it does, (In the YouTube video) does the Num Lock, or Caps Lock etc. keys still respond or not..? Have you done a reset to factory defaults for the BIOS..?

** Check the rest of the fans when it's doing what you show in the video.. Because it really looks like all the fans are ramping up.. Which could point to more a MB or BIOS setting or issue.  Also find out if the PC actually becomes completely unresponsive.. Num or CAPS keys work well for a test.

Do you have 2nd PCIe slot you could move the video card into for a test..? Also make sure you have the correct, most recent (Non Beta) MB Firmware installed. Also make sure Chipset Drivers & similar are all latest versions.. There was a new AMD chipset driver released recently within the last week or so.

Also what happens if you set Turn Display Off to 'Never' leave it run for a few hrs on as screensaver or desktop with the monitor off, Then turn the screen on again?

View solution in original post

mrDMG89
Journeyman III

Maybe not the most elegant solution, but I found the way that works for me.

I have the same issue with RX580 from Sapphire. When monitors go to sleep, fans ramp up for a few seconds. But I faced it after full Windows reinstall. So, the answer is... HWiNFO or MSI Afterburner. No, you don't need to configure fan curve. It's enough just to let them monitor GPU sensors. When I start to troubleshoot this I installed HWiNFO to see what is going on with temps, RPMs, freqs etc. And when HWiNFO is open, issue goes away. Close HWiNFO and fans ramp up again. Tried even on different SSD with other Windows install, same thing. 100% reproducible. MSI Afterburner works the same way. I use it with Rivatuner constantly for monitoring FPS, CPU/GPU load. It always been in auto start in my system and may be it prevented this issue to pops up before for me.

I saw you last reply. Glad you system is works well. May be you also install software for GPU monitoring and problem goes away?

View solution in original post

11 Replies
CheeseMeepes
Adept I

Have you tried a factory reset on your gpu? If that doesn't work, it might be a problem with your monitor, try checking for display/monitor drivers, make sure the display wire is properly in, and try plugging your gpu to different monitors and see if that works. I'm guessing the problem is that when windows tells the monitor to sleep/turn off, the monitor or windows either doesn't send a proper signal, so your gpu does not know what to do and speeds the fan. 

Thank you for reply!!

I have a couple of monitors and tested with them,
I also tried resetting the GPU, but it didn't change. I completely missed the possibility that the problem was on the monitor side... Thank you for your advice.

0 Likes
ScotchFury
Challenger

Could also double check your power settings that it's only turning the display off after 3 minutes and isn't trying to enter some form of suspend or hibernate mode. Try disabling or enabling "Allow Hybrid Sleep" and check the other advanced Power Performance options For PCI Express. Variously sleep states. etc.  Also have a good look through your BIOS settings.

Under "Control Panel\Hardware and Sound\Power Options\Edit Plan Settings"  then "Change Advanced Power Settings"

Power Options.png

 

 

 

I tried turning off ASPM for PCI Express and turning on/off "Hybrid Sleep" from "Change Advanced Power Settings", but there was no change.

Thanks for the reply and advice

0 Likes
Hikidebu29
Adept I

I recorded a video of the problem being encountered.

00:02 -> TurnOn fan LED and fan spinning at maximum RPM.
00:14 -> Stop the fan.
01:17 -> TurnOff fan LED.
01:42 -> TurnOn fan LED and fan spinning at maximum RPM.
This will be repeated.
I did not touch the computer at all when I recorded this video.

YouTube -> https://youtu.be/GTa14bCEvMo

0 Likes

And it only does this when it tries to bring the display back from sleep?

Can't be 100% from the video.. But it definitely looks like the case fans ramp up as well.. (Little hard to tell as can only see them on the edges of the video.. Which is similar to an initial boot where all fans run @ 100% for 1 - 2 seconds while the BIOS runs P.O.S.T and starts the fan controller and drops the power back to the pre-configured RPM V Temp.

Does it work normally if you Put the entire PC to Sleep. I.E  Win Key, Power, Sleep. and then attempt to wake it again..?

Also have you tried turning off Zero RPM Fan mode or setting a manual fan curve for it..? When it does, what it does, (In the YouTube video) does the Num Lock, or Caps Lock etc. keys still respond or not..? Have you done a reset to factory defaults for the BIOS..?

** Check the rest of the fans when it's doing what you show in the video.. Because it really looks like all the fans are ramping up.. Which could point to more a MB or BIOS setting or issue.  Also find out if the PC actually becomes completely unresponsive.. Num or CAPS keys work well for a test.

Do you have 2nd PCIe slot you could move the video card into for a test..? Also make sure you have the correct, most recent (Non Beta) MB Firmware installed. Also make sure Chipset Drivers & similar are all latest versions.. There was a new AMD chipset driver released recently within the last week or so.

Also what happens if you set Turn Display Off to 'Never' leave it run for a few hrs on as screensaver or desktop with the monitor off, Then turn the screen on again?

The same problem as the video only occurs when the computer is turned on and the display is in sleep mode. This works as usual when I press any key or move the mouse to recover the monitor from sleep mode.
In other words, with my setup, this problem occurs only after the monitor disappears after 3 minutes.
The time it takes for the fan to start spinning after it turns off seems to be really random, I'm not sure

I looked at the speed of the other fans, but there was no change.
I think it's probably the shutter speed of the camera.
Also, during the 0.1 second (not exaggerating) transition from the Windows logo to the lock screen after pressing the power button, the GPU fan spins up for a moment (like sighing).
After that, the fan speed returns to zero immediately.

When I run Windows -> Power -> Sleep, all the fans stop and will not restart no matter what I do until I press the power button.

I have tried turning off Zero RPM and manually controlling the fan, but no change.

When I tried safe mode, the fan would not turn off (not the maximum, about 800RPM) and there was no problem except that the RPM did not go to zero when I turned off the display. I thought if it was a driver or software problem, there would be a log, so I checked the event viewer, but there was nothing like that. . . .

I have upgraded the chipset drivers to the latest. The last update was 5/25 2021, so I don't think it has changed that much. It still didn't change.
Also, since I have a PCIE x8, I tried to move it, but it interfered with the power supply pin header, so I gave up :((((((((

I set "Turn off display" to "No" and turned off the monitor, but it didn't change.

Thank you

0 Likes

Try playing around with your monitor's resolution and frame rate. Some monitors at higher resolutions and/or frame rates do not have proper VBIs, or vertical blanking interval, which cause the gpu to overwork at times. Another thing to do is going into BIOS and making sure that the PCIE slot is set at PCIE Gen 3 speeds and not auto, windows sometimes gets confused when put on auto. To be honest, your problem is something that is out of my league and I recommend contacting the manufacturer about this problem.

Hikidebu29
Adept I

I really don't know why, but it was resolved a few of days after my last answer.
Thank you so so much, CheeseMeepes and ScotchFury.

mrDMG89
Journeyman III

Maybe not the most elegant solution, but I found the way that works for me.

I have the same issue with RX580 from Sapphire. When monitors go to sleep, fans ramp up for a few seconds. But I faced it after full Windows reinstall. So, the answer is... HWiNFO or MSI Afterburner. No, you don't need to configure fan curve. It's enough just to let them monitor GPU sensors. When I start to troubleshoot this I installed HWiNFO to see what is going on with temps, RPMs, freqs etc. And when HWiNFO is open, issue goes away. Close HWiNFO and fans ramp up again. Tried even on different SSD with other Windows install, same thing. 100% reproducible. MSI Afterburner works the same way. I use it with Rivatuner constantly for monitoring FPS, CPU/GPU load. It always been in auto start in my system and may be it prevented this issue to pops up before for me.

I saw you last reply. Glad you system is works well. May be you also install software for GPU monitoring and problem goes away?

I noticed that too.
I tried to use GPU-Z to see the voltage when the GPU is in sleep mode.
This may be the best solution.

Thank you for reply!