cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

John_William
Adept I

New RX 6650 XT causes stuttering

Hi everybody,

I just installed a new graphics card in my PC, I went from a gtx 1060 6gb (which I've never had any problems with) to an RX 6650 XT. Before I installed my new graphics card I used DDU to remove the old NVIDIA drives. and then I downloaded and installed the new RX 6650 XT drive. But now it is the case that I often have stutters in games, that the image sometimes freezes for a few seconds or a few milliseconds. And almost always, for example, when I leave a game in battlefield and when I respawn with battlefield or warzone.


My PC specifications:
Ryzen 5 3600
16GB RAM
RX 6650 XT
500GB SSD
1TB HDD
Cooler Master V550 Gold-V2
a320m-h-cf Motherboard
1080P 144hz monitor

Performance measures (see drops in GPU usage and Clockspeeds at te same time, sorry this is in dutch):

Schermopname (93).pngSchermopname (94).png

How is this possible and how can I stop this stuttering?

Thanks in advance for your help!

10 Replies
Deemon69
Adept III

Good day!

What power plan are you using? This is the first question. The second question, have you tried to share the load of the processor and video card by disabling Windows hardware acceleration (HWAcceleration)? And the third question, how do you use the swap file, automatic or fixed?

Thanks for the reply. I am using the balanced powerplan. what will be the best powerplan to use?

I will try to disable windows hardware acceleration.

What do you mean by: how I swap file? automatic or fixed? and how can this help me?

0 Likes

Good day!

The swap file greatly affects the performance of the PS. I recommend letting Windows adjust its size automatically. With AMD Ryzen 3600, it was necessary to use not just a Balanced power plan, but use AMD Ryzen Balanced or AMD Ryzen High Performance power plans. Therefore, try the following:
1. Install the swap file in automatic mode;
2. Disable Windows hardware acceleration;
3. Use AMD Ryzen High Performance power plan. Because this power plan has a lot of questions in the latest drivers, I recommend using the AMD Ryzen™ Balanced LowPower custom power plan with bug fixes, you can get it here.

1. Swap file was already in automatic mode.

2. I do not have the option to disable hardware acceleration I think. I tried to follow a tutorial, but I do not have those options.

3. Sorry, I do not understand what to do with your third advice. can you be more specific? I don't know how to get the power plan via your link.

0 Likes

To disable hardware acceleration, you need to edit the registry settings, so be sure to create a system restore point before proceeding any further.

1. Press Win + R to open the Run application.
2. Type regedit in the text field and press Enter. You will need administrator rights to make changes to the Windows registry.
3. In the registry, navigate to HKEY_CURRENT_USER > Software > Microsoft > Avalon.Graphics using the navigation bar on the left.
4. Here, right-click on an empty space in the right pane and select New > DWORD (32-bit) Value.
5 Name the entry DisableHWAcceleration.
6. Now double click on the record you just created and enter 1 in the Value data field.
7. Click OK.
8. Exit Registry Editor and restart your computer.

As for power plans, I don’t even know what else to say. There is an instruction in English under the spoiler. In short, you can download from the links suggested there from Google Drive AMD Ryzen™ Balanced LowPower Win11 v.1 if you have Wimdows 11, or AMD Ryzen™ Balanced LowPower v.10 if you have Windows 10 (just v.10 without PP ).

1. Download the POW file.
2. Place this file in the root folder of the drive C:\.
3. Start a Command prompt with Administrative privilege (search for command prompt in start menu).
4. Import the plan with "powercfg -import c:\filename.pow"
5. Go to power plan management and apply this plan.

0 Likes
addiepie79
Adept III

I'm curious do you happen to use Discord or twitch? if so turn off in game overlay which can cause studder in this game I have a rx 6950 xt and I play that game studder free so no worries buddy there are a bunch of us that will try and help you!!!

Adam J Martin
0 Likes
John_William
Adept I

Thanks for the responses. I already found out what the problem is. My cpu was bottlenecking the system. This is because battlefield 2042 asks a lot of you cpu. 

0 Likes
Luis_Alduncin
Journeyman III

I believe I had the same Issue. Have you tried updating your BIOS and enabling Smart Access Memory? That solved a really annoying lag and stutter that I was experiencing, even in windows using chrome. 

I used this video as a guide (4:05): https://www.youtube.com/watch?v=RxjRyN-4VdI&t=313s

0 Likes

Yes, I already tried this. But for me it was just that the cpu was bottlenecking. Battlefield 2042 just asks way to much of a cpu. Not normal! 

0 Likes