Showing results for 
Search instead for 
Did you mean: 


Journeyman III

My Radeon RX 570 Series is at 100% utilization when it shouldn't be.

I tried running Battlefield 1 and Dishonored 2 a few days ago and suddenly my frame rate is way worse that it used to be. Set everything to lowest settings, still runs like garbage compared to when I had it at high. Check my Adrenaline performance tab and GPU is running at 100% utilization. Open up some games that could prob run great on a laptop (Dusk) and its still at max utilization, although the framerate is fine. This is not an issue of it reading 100% when it shouldn't as when I'm in my desktop its at 100%. Went and opened up my case, cleaned out the fans a little and unplugged the cable connecting to it. Boot up everything runs great again. Come back again this afternoon and it's doing it again.  Clean out and unplug again like last time, this time it didn't help.

5 Replies

Maybe open Task Manager to see, which process is causing it.


Click GPU tab to order processes by how much GPU time they consume to see the culprit.

Could be some background process is stuck running, or maybe you have screen recording on, but I doubt that would eat so much GPU time.

You or any other user of the computer (does it have multiple user accounts for different users) have crypto mining or folding@home -type of software running?

Could be a malware mining crypto too.


Checked my background process a while back, nothing so major that it would cause a 100% usuage. I don't do crypto mining and I'm the only user and I'm pretty safe when it comes to downloading stuff so I don't think its malware. Starting to think its an actual hardware problem.

Journeyman III

It sounds like you're experiencing a performance issue with your GPU. Some possible causes could be outdated drivers, overclocking, thermal throttling, or hardware malfunction. You can try updating your GPU drivers, monitoring your temperature, and checking for any loose connections. If the issue persists, it may be necessary to seek further assistance from a professional or the manufacturer.


I'm looking towards hardware malfunction because I checked and am pretty sure I have the most recent drivers, I don't overclock, my actual temp seems to be fine.

Journeyman III

I faced same issue and here is how I fixed it.

  1. Remove Adrenalin driver completed by DDU or in safe mode. 
  2. Install the drivers again, either with Driver only option or Minimal installation mode. 
  3. Restart your PC.

Only issue with this is, you cannot use the performance tab in AMD Adrenalin software. But it is not worth the pain of struck GPU utilization.