cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

Spankej
Journeyman III

Blender and Games crashes RX6600M (squares artifacts)

I have a problem with my new laptop. When working in Blender the system freezes after some minutes and artefacts (small squares) show up on the screen.

My first thought was that it's Blender's fault. But the same thing happens when I play games.

It's not the case of system overload or overheating either because the problem occurs even when I do the simplest things in Blender.

At some point when I play, the game freezes and artefacts show up on the screen - and the game doesn't respond and I have to swith it off via Task Manager. And waiting for it to respond doesn't do any good. At the same time the rest of programes and apps open in the background work perfectly fine.

My laptop is Omen 16 c0322nw
ryzen 7 5800H
AMD Radeon RX 6600m
16 Gb ram
Win 11 

I have the most up-to-date dreivers (22.2.3) and I've already tried the old drivers - no changes. Windows System has all the updates. The problem doesn't depend on whether the laptop is plugged or not.

I've updated the Bios' drivers and tried to run the programes in backwards compatibility mode and as Administrator. Then I've reset the entire system back to the factory settings - nothing's changed. The problem still occurs.

I've played Hearts of Iron 4, Batlle Brothers and Kingdom Come Deliverance and the problem's occured only with Hearts of Iron 4 and Batlle Brothers (which have less requirements in theory). Kingdom Come's worked perfectly fine.

Do you guys have any ideas what could be the nature of problem? Bez tytułu.jpg

43 Replies

GPU Artifacts can be from overheating, GPU going bad, driver, overclocking and possibly bad PSU Outputs.

Download and run OCCT -CPU and GPU and GPU vMEM to check and see if your laptop is overheating or if artifacts starts showing up during the tests.

Keep an eye open to CPU, GPU, Motherboard Temperatures and Fan speeds.

Try running your HP laptop's Diagnostic software and see if everything comes back normal.

Otherwise since it is a new laptop I suggest you open a Warranty ticket with the HP Support to have them check it out for you. You might do something to void the Warranty on the laptop.

NOTE: If the video artifacts occurs during POST, while BIOS is booting up, then it could be a defective APU or GPU card in your laptop.

EDIT: Was finally able to locate your European (Bulgaria) HP laptop driver download page: https://support.hp.com/bg-en/drivers/selfservice/omen-16.1-inch-gaming-laptop-pc-16-c0000/2100371407...

Screenshot 2022-02-27 093811.png

I found your laptop from this foreign HP Support website:

Screenshot 2022-02-27 093811.png

When I inputted "59A34EA" HP Support sent me to the above download page for your laptop.

 

 

I have exactly the same issues with the same configuration, even the second monitor is HP. And having the latest driver. And it has nothing to do with the OVERHEATING. I am 100% sure.

Seems like AMD doesn't care of what happens with the new models. I am talking about RX6600M. Tried old drivers, doesn't work. Still the same artefacts and the blackouts. And in some apps the screen flickering with black every minute. I've tries changing the cables but still no luck.

So there's only one resolution is to wait for amd to replay back in this thread. Tbh I am completely mad with what I see.

Btw the first suggestion to update the drivers doesn't help. Srsly, monitor drivers or anything else. I am thinking of maybe to switch to my DELL N5110 because of that (NVIDIA). Spending so much money to get 144hz and to use a laptop which is 12 years old.. And this is my first experience with AMD GPU!

0 Likes

I agree with @eltasci. Please make sure you are using the latest BIOS and AMD display driver for the HP Omen laptop. For the opening poster, here is a link to the latest BIOS and AMD Display driver version for your specific laptop. 

https://support.hp.com/bg-en/drivers/selfservice/omen-16.1-inch-gaming-laptop-pc-16-c0000/2100371407...



Please download and update/install the BIOS and AMD driver version directly from the HP webstite to see if it resolves your issue. 



If the issue persists, I would also recommend reaching out to HP for additional assistance.

Since it seems that most of the replies in this thread concerns HP Laptops and specifically the Omen model to me it does seem to indicate a HP engineering issue or QA issue when the laptops were manufactured.

All are using AMD Professional GPU cards.

I would just RMA the laptop back to HP, if still under Warranty,  and link them to this thread as a reference to let them know it isn't a isolated case.

That is if updating the BIOS and using HP's OEM AMD Driver doesn't fix the problem.

I am using the latest BIOS (for my HP Omen 16.1 AMD CPU and GPU) and tried the GPU drivers from the official HP website (HP drivers are so outdated with the same effect and squares, then tried all of these official AMD drivers with no progress  https://www.amd.com/en/support/previous-drivers/graphics/amd-radeon-6000m-series/amd-radeon-rx-6000m...

Konst_0-1648641882983.png

Also, I have the latest AMD Adrenalin 22.3.2 rn.

So, I think AMD won't help us somehow. AFAIK this is not the first AMD product that has the same black artifacts (lots of posts here with GPU issues). Will try to reach HP company, but I think all of us stuck with this product.

This is the worst experience I ever had..

@Konst 

From everything you have done and said it doesn't sound like a AMD issue more of a HP hardware issue with that particular Laptop model.

Hp is using AMD hardware but they are the ones that engineers the motherboard to use AMD hardware. if there is a flaw in their design or just lousy QA is something that HP needs to look into and not AMD since they aren't the manufacturer of the laptop.

Hi,

Today uninstalled all drivers with ddu and installed the ones that HP gives. I already updated the bios yesterday. And I have used only the laptop screen. 

The artifacts have appeared twice in 8 hours and a blue screen followed to send a report to amd.

Visual Studio

2022-03-30 19_26_16-Greenshotasd.png

Working with secondary screens, the problem of artifacts is more frequent, both for hdmi and for displayport.

0 Likes

Have you tried to disable the internal AMD Graphics?

Just use only rx6600m

0 Likes

As an update to this thread HP Support Agent has brought this issue to the attention of an appropriate team within HP.

https://h30434.www3.hp.com/t5/Gaming-Desktops/HP-OMEN-16-Black-artifacts/m-p/8345241#M17995

So, will update the results when I will have an update on that.

Good going, You finally got HP to react and at least try to reproduce the issue with Omen Laptop and it AMD GPU card.

Hopefully they will reproduce the artifacts and come out with a new BIOS to fix the problem. It sounds like a HP Laptop Motherboard issue more than a AMD GPU card issue since so many others are having the exact same artifacts with the same HP laptop model and GPU card installed.

I think I am going to stop asking for help, will buy a laptop from a different manufacturer (not sure probably Lenovo).

As a resume:

Never buy HP laptops. HP support is useless.. They never pass the information to the appropriate team.

0 Likes

Hey, this is a driver problem. I have this issue with fusion 360 and i get to work only and after i disable the low end AMD graphics that is used for browsing and stuff. But u guys need to figure this out. Don't just pass the ball to HP. We are customers and if u sell your hardware to HP then u should make sure there is support for it and that users are happy. I was on Nvidia my whole life but I decided to give AMD a try. When I game it is spot on and optimized, but as soon as i use some app that is OpenGl - like 3d printer slicer, fusion 360 or blender the problem is there and it is only becouse of the secondary graphics card and i am pretty sure you guys can give us some stable drivers so we can use your hardware. Like i said i am gaming on 240 + fps no problem . but productive apps just are a no go! FIX IT 

I have something to add. HP simply doesn't do anything. So, I did some investigation and found out that when you keep the load on the GPU (RX 6600m) there seems to be no artifacts. Basically it searches for "gfx1032" amd navi32 identifactor and starts simple calculations. Here is the GIT with the sources and binaries that I did: https://github.com/kb2288/amd-gpu/releases

It just simply keeps load on this GPU..

No response from HP, No response from AMD as well.

Pretty much confused, how these companies doing their business..

Never used AMD products before RX6600m (HP as well).

 

Also, AMD says (we don't care if you have a mobile GPU):

https://www.amd.com/en/support/kb/warranty-information/mobility-graphics

 

If we can reproduce it, without installing 3d party software, that could help.
So, I will debug the applications, and will try to debug the drivers.

0 Likes

It looks like you are right, that is the driver issue with the Open GL.

I did some debugging and it stucks somewhere in atioglxx.dll

AMD is responsible for that.

etozhevodim
Journeyman III

Im using Ubuntu and have the same troubles on second monitor

0 Likes

I have the same problem with my OMEN 16 ryzen 9 and RX6600M.
On Ubuntu it's created a lot of artefacts and on win 11, the directories and files are disappear (just before the screen is blinking when it's plugged on an external screen).
I've returned the computer and HP said they have changed the motherboard but nothing has changed and my computer is still unusable.

0 Likes

I believe that is the driver issue. And they have to fix it. I have attached 2 screenshots with the problem (one is RDP access it is just stale sometimes and is gving the very solid black), but all of the software that is somehow using the GPU gives the tiny black squares and it crashes btw.

artifacts.png

Konst_0-1648152811810.png

Hmmz, so all are running an HP machine? Not saying it is a HP issue (bios related) but .. still all HP. Use dxdiag to see which GPU is being used, APU or dGPU.. using a non manufacturer driver (HP in this case) can cause issues with fans or cooling. 

Please first: turn on vsync.Disable adaptive and freesync. Try with vsync off and turn on vsync and test..

Could one of you try an CPU stress test and (someone else) a GPU stress test? For those tests please select high performance power plan within windows, so that power management should not be an issue. 

Always look for the latest bios and drivers supplied by HP. Only if really old use AMD site for drivers, as HP bases their driver on those released by AMD. 

It could a powerplay/powershift issue or a weird bug with the switchover from apu to dgpu. Also.. on my dell laptop i had an image corruption issue. Reseating RAM fixed those.. no other issues as dat as im aware off. 

Btw I've read about problems like this on NVidia Gpu's and had some issues with Intel as well 

Let me know about the vsync testing and stress tests, (prime95 small FTT & furmark will do)

Good luck

 

0 Likes

First of all, this laptop is HP OMEN 16.1 and I bought it just 2 weeks ago or so. So it is a new one. Reseating sounds very confusing when all of us has the same issue with new HP product. I have an updated BIOS

Did everything what you said:

VSYNC - ON
VARI BRIGHT - OFF
FREESYNC - OFF

(FOR BOTH DISPLAYS)

Detected GPUs (AMD CrossFire enabled, 2 GPUs)
- GPU 1: AMD Radeon RX 6600 XT, GPU: 72°C
- GPU 2: AMD Radeon Vega 8, GPU: 69°C

 

No issues with that so far!

And the applications continue showing squares

0 Likes

All those with HP Laptops that are having the artifacts do you all have AMD APU or Intel APU processors?

Reason why I ask is because normally in a laptop the APU Graphics works in conjunction with the Discrete GPU in the laptop.

Possibly it could be a AMD APU issue that is affecting the dGPU in the laptop.

Also the OP's artifacts occur while running Blender. What programs if any are you seeing the artifacts occur?

Is it also Blender or some other rendering software or just normal browsing?

 

0 Likes

It is a video streaming application.
And the solid black boxes is VMware Horizon (codec H.264)

Also, not sure, but Windows 11 can switch the graphical cards. So tried changing the profiles.

Internal AMD Radeon Graphics works fine with the streaming application.
RX6600m is crashing..

@Konst 

(Do you have HDR enabled in Windows? If so disable and test after reboot please?!)

Ok, you are right that odds are slim on reseating mem. I would still try myself, but its a long shot. 

Basicly even more as the APU doesnt have issues. 

But it could be an issue with the 6600M, but than again .. would be weird if all of you have the same broken GPU.

Was looking at disabling smartshift or Sam as a test .. but that doesnt seem to be easy on the HP omen ... 

Hmmm, well could be a driver issue, but also a bios issue... and even a hardware issue but still learning towards a weird implementation of the APU and dGPU functionality by HP. Still that doesnt help you...

Wondering if disabling APU helps dGPU functionality... but can find an easy wat to do do that i would recommend. 

0 Likes

Hey,

HDR was disabled in a test. I even disabled windows transparency.

Having the latest BIOS from HP.

Ok .. thanks for testing..

I can think of one test, but you probably wont like it: Clock down vram mem clock on the 6600m as far as possible.. if that works, it RMA time as the GDDR6 probably has an issue ..

Could you post vram voltages (that is of it doesnt lock up) .. both radeon software and gpuz will do for that.. if voltages are off, it can corrupt vram contents as well.

Still have hopes its fixable though software or bios or something, but lets try to rule out hardware as much as possible. That said: looking at the screenshots that could be memoryissues.. not sure if HP is using some kind of MUX chip..

0 Likes

I have some interesting results,

I see that the GPU Voltage is jumping (from 0 to 0.731) when I do not run games (GPU intensive things). Btw, I have no issues in games. So, I started the game and was checking this issues during 15 minutes, and it doesn't come up. The GPU Voltage is constant in game, and I see no issues in all the applications I have.

Konst_0-1648420552451.png

Konst_0-1648421276541.png

 

Konst_1-1648420655457.png

Konst_2-1648420684537.png

And then I stopped the game, and the app that had issues continue working okay, without dropping the voltage. Then I stopped it and voltage started jumping. And I see it is now flickering in some of the application and the apps doesnt' work Black again

Konst_3-1648420965195.png

 

Also, laptop GPUs doesn't have a Wattman, so I believe I have no ways to configure anything.

Internal GPU doesn't drop ofc. I disabled the 'enableulps" doesn't seem to be working anyway.

0 Likes

All the configs AMD left for RX6600M

Konst_0-1648422088811.png

 

0 Likes
ngmr
Journeyman III

Hello.

I have the same problems as described here. It has happened to me with applications like AnyDesk or Winbox, remote desktop.

The artifacts appear randomly. I bought on February 2, 2022 an HP OMEN 16 16-c0026ns, AMD Ryzen 7, 16GB, 1TB SSD, AMD Radeon RX6600M 8GB.

Seeing as you've been having problems with Blender, I'll try it out tomorrow.

Do you have a way to replicate the artifacts or is it totally random?

Same for AnyDesk..

0 Likes
Falkenstein
Adept I

Hi, I have an Lenovo Legion 5 15ACH6A, Ryzen 7 5800H/ RX 6600M/ 32GB of Ram(2x16GB of X8 memory), I have the exact same problem as you guys. I brough my laptop in fabruary, Mfg date 21.12.2021 (it's when it was build) taken from the bottom of the laptop, so my problem is present with the drivers from Lenovo and the one from the AMD website (same problem). With optimus enabled, when playing Apex Legends and Resident Evil 7 (the game I played on this laptop) or using TimeSpy and Fire Strike Stress test from 3DMark, my pc crash? sometimes with freeze + artifacts, then black screen and return to the home page (with error message or not) or the pc restart, it can a lot of different combination, with optimus disabled the 3Dmark stress test  goes well but games that use the gpu is max performance crash. Where I live there is no Lenovo store, so they oriented me to an approved maintenance center. This maintenance center tried all they could and did what Lenovo asked to do, so my pc had his bios + drivers updated without success, motherboard remplaced by a new one freshly sent by Lenovo France (so cpu and gpu where remplaced) without success, my system was reinstalled, from win11 to win10 (because maybe the problem was caused by win11) + update of drivers without success, Ram was tested memtest (no problem detected), so now I have my pc who is defective at home and I have to try to make warranty return from the store in France I brough it from (price of delivery is on me and I will get a gift card of the price I paid for delivery but I am so poor right now XD, these last month where cursed with problem so I am broke), I hope they will find the problem and repare it or refund me or give me an nvidia equivalent, don't know anymore. I have so much to think about right now, plus my money problems as a student, I am going crazy , just want a laptop that work, so guys try not to buy a pc with RX 6600M until these problems are fixed, because for now it's clearely not the case, and this for lot of brands. Image_1.png

kekelinks
Journeyman III

Hello everyone,

I have the same problem, I'm working on a workstation, not a laptop and not HP, with a whole AMD bundle and a RX6600 as well that I assembled on my own.

I worked for months on Blender without any problems, and played also games on it flawlessly, but suddenly I started to have those little artefacts while running blender that occured and got the software to freeze, I have to quit it and restart it to make it work.

I don't understand where the problem come from, and I tried to download previous versions of blender, it didn't work either.

I updated my AMD drivers and it didn't help either (maybe it's because of a new version that makes it to freeze ?).

I don't understand really, since I use this computer to work and earn money, it's kind a problem...

I submitted several days ago a ticket to AMD through the adrenalin app, but no fixes until now.

Do you have news about this problem and how to fix it ?

Capture1.PNG

@kekelinks It looks like hardware fault. Memory defect for example.

I recommend to RMA if you can.

You can try to downgrade drivers by using amd cleanup utility and installing older drivers from archive.

https://www.amd.com/en/support/kb/faq/gpu-601 

 

Qanatoz_0-1658837427514.png

 

0 Likes
Konst
Adept II

I have found a stable driver, which doesn't show so many glitches like Adrenaline does:

https://www.amd.com/en/support/kb/release-notes/rn-rad-win-21-40-beta-blender-3-0

 

It partially solves issues for my HP Omen. That is the driver issue 100%. AMD DO SOMETHING!

Falkenstein
Adept I

I am back.

I personally tried a lot of things :
- fresh install of win11 of Lenovo, and the normal win11 of Microsoft
- bios update
- all drivers update/reinstallation each time I fresh installed windows
I never tried AMD professional drivers but I will try, I know that someone seem to have found a AMD driver more stable on blender.
What I personally found is that if you remove a stick of RAM of the 2 installed you will have no crash's in games and 3DMARK stress test (the Time Spy and Fire Strike one, so the problem should be dual channel RAM (CPU is memory controller maybe) or the RAM that is delivered with our computers are faulty (don't work with the AMD system, or really defective). I tested the each RAM sticks alone and in pair in each slot in memtest86, no error found in each cases, so I don't know, all I know is that for me when only one stick is installed whatever the slot or the stick it don't crash, you should try that and tell us if it works. If you have the possibility try 2 others sticks of ram as I couldn't try because I don't have another pair at disposal.

 

On reddit someone have the same problem, here is the link : OMEN by HP Laptop 16 - AMD Radeon RX 6600M Blender Crash : AMDLaptops (reddit.com)

0 Likes

"I tested the each RAM sticks alone and in pair in each slot in memtest86, no error found in each cases, so I don't know."

Memtest86 is quite weak as memory test and only will show you brutally wrong errors. Ones that can easily cause system corruption. 
Something like y-cruncher, or TM5 (Anta777 Extreme or ABSOLUT profiles), Prime95 large or mixed FFT or Google stress app are much better in searching for memory errors. 

Notebooks are in some shady ground with their BIOS settings and memory performance, imo. There are plenty of decent sticks, but topology is different from normal DIMMs, which can make them harder to work with higher efficiency. And OEM manufacturers aren't helping with this
Usually to run 3200 mHz on RAM you need to enable XMP profile. But if you don't it will only run defaults. Or it can somehow run 3200 with default timings. Also depending on mobo voltage given to sticks can be 0.01-0.02V higher or lower than set value. 

0 Likes
Falkenstein
Adept I

So today I tried my friend is ram, Kingston Fury 16GB of RAM(2*8GB 2666MHz CL15-17-17 1.2V PnP) in my laptop instead of the 2 sticks of ram that came with my laptop Samsung 32GB (2*16GB 3200MHz/ Rank 1Rx8/ 1.2V/ link to memory is datasheet below) and I am happily surprised, my laptop run 3DMARK is stress test Time Spy and Fire Strike (I say the stress test not the benchmark run, the stress test have 20 loops), and it didn't crash, same as when I only plug one stick of ram stock ram or not.

So now I can say that my laptop don't crash with 16GB Ram (2*8GB 2666MHz), so it don't seem to be a voltage issue as they use the same as the sticks that came with my laptop. So now there is 2 possibility,

1- the Ram that came with our laptop are defective or not working properly with our laptop model when in dual channel.

2- our Amd systems goes crazy when 2 sticks of 3200MHz are plugged, need to be tested with other 3200MHz stick of ram, even if it would be weird if it was the case as there don't seem to be a voltage problem as the sticks I tested use the same 1.2V, and when a 3200MHz stock ram stick is plugged the system don't go crazy so it seem that the CPU is memory controller can undle 3200MHz just fine. Maybe when 2 sticks of 3200MHz memory sticks are plugged it work differently. I don't, can someone give information if they know.

What I know now, is that changing the ram make the crash and artifacts disappear in the stress test of 3DMARK, I will test Resident Evil 7 as I know it's one of the game that crash and show artifacts with stock ram, I will modify my comment in some minutes. 

Edit : Finally I couldn't test Resident Evil as it wasn't up to date , I tested Apex Legends that I know crash when the 2 sticks of the stock ram are in and it didn't crash, so I think I solved the problem for me, as we have the same issue I think that you should definitly give it a try. I will personnaly go to the aggregated maintenance center Lenovo first send me for support, and ask them to see if they could try to change the ram as it seem to be the problem, I don't wanna buy new RAM, my only problem is that is the laptop I use for my daily life as a student, my lesson, notes, homeworks, all of those are in it and it's the laptop I use to write my notes in classes with the help of my graphic tablet, it's to tell how much time I will have to do without it ;-; , I will have to use my old laptop that last around 1hour on battery saver mode XD (i3 6006u/8GB (2*4GB)/intelHD520), my charger will have to be plugged all the time ;-; , the exact reason I took this legion 5

https://memory.net/product/m471a2g43ab2-cwe-samsung-1x-16gb-ddr4-3200-sodimm-pc4-25600s-single-rank-...

Falkenstein
Adept I

Can the people who try or will try what I did, could you write what are the results for you, so we get more information and maybe get closer to solving the issue for all of us. It worked for me, if all goes well, tomorrow I going to the aggregated maintenance center to deposit my laptop so they can test the switching etc (tight timing as the rendez-vous is like 2h after I get of college, but I hope to get there in time as I am taking the bus. The test should take a day or two, once confirmed I will take back my laptop and wait for the delevery of new ram, I hope all goes well.

0 Likes

One solution worked for me when Davinci Resolve crashed.
1) use amd clean up utility in safe mode and delete all amd drivers.
2) disable internet connection 
3) instal the original old AMD High Definition driver 30.0.14024.3 from March 16.2022 and reboot your laptop
4) DO NOT update this driver.
5) after that I have worked with plugins and rendered the videos with no crushes and artifacts... until the day when my windows update have automatically updated it.
Today I tried itagain. No crushes in Davinci Resolve

I hope it helps. But yeah, HP doesn't support their laptops at all
UPD: Unfortunately after few hours of working in Davinci it has crashed again
But video renders without shutdowns... i am thinking to bring this amazing laptop back in store....

Amd driver HP omen .png

0 Likes

I know that this subject lasts for so long and still there's no solution.

But, as a temporary solution I am still using is the following application I made:

release: https://github.com/kb2288/amd-gpu/releases/tag/1.0a
source code: https://github.com/kb2288/amd-gpu

Just place it into the start menu (source is attached you can build it on your own, if needed). What it does it starts utilizing the GPU, it does simple math all the time. And it keeps the GPU awake. But that works! The same is posted at hp.com community forums.

AMD and HP are not going to share the responsibility for the product they produce.
And I cannot fix the drivers myself, it requires some knowledge how to patch and sign it, but that is on AMD's side.