cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

K1lted
Adept II

Bizarre vertical-screen depth issue with 7900XT

Hi folks, I am trying to get my head around a bizarre issue since I installed my new 7900XT this morning.

MY primary display is a Samsung U32H85X 4k, 32 in monitor, which operates at native resolution (3840x2160) and is connected via displayport.

I also use a Second monitor, which is a Sony Bravia 40in TV, which has a native 1080p resolution of 1920x1080). It is connected via HDMI (the only option)

Everything was working just fine until I installed the new card this morning. Since then, the 2nd display compresses the vertical aspect of the image into the top half of the screen (see image1). Interestingly, when I take a screenshot, it misrepresents that everything is OK and shows how it SHOULD be, not how it IS!

I have tried

- autodetecting and applying recommended resolutions
- disconnecting the second monitor, rebooting
- rebooting again
- reconnecting the monitor
- reinstalling drivers
- making sure that all old nVidia drivers were removed (and associated software), then reinstalling drivers
- re-disconnecting, rebooting and reconnecting 2nd monitor

Haven't yet run DDU (forgot as this is my first GC upgrade in almost a decade), but don't see it helping, I imagine this is a driver issue.

Suggestions welcome

1 Solution

I found a solution everyone, at least for me!

I had a new 7900XTX and was having this issue and I too was having it on my 3D capable TV. 

Try this:

Open Adrenalin software and go to Settings>Display>Arrange Displays 

Under Multiple Displays, turn on 3D display mode

It fixed the screen issue for me, shows 1920x1080.  Curiously, the input data on my TV shows it as 10-Bit 3D.  Definitely something with either the Adrenalin software or Windows after the drivers install.  It seems to be doing what it's supposed to do, just need to run some testing. 

Hope this helps others! 

 

 

View solution in original post

91 Replies
K1lted
Adept II

image vertically compressedimage vertically compressedscreenshot looks normal but is not what I seescreenshot looks normal but is not what I see

K1lted
Adept II

In 30 years of building/maintaining PCs, never seen aything like this!

Zeltor
Adept II

Ha that's crazy. Have you tried messing with these settings in the driver?

gpu.jpg

0 Likes

Yes, I have.... makes no appreciable difference.

I have also tried "eyefinity", but all that does is drop the resolution on my 4k monitor to 1080p and extend the desktop (correctly) onto the entire second monitor.

It's definitely a software issue, but haven't found a solution yet

Zeltor
Adept II

What happens when you change your 4k resolution tot 1440p or 1080p?
I wonder if it evens it out

0 Likes

Tested that this morning - made no difference at all. Also tried a different HDMI cable and different port on the second monitor, with no benefit.

IF it helps, when I power off the monitor at night, it shows nothing at all when I power it on again in the mornig until I reset the display parameters in the AMD app.

It has been suggested that the issue might be caused by main monitor being DP and 2nd one being HDMI and that a DP > HDMI adapter or USB-C > HDMI adapter might help... have ordered one of the former and will try it when it arrives

Other than that, I have had zero response from AMD to either this report or the 2 bug reports (one of them a crash of the app) which I have sent, which is disappointing

0 Likes

Considering I'm having the same issue with a 1080p TV, I dont think the resolution is the problem. Its something with the signal/refresh rate I think. Problem is I don't know if this is a driver specific issue or a hardware defect.  It has to be software related I think.

0 Likes
K1lted
Adept II

Bah humbug! Just uninstalled audio and video drivers, performed the DDU process (in safe mode... !) and reinstalled ONLY the AMD chipset audio driver (I have an x570 motherboard) and Radeon video graphics driver (ONLY).

I had already disabled the High Def audio device, but Radeon reinstalled it with their driver, so I disabled it again and made sure the main audio output is the default AND the selected device, but speakers still not working and nothing has changed with my secondary display which is completely useless at the moment

Thanks AMD!

0 Likes

Sadly, neither a display-port to HMDI adapter OR cable fixed this... this is a software problem.... SORT IT OUT AMD!

drookash
Adept I

Welcome !

You are not alone !

I've same issue. Gigabyte branded 7900XTX, reference card design.

Fresh install Win10 and Win11. Legal, activated copy.

Samsung UE55H6700 pluged in by HDMI cable and recognized properly. No other display connected.

Same cable pluged through DP>HDMI connector - same things no matter first or third DP socket.

60Hz = 1/2 screen

50hz = full screen but poor image quality, like interlaced.

Any other resolution - same issue.

When connected to Benq PD2500 through HDMI - issue, when DP - all OK.

When try to play YT movie  on TV system goes blank screen. On classic monitor Benq all is OK.

AMD please read this forum and FIX it !!!IMG_20221225_111641.jpgIMG_20221225_111618.jpgIMG_20221225_111935.jpg

K1lted
Adept II

Come ON AMD... please release a driver worthy of the name......

Did you ever fix this or get a response from amd? I have the same i have posted a comment with picture here

No reply from AMD (including to the techinical support request I made when they eventually reopened their systems after new year, which did not even get acknowledged apart from an on-screen issue number), no reply from Sapphire and no effective suggestions either here or on Tom's Hardware.... problem is exactly the same and both sound and 2nd monitor issues remain borked!

Not impressed.

They released a new driver yesterday. I installed it but no difference. Still having the same issue as you.

Removed all the drivers and then "DDU'd" the system (in safe mode) to remove all traces before reinstalling drivers..... problem persists.

I have managed to work around the sound issue by enabling HD audio via the 2nd monitor and connecting it's output to speakers, but I shouldn't have to go to that bother because a driver hijacks my sound (which it did again by default on installing the new drivers)

0 Likes
BlackVen0m
Adept II

Hi! Im so angry!! I have the exact same problem. I think it happened when i changed GPU scaling or/and when changing 10 bit to 8 bit and to RGB full range. This i can change with no issue on my rtx 2080 and 1080 TI. Or i get blackscreen. It has driven me mad! I have done everything nothing works. I cant even disable gpu scaling it just re enables it self. Maybe thats why this is happening. Im doing an RMA!

20230110_150337.jpg

0 Likes

No Never fixed Returned GPU and now on RTX4080 all seems to be OK.

Try change refreshrate from 60 to 50Hz.

Best regards !

 

Tried 50Hz, which was incompatible with the display, but thanks for the suggestion

50hz makes the tv look really bad, the text are all extra blurry, but i get fullscreen it works in that way, but playing in 50hz/fps is very bad and it seems to activate my 3d in my 3d tv. i wonder if this issue is related to 3d TVs making it split in half? but if i unplug my power on the tv and pull out the hdmi from the gpu and wait for 15 sec, i sometimes get full screen 60hz! but as soon as i change resolution in game or go from fullscreen to windowed or viceversa, it splits in half again.

0 Likes
xlox
Forerunner

people coming here and advertising nvidia and not helping anyone, are just trolls (saying they have nvidia gpu , so what do you think they do on amd forum ? wasting time ? or trying to sell cards with propaganda and spreading lies making think they "understand you and had the same problem and the only solution is to buy nvidia", ...poor manipulation polluting the forum)

i didn't read all the reply to your thread .. but yeah before going too far in searchings .... => you have to do the basics as you say you just changed your gpu from nvidia previous gpu ... first thing is to "load default settings" in pc bios ... and absolutely reinstall driver by making a proper DDU, then we can start to investigate further

update : i just checked on my old 1080p 60hz tv connected to 7900xtx hdmi , no problem seen by me... only difference i see i am on windows 11

0 Likes
compaholic
Adept II

I have the same issue and just posted about this yesterday. I ran DDU prior to Nvidia swap and updated my BIOS with load default settings. I'm not sure what else can be causing this.

https://community.amd.com/t5/graphics/7900xtx-hdmi-out-issue-to-1080p-tv/m-p/576218#M93617 

0 Likes

on the other thread you say you didn't "load setip default" after installing new gpu ... so .. if you don't want to do it to eliminate potential causes sorry but i think i'm wasting time

i repeat that 3 times a day because this is truth : computer science problem are 90% coming from between chair and desktop

0 Likes

Reread the comment you responded to on the other thread. I literally said I updated the BIOS to the latest version and loaded setup defaults. It made zero difference. This is not a BIOS issue. Perhaps reading comprehension isn't one of your strongest traits.

0 Likes

Replies with the arrogance that yours contain does nothing to help either. By your own admission, you can't even be bothered to read the information to see what HAS been done, then you make blind assumptions that would have been ansered if you did.

Sounds just like what passes for "technical support" nowadays.

osaru
Adept II

Having exactly the same issue here on a brand new TUF gaming RX 6800 xt OC 16G. Drivers - 21.3.1

Thought I was going mad as barely any information about this outside of this forum.

Rest of the system is all waiting for an upgrade, I thought I'd just test out the card... win7, i7-3770k on an asrock z77 pro4. Don't see another common denominator with anyone else's systems monitor wise either. I get the same messed up display with HDMI on my optoma 1080p60 projector at 60hz and DP on my philips 4k monitor if I drive it at 1080p too.

Messing with GPU scaling options did nothing except make the system crash.

Interesting that screenshots were being saved with the correct output... if I use nomachine to connect to the box while it's showing it's busted display, I get the full correct view too. Don't know if that maybe helps someone who knows more intimately how these cards work, determine where in the rendering pipeline things are going haywire.

Card is basically useless at the moment.

I have a 55" 3D tv "dont know if its related to 3D, do you have a 3D tv? Maybe 3d tv gives us this issue" and not only the split screen issue VSR dont even work, i get no more option than the native 1920x1080. Then i put the hdmi cable into my other sony tv native 1360x768 and i get fullscreen no issues at all. Even VSR works on it! This makes me wonder if its related to native 1080p resolution? I really strongly belive this is related to 1080p native displays/tv. if its 1080p native then you get issues. Do you get fullscreen when you use native 4k resolution on your 4k display? Do you see VSR working on your 4k? Can you also try to see if VSR is working on your other display that does not work by going into resolution in windows and see if you can change from 1080p to higher? 

That's interesting, I have no interest in VSR really, so I haven't tried enabling it until now. I just checked it though and it let's me enable it, but doesn't give me any higher resolutions than 1080p to choose from.

The projector is 3d capable, yup... but it's disabled, and defaults are set to SBS rather than top-bottom mode. Was one of the first things I thought though, seeing as the resolution is packed in so strangely. (Does anyone else also have the top row or 5 or so pixels 'cut off' and moved to the bottom of the image, just above the repeating block of colour?) I don't know where options would be on win7 for outputting 3d content anyway, I'm pretty sure I've not seen a control panel for that anywhere.

When connected at 4k on the monitor everything works perfectly, both hdmi and DP. VSR works on the 4k monitor... sort of... it allowed me to pick 5120 x 2880 resolution but then just displayed that, it didn't scale it down to native as indicated that it would in the adrenaline option tooltip.

0 Likes

The block of colour I'm discovering, is made up of the top row, centre 3 or 4 pixels, and switching between them constantly, not so bad if you have a solid colour background, vomit inducing if you have an image with a colour change right around that area as it's strobing through the colours constantly.

Serious epilepsy hazard too I would think!!

0 Likes

Hey now I really believe it's related to 3D TVs even with 3D OFF!! Because I have older TVs than mine and other TVs that are newer 1 of them 4k, all of them work, even with VSR that I can use in games to lower my CPU bottleneck that does not work on my 3D TV. The only TV that has not worked, even though it works perfectly with NVIDIA, is my 3D TV. But I have found a workaround, and it has even given me 100% more response in overall performance of the computer and in mouse response. I made a thread about it but because i shared a link in it, it seems it's not accepted, so ill put it here without the link. Here goes.

I am having the vertical split screen with my 7900 XT on my 55" TV. I finally found a workaround that works! Firstly, i installed latest driver with amd. Then without DDU and in windows (not safemode) I installed V5-22.5.1-Rev5.0-PVN-UMD-WHQL-Nemesis-NimeZ-DCH drivers over the amd without uninstalling, i know this is not the way to do it but i just did it and it worked. Doing this may not be necessary at all but i just wanted to tell you guys what i did before finding a fix. I found a software called DisplayFusion and when you open it open Advanced settings then search for Disable WMI polling and then make sure fusion starts with windows.

Now when i start windows i get split screen but i let it load fusion and then i go to the back of my tv and unplug the hdmi, wait for about 5 sec (don't plug it in to quickly) then plug it in again, now you should have full screen. Now it should not get split again. Only sometimes some games do split it again, but all games i ran worked without splitting the image, but only half life 2 did that until i chose borderless window in the game then it stopped splitting the screen.

I'll tell you why i think its doing this. 2 amazing things happened because of this. 1 i have full-screen 1080p and the other mind-blowing change is that now everything is 100% quicker when alt-tab from a game, it does it in a split second!!!! and the response on the mouse is mind blowing!!!!! Even with vsync it's amazing!!! i think disable wmi polling has done something amazing that i think so many people don't know about and will because of this info go crazy on this software and buy it! This is the most amazing thing that happened to me in gaming ever! The response on the mouse is making me believe i am dreaming! I just cannot believe it. Now the aiming in red dead redemption 2 is amazing, i can now finally aim!! So my theory why the screen splits on some TVs, is that when you don't have this amazing effect of wmi disable polling it takes time for the screen to update information to the GPU with black screen when you alt tab or change resolution,

that results in some kind of de-sync, i don't know exactly, but I'm almost positive the split second alt-tab and overall response is enabling it to work because now there is no delay. You guys have to try this, and even people without split screen issue MUST do this trick to get the most amazing response time ever! Please test this out and confirm without doing the installation of drivers like i did, stick to your current drivers and try the trick with fusion first!! If this works for you too, we need to get the word out about this trick! I still feel like i am dreaming because of the overall response with mouse and-tab out of games.

EDIT: There might be a chance it's a combination of one other trick i used, it's called "Automatically Disable Full-screen Optimizations" search for it on Google it's on Reddit

It's a bat file and when you run it, it will give you options, chose the disable part and then apply! You can revert with the same bat file. It may be a combination of these 2 tricks. But when i used this bat file alone, i did not have all those benefits i talk about here, not by a long shot. But still, they might work best together to get the same amount of response as i have now. I had 1800 DPI on my G502 mouse, but after this i had to lower it to 550 because it was so fast and responsive now.



0 Likes

Glad you found a fix for you and that it improved responsiveness too!

DisplayFusion looks like it has some good options for multi-monitor setups. I used to use something similar (ultramon I think it was?), to get a lot of the same things that are just missing in windows. I'll have to try it out.

https://learn.microsoft.com/en-us/windows/win32/wmisdk/about-wmi - was this really concerning WMI Polling though? leaves me wondering. From the reddit post talking about disable fullscreen optimisations, it certainly looks more like that is what is helping with your reducing of input lag and mouse movement. Going from triple buffering and vsync forced on, to whatever the application specifies would be a big leap!

To "solve" this myself, I've just given up and used an EDID dongle to clone the data from my FHD non-3D screen, unplugged the cable to it and plugged it into the Optoma projector. Lo and behold, the image is crisp 1080p60 now and no issues. I use this dongle for my home theatre machine though, which stays on despite the screen being switched off. Each time the power cycles on the machine, it will re-read the EDID data once from the display attached and keep passing it, so I need something else for a long term solution, one that passes a forced EDID of 1080p60 with no 3D to the card permanently.

This is really, really, pathetic though AMD. Definitely a software / driver issue reading the 3D data out of the EDID. Never seen anything else break like this, even with the cheapest of machines I connect to the display.

It definitely seems to be software-derived AND related to native 1080p.

Having installed the 23.1 driver today, I had another go at setting it up with eyefinity..... it then made a composite of my 3840x2160 main and 1920x1080 2nd monitor into 3840x1080, so everything was distorted BUT at least using the whole of the space available (including the second screen). This would seem to confirm that it is software-related and not a hardware failure.

Then tried setting up a custom resolution on the Sony TV at 1920x1080.. TV says it is the right resolution, PC is outputting the right resolution, but it is still resulting in 1920x540... so frustrating.eyefinity-3840x1080.jpg

yeah I also tried enabling eyefinity and it gave me a 5760 x 1080 mess, so basically switched me from having 1 useless image distorted on the projector, to 1 useless but not distorted image on the monitor (with the projector behaving properly).

Needless to say, 2 useful images would be much better!

0 Likes

Tested just now on my 1080p native portable display and no issues at all, works perfectly, including VSR options. No 3d on that display.

0 Likes

Yeah i can confirm its not related to 1080p monitors! i have a old full hd 1080p TV and its working perfectly! Its because of 3D TVs i am almost 100%. Maybe something that can be fixed through software drivers, or its something else going on with the signal because of 3D TV even if 3D is not enabled. When i have it connected to my 3D TV i get a option in windows where you change resolution it says 3D and you can flick it to ON or OFF, when i do that i get full screen but its on 30 hz or 50 hz and it looks like **bleep** because 3D is on! So AMD is sensing the 3D tv and giving you the option in windows, i do not get that option with nvidia card and i have zero issue with nvidiacard with that TV. So there must be something going on with the signal from the card to 3D TV. Some kind of bug or something. We need to tell AMD about the 3D TVs, that it might be related to that.

0 Likes

So here's the kicker for me.  When the PC boots up and it displays the initial BIOS/boot screen to the TV, it works perfectly fine.  When it gets into windows, that's when it happens.  The bootup resolution is always lower.

Mine is a 2010 era 3DTV. So it's possible its related to that tech.  I didn't try backing the resolution down to 720p yet, I may try that tonight.  It's almost as if the TV is consolidating interlaced lines in the top half of the TV.  Problem is it's not using interlaced at 1080p since that resolution is progressive only.  It's definitely a refresh rate related issue.  I remember older video cards had issues with flickering due to faulty RAMDAC's.  I don't think this is that but perhaps its the driver misinterpreting how to send that data out of the HDMI port.  Could be this is related to the higher than normal idle power draw when at least one of your monitors is higher refresh rate. Tonight ill try running it at 720p and also, unplugging all other displays except the TV to see if it isolates the issue at all.

0 Likes

I found a solution everyone, at least for me!

I had a new 7900XTX and was having this issue and I too was having it on my 3D capable TV. 

Try this:

Open Adrenalin software and go to Settings>Display>Arrange Displays 

Under Multiple Displays, turn on 3D display mode

It fixed the screen issue for me, shows 1920x1080.  Curiously, the input data on my TV shows it as 10-Bit 3D.  Definitely something with either the Adrenalin software or Windows after the drivers install.  It seems to be doing what it's supposed to do, just need to run some testing. 

Hope this helps others! 

 

 

Thanks, but Win7 is too old to have options for 3d display unfortunately.

Also, doesn't this mean (seeing as the display sees it too) that you're now sending it a TopBottom 3D 1080p image? so, essentially half the framerate is a blank image still, and either a flicker (or just the top half of the image if the TV is intelligent enough to display it in 2D while receiving a 3D signal) and compressed resolution?

0 Likes

When i have it connected to my 3D TV i get a option in windows where you change resolution it says 3D and you can flick it to ON or OFF, when i do that i get full screen but its on 30 hz or 50 hz and it looks like **bleep** because 3D is on! So AMD is sensing the 3D tv and giving you the option in windows, i do not get that option with nvidia card and i have zero issue with nvidiacard with that TV. So there must be something going on with the signal from the card to 3D TV. Some kind of bug or something. We need to tell AMD about the 3D TVs, that it might be related to that.