cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

FeuFeu
Adept I

7900 XTX freezing and Bluescreens after 30 secounds

Hello,

my new setup is freezing randomly. Mostly while browsing but i mean i had one right after restart. Sometimes with big gaps and sometimes after hour or minutes. The sound is playing some secounds, mouse gets slow/stopping and after 30 secounds i get BOD, with half of the monitor with pixels errors (Black and random pixel, like it was cutted in the memory)

Playing and benchmarks had no problem.

What i did so far:

  • Disable EXPO Profile, AMD-V, Onboard GPU, Onboard HD Audio Controller
  • Disable Wallpaper Engine
  • Used Chipset Driver from AMD directly and not MB
  • Updated Wifi Driver from lenovo (since MB Vendor had old one)
  • Disabled some minor update services and onboard audio service

My Specs

CPU: 7590x AMD
RAM: 2x16 GB 5200 MhZ in EXPO Mode (37-40-40)
MB: Gigabyte X670 X AX Gaming (Latest Bios F5a X670 GAMING X AX (rev. 1.0) Unterstützung | Mainboards - GIGABYTE Germany)
GPU: Saphire Radeon 7900 XTX Gaming (AMD Radeon RX 7900 XTX 24G GDDR6 (sapphiretech.com)
Sound Card: Sound Blaster Z with the new Command Center Software
OS: Win 11 Pro
Power Supply: 1000W Be quiet straight power 11
Mouse/Keyboard: Logitech G900/ Razer Huntsmand Elite

Dump Files: https://1drv.ms/f/s!AmQCcKE8vXedg0tEh_ZRjkiWnPbR 

1 Solution
FeuFeu
Adept I

To the guys who has simliar issue, till now  i had no BOD:

After disabling the hardware acceleration from my EDGE Browser, i had no BOD till now. I discovered similar threads:

hardware acceleration is broken since 22.7.1 : Amd (reddit.com)

Problem with 7900 XTX - AMD Community

 

After these threads, you could also disable Multi-Plane Overlay (MPO) inside Windows Registry.

Another one said you can force disable a option inside AMD Software Center (Adrealin Edition) -> Settings --> Graphics --> Wait for vertical sync (last option), and set it to disable force. This should fix also flickering Screens.

You could write down here if these helped more. My question would be if you can force a Bluescreen now.  

View solution in original post

15 Replies
simikolon
Adept I

I got exactly the same problem! Fix urgently needed!

0 Likes

If you have an AMD Radeon RX 7900 Series graphics product, and the BSOD (error code: DPC_Watchdog_Violation) problem occurs for unknown reasons, you can refer to this article:
https://forums.guru3d.com/threads/for-rx-7900-series-driver-with-refresh-rates-above-60-hz-may-cause...

0 Likes

hey im getting the same error but with a 6700xt, theres any fix?

0 Likes
uncyler825
Adept II

I downloaded and read the dmp file you provided, your situation may be similar to this article (BSOD error code: DPC_Watchdog_Violation)https://forums.guru3d.com/threads/for-rx-7900-series-driver-with-refresh-rates-above-60-hz-may-cause...

You can try to adjust refresh rates to 60Hz and turn off variable refresh rate feature, maybe this way can solve your problem.

 

 

@uncyler825 Thanks for that article! Adjusting refresh rates to 60Hz solved my problem. So far I have had no more freezes and BSOD.

Now, like the thread creator, I will try to use at least 144 Hz (my monitor could actually do 240).
I hope AMD will get the problem under control with the next driver.

0 Likes
verte95
Adept II

i also have the problem.

While gaming i do not have any problems but while browsing in chrome suddendly it freeze and the sound stutters. I do not get an Bluescreen. To resolve this situation i have to reset my pc.

i tried, BIOS-Update, two seperate PSU cables

 

my system:

5900X

 Asus B550 Gaming F Wifi

Corsair Vengeance 2x 16gb (3200mhz)

AMD RX 7900XTX

Straight Power 11 1000w

Monitor 1440p 144hz per HDMI

0 Likes

You can try adjust refresh rates to 60Hz and turn off variable refresh rate feature, disabled AMD FressSync from Radeon Settings.

This ways maybe can solve your problem.

0 Likes

For the Bluescreen you have to wait, about 30 secounds or more

0 Likes

The blue screen appears after 30 seconds to 1 minute. I haven't used a clock to measure it, but you have to wait. I'm curious about what our setups have in common. My current setup is as follows:

  • AMD Radeon RX 7900 XTX
  • Intel Core i9-9900K
  • GIGABYTE B360M DS3H
  • 4 x G.Skill Aegis DIMM Kit 8GB, DDR4-3000, CL16-18-18-38
  • BenQ Zowie XL2540K (connected to DP)
  • be quiet! Pure Power 11 700W (my CPU is throttled to ~70 watt)
  • Windows 11

I plan to upgrade my entire computer within the next 2 weeks, keeping only my 7900 XTX and reinstalling Windows. I hope that this will solve the freezes and crashes. I'm not sure if AMD is working on a fix for this issue, but I hope they will release a new driver version after 22.12.2 that addresses it. I'll let you know how it goes after my hardware upgrade.

By the way, I also had a crash recently while using a refresh rate of 144 Hz. However, lowering the refresh rate from 240 to 144 Hz made the freezes and crashes less frequent. I've also experienced crashes while playing games (Dota 2 and Warzone), but they are less frequent compared to when I'm browsing. In both cases, Chrome was running in the background, so it could be related to the browser.

0 Likes
FeuFeu
Adept I

To the guys who has simliar issue, till now  i had no BOD:

After disabling the hardware acceleration from my EDGE Browser, i had no BOD till now. I discovered similar threads:

hardware acceleration is broken since 22.7.1 : Amd (reddit.com)

Problem with 7900 XTX - AMD Community

 

After these threads, you could also disable Multi-Plane Overlay (MPO) inside Windows Registry.

Another one said you can force disable a option inside AMD Software Center (Adrealin Edition) -> Settings --> Graphics --> Wait for vertical sync (last option), and set it to disable force. This should fix also flickering Screens.

You could write down here if these helped more. My question would be if you can force a Bluescreen now.  

Since I lowered the refresh rate from 240 to 144 Hz, I've only had one crash, and that was in-game and not while browsing. Therefore, it may not be worth using the options you mentioned.

If I have problems with my browser again and experience a freeze and blue screen, I'll try your excellent tips! Currently, however, I am unable to reproduce the problem while browsing.

In response to your question about whether I could force a blue screen: Yes, I think it would be fairly easy to do. The only two things I have changed so far are:

  1. I set the refresh rate of my monitor to 144 Hz (since then I've only had one crash)
  2. I disabled the RAM-saving option in the Chrome browser.

If I revert both of these changes, I am sure that I will get as many crashes as I did before.

0 Likes

Try disable all "Sleep" options in windows.

Additional you can do:

In your energyplan are serval options like hybrid sleep, disable sleep after XX min, disable fast boot in the energy option so windows will always to a clean boot. (It does not get slower anyways.)

This should prevent some other crashes which i experienced mostly while i was away or using virtual machines

0 Likes
corerj
Adept I

Had similar issue, powercolor mba 7900xtx, tried ALL solutions...and setting 60hz worked...but  figured a better solutions...set Max core clock to 2300mhz-2500mhz.....now can play 120hz 4k games with freesync on, stable!

Studying gpuz logs, show fequencies higher than 2600mhz when starting games leading crash or shutdown....by the way undervolted to 1075mv...using 850w psu....

0 Likes
rekoj
Adept I

you get a freeze then a BSOD with this error DPC_WATCHDOG VIOLATION? im also getting this error, screen freeze randomly while sound still runing, then after 1 min i get the bluescreen with this error

0 Likes

Try to disable FreeSync (Adaptive-Sync) ?

 

Another discuss from Reddit and report to AMD.

https://www.reddit.com/r/Amd/comments/10aumlr/dpc_watchdog_violation_rx_7900_xtxxt_user_if_you/

[DPC_WATCHDOG_VIOLATION] RX 7900 XTX/XT User if you encounter this BSOD, disable FreeSync.

0 Likes