Showing results for 
Search instead for 
Did you mean: 


Journeyman III

5700xt CSGO Failed to create d3d device

I keep getting the failed to create d3d device error on CS GO bootups.  I've used the DDU to rollback to 19.7.2 and additionally have also tried the most up to date drivers 19.8.1.

Can anyone provide a solution to this issue?

4 Replies
Journeyman III

I don't see the error myself, but I believe that is the issue for me as well.. The game launches for me, and it says I am in game via steam, although the game doesn't seem to run at all, and I have to end "csgo.exe" via task manager to exit it. Have reinstalled windows, tried various drivers, updating BIOS etc., nothing has worked so far. Other games work fine. 
Running 5700XT and 3700X on a X570-E gaming board.

Journeyman III

I do have the same issue. It worked for me when i first installed my 5700 XT and the drivers but now i have the same d3d device error. I have also tried to reinstall the drivers but nothing has worked out so far. Currently with 19.8.2 it does not work either. 

Running 5700XT with 3700X.

Journeyman III

Exact same problem, 3700x and RX 5700XT, worked for first 2 days now I'm getting this error and can't fix it.

Adept I

Hey guys, I've had this issue and also tried all the work arounds to no success.

I figured out what's causing this problem. It's the Radeon Anti-lag feature.

Go to AMD software, Games, CS-GO, and deactivate Radeon Anti-lag. Now the game should work.

You can always activate again it in-game. Spread the word.