Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

XFX RX 480 only works with driver 16.10.1, everything else causes code 43, or fails

I got a RX 480, The only driver that will currently work is the WHQL-Win10-64Bit-Radeon-Software-Crimson-16.10.1-Oct13, that i had to manually install through windows device manager. Any other driver i install through amd after restart it reports code 43 in DM, and if i try to install any other driver through DM , after some time my screen will turn off then back on only not taking as long like the driver i can install successfully. and it reports windows has stopped this device. So i am not to sure what is going on,

I have used DDU and AMDs cleaner utility, Stopped windows from updating the driver, and have had let windows install the driver same results.

Also tried multiple clean install of windows 10, a friend suggested i increase my virtual memory to  min of 8GB but that also did nothing to help, my mother boards bios are also updated, and i updated my SMS BUS, so im not to sure what else i can do at this point.

PC Specs.

FX 6300

hipro HP-W700WC3 LF 700W

asus m5a97 r2.0

2x 4gb 1600 cas 11 really don't know the brand off hand

did notice some weird things in GPU-z

but everything thing seems fine  in the sensor department


and under load for a little bit


5 Replies

First 2 images are 404 not found, third image is gtx970.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Journeyman III

sorry about that seems GPU 7 doesn't keep the images around for long.

Here power usage after a full day under load


and the info it outputs about my card, i just assuming some info is missing cause im using old drivers



ehh and those failed to upload

card info

info —

full day of load

480 —


There should be a switch on your Card, to swap between the UEFI BIOS (both are identical without flashing just as a note)... try switching to the Secondary BIOS.

It's possible the Primary BIOS has become corrupted, thus the Drivers (using the new Hardware Info TK) don't recognise it as a Reference / Retail Device.

Happens from time-to-time, especially with Dual BIOS Cards... although not sure why they tend to be more susceptible.

Anyhow if that does resolve it, use ATIFlash (Win) to backup the BIOS... Switch it Back and Replace the Primary BIOS with the Secondary BIOS Image.

Always good to have a backup available.

Thanks for the info, i did switch it over, i was still getting the same results, but didn't realize there was a switch, what did end up ultimately doing it was when i was following your directions and doing some googling, i ended up using atikmdag-patcher and that fixed it.

What I did Exactly!

Run DDU and Restart

Installed the latest driver through AMD and Restart

After Restart, Code 43

Run atikmdag-patcher.

I Myself Just disable my RX480 then Re-Enabled and it ran fine, then restarted my PC

I'd suggested just restarting after running atikmdag-patcher

from what i found out, my problem was caused by previous owner flashing the bios.

Thank you for your help!