Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Sapphire RX 6800XT Nitro

Hi I am kinda lost on this. Just bought a Sapphire RX 6800XT Nitro everything was fine. When i moved it on my new rig. The fan RPM always reads 0 RPM even though fans are spinning. Fan control whether manual or fan curve set works well. The problem is it only reports 0 RPM. Have checked it on multiple monitoring software like adrenaline, HWinfo, Trixx and GPU Z it only reports 0 RPM. Also, i physically checked the card and did not found any loose connections.

*I noticed when i disable the zero rpm feature via adrenaline and then set a custom fan curve save as profile, restarted the system and it shows the intial rpm read then gets stuck on that number. (example after restart it shows 589 rpm all the while)

To summarize it, fan rpm reporting is broken but fans are functioning well.

Is this a driver issue or could be fixed with a driver update?

11 Replies

It could be a bug. 

I would try to install the driver again. Use the Factory Reset option and see if that helps. 

I not report the bug to AMD:

In Radeon Settings there is a Bug Report tool too you can submit the issue or

You can contact AMD support here:

Good Luck!


Thanks for the response. I did DDU ,reinstalled the driver multiple times selected factory setting, also used 3 different drivers. 12.1,11.3,11.2. It did not solved anything.  Yep, already reported this via the bug report tool hoping for a driver update would solve this.

Journeyman III

Try going into the radeon software and turning off the zero rpm setting,, under performance/tuning 

I was a little confused and had the exact same problem earlier today after installing my brand new RX 6800 XT Nitro +


Turning the zero rpm setting off worked fine I have since turned it back on again and the fans are working fine, It's just how it's designed. There is nothing broken as far as I can tell!


Thank you.

Adept I

Out of curiosity that card has dual bios for a performance mode and normal mode.  Have you tried shutting down and switching the bios setting on the card itself and see if that resolves or alleviates the issue?

Journeyman III

Hello, any solution i just face the same issue with RX6800 Sapphire..

Same issue with 6900 xt nitro.  😕

Journeyman III

I got mine working all perfect now,, all I did was uninstall gigabyte fusion 2.0 and restart, now I have full control on the sapphire trixx etc, leds and fan settings all work, as does the save and change bios option. 

Had a small issue with now controlling ram rgb but the gskill ram program fixed this except for sync. 


That helped, uninstall then i open Trixx app to test the fan. sync with AMD software. And reinstall RGB Fusion. was okay for awhile. but nope, this RGB Fusion is trash

Journeyman III

Hi, (Already fix this bug)

Also have this bug with my Sapphire rx 6800, I never tot that this is a hardware fault like you said when I modifying the fan curves it work, including in this bug is the LED bug.
0 rpm even running and LED can't change in TRIXX.

Solution : 
1. Set ur manual fan curve in the adrenalin.
2. Uninstall Trixx, adrenalin (dont do factory reset just simply uninstall), RGB Fusion
Restart to BIOS. (only if u are running Aorus board)

3. in BIOS , go to peripherals then forced the RGB fusion to OFF. (reboot)

4. Install adrenalin first, then observe the fan speed while running stress test (just to force the fan to run)

5. if you see that there is a RPM, you're good to go. 
6. Install TRIXX, and run the fan test.
7. go to Nitro Glow and checked if the lightings are working.

Thank you for the previous replies, big help!

I just purchased a Sapphire Nitro+ 6800XT, using it with my Gigabyte X570S Aero motherboard. I also see 0 RPM for all fan indications in software that shows it (Adrenalin, HWinfo, overlays etc). Unfortunately I cannot find Sapphire's Trixx software on their website anymore. They must have pulled it, so cannot check with that. 

To be honest, I hate RGB, but since you don't have a choice these days, I installed Gigabyte's app center to try and "unify" my RGB control. 

Removing the Gigabyte software to see if it will help.