Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Sapphire RX 5700 XT Pulse fans issue


I recently bought a Sapphire Radeon RX 5700 XT Pulse and I have a problem with the fans.

They randomly go to 100%, often when I'm not playing, just crusing on the web. The temperature of the GPU is around 45-55°c when it happened.

It's very frustrating.

Moreover, whatever I choose on Adrenalin to control the fan speed isn't taken into account.

Please help me,


11 Replies

1. Use GPU-Z and open it

2. Click on "Save Bios" below the logo near UEFI

3. Open MorePowerTool and click on "Load" it will tell you to find the Bios you saved earlier

4. Now everything is selectable and just do a check for "Zero RPM" you can find on each tab also change

"Zero RPM Control" from 0 to 1 

5. Once done click on "WriteSPPT" and exit.

6. Reboot your system and open your "AMD Control panel" go to tuning disable "Advanced Fan Control" or similiar and now you'll see "Zero RPM" uncheck it to disable it your fans should now spinning. After that create your own custom fan curve.


I hope it helps you and I explained it to you well.

Ekran Alıntısı.PNG

i did it and it works.
just download gpu-z
and morepowertool programs

Thanks a lot for this, but it doesn't solve my problem... look at the overlay, 33°c, 3000rpm... And my custom fan curve doesn't want this. Sans titre.png


go back 19.2.2 and try it


Hi, I couldn't install it, it looped when it was reseaching the last drivers. I sought on forum what is the best driver and many told about 19.7.5, so I install it but my problem is still there...

I'm currently writing whit that jet noise rrrhhhhh

Adept III

I same this problem with rx 580. Bugged drivers....

Adept I

jaydeejoy‌ which gpu model you have? I have the 5700 pulse on the latest radeon drivers would that work for me?

pullnd‌ have you tried with the 2020 drivers? the person that answered your question is using it, your using 2019 version according to the image you attached.


Hello guille92h‌, yes I tried with many drivers, using DDU to uninstall the current one. Same issue at each time...

BUT, I create a ticket to AMD support and Sapphire support. AMD asked me to use AMD Utility to uninstall my current driver and install the the last driver (19.12.2), without network connexion and with my antivirus disable during the installation.

I made this yesterday around 5pm. I was on my computer all the evening until 10pm and the problem didn't appear. So it's a good news, I will be attentive the following times I use my computer and I hope fans don't run at 3000 rpm at any time !

I'll keep you posted.

Adept I

Ok, i did as jaydeejoy‌ said with morepowertool but the zero fan slider doesn't appear, but now my fans are all the time at 22% of speed doesn't matter which fan curve i put, except in idle that the fans stop(this is good because i don't want the fans on idle which for me is 30º) but when i play a game the gpu goes up to 70 and memory temps go to 82 because of that issue, at least is an improvement with the stock fan curve was bad also as the memory got to 88 because didn't start spining till the junction temp went to 60, as some of my games use a lot of vram memory but few gpu, now at least got down the memory temps. Wattman show different rpms to what really is happening with fans stopped shows 600 rpm, i tried putting the fan curve at 80 % on low temp so i could make sure that the fans were kicking up and wattman shows 1400 rpm, but i don't hear the fans spin faster and the motherboard is telling gpu fans at 22 % still, and in case you say it, i pressed apply changes.


do this step by step









Adept I

Thank you very much jaydeejoy .

Now it worked, but after doing all that i had to leave the zero rpm slider in wattman and use msi afterburner to do the fan curve, that's good because afterburner allows me to put fans at 0 in idle and has more posibilities to do a custom fan curve since i can create as many points as i  want for the curve.

Journeyman III

I am detecting hardware the now to install driver but won't detect software.