Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

RX 6800 Black screen under load

So not the first one to get this issue, there have been countless topics about this, and AMD has been a bit silent on this lineup. Would we be seeing any driver updates this month? 

To summarize the issue:

During gaming, all monitors go black, the GPU fans sometimes swing at full speed or remain at the same fan level, all lights are still on, the audio cuts off 4-5 seconds after that happens, then the lights turn off. I can't do anything except hard reset the PC

I've mostly noticed this happening under heavy load (GPU usage 80-100%) especially with a video playing in the background. This is not mandatory as the black screen crash could happen randomly within 5-10 minutes of gaming

Tried all possible solutions so far:

Manually updating drivers
Windows reinstall
CMOS reset
GPU reseat
Separate Power cable + reseat
XMP disable
Bios reset
AMD Drivers without Adrenalin
Windows Update

1 Solution

I RMA'd it and AsRock confirmed the card was defective.

View solution in original post

104 Replies

Hello, I have a similar problem.
When playing Rust and browsing Twitter on Google Chrome,
Suddenly black out and system will reboot with headless(blank screen).
To recovery from this symptom, need a power cycle.
I hope it's not a hardware problem.

Reproduction procedure:
(Desktop resolution is 3840x2160)

  1. Launch Rust with windowed mode 1920x1080
  2. Join any servers
  3. Launch Google Chrome and open the Twitter
  4. Repeat scroll up and down the timeline of Twitter

My rig:
CPU: AMD Ryzen 7 5800X
RAM: 32GB 2x Team TEAM Vulcan TEAMGROUP-UD4-3000
                     2x G.Skill Sniper X F4-3000C16-8GSXWB
M/B: ASUS ROG Strix X570-F Gaming (FW Ver. 3402)
Graphics: ASRock Radeon RX 6800 Challenger Pro 16G OC
SSD#1: Western Digital WD Black NVMe WDS500G2X0C
SSD#2: Western Digital WD Black SN850 NVMe SSD WDS100T1X0E
HDD: Toshiba DT01ACA300
PSU: Corsair RM750x

Radeon Software: 21.2.1 (I also tried 20.12.1 and 21.1.1)


First, do not mix brands of RAM. Run one or the other brand and type. Doesn't matter if the speed is the same, internal timings are different. Post back after you clear CMOS and pick one set to run. 20.12.1 is a good driver for my Gigabyte Windforce RX 6800 Gaming OC. Be sure to use DDU in safe mode to remove the current video driver or when switching drivers, which shouldn't be necessary at this time. No current changes for your setup in any newer driver than the one I posted. 

Link for DDU: Display Driver Uninstaller Download version (

Also RUST is a high CPU title, don't expect huge gains in FPS. It's a game issue not hardware. Windowed mode can cause some issues in games as well, try full screen. Future driver release's might address some games. You can submit a bug report via the Radeon software, fastest way to get a driver issue response.

"It worked before you broke it!"

Thank god this thread exists and everyone here has been posting great info. I thought I was going crazy. Bought a new Seasonic 850W PSU to replace my EVGA G3 750w and everything.

Did a DDU a couple of times, tested cables. I will try some of the overclock and undervolt fixes. New driver came out today so we'll see if that helps.

I also have the Asrock Phantom D 6800 so I feel like it's got to be a driver issue. Let's hope it is. Will update soon with how I get on.


Another guy bought the AsRock on here and nothing worked but RMA and he bought a Gigabyte Windforce RX 6800 Gaming OC like mine. Problem solved.

"It worked before you broke it!"

I read that. But stock is so rough in the UK right now and everywhere else that RMA and a different card seem so far away.


Still crashing under Feb 2 Adrenaline driver and L02 vBIOs and maxing clocks with Mins/Maxes etc.

Time to return the card I think...


I have used the AMD cleaning tool (that cleans all AMD drivers in safe mode) and then finally it is now running stable. So, for sure, cleaning up matters... and I keep forgetting it.


@mackbolan777 Finally I could have enough time, so I removed one set of RAM, cleared CMOS and Reinstall driver with using DDU.

Also I tried to update chipset driver to, update vBIOS to L02,  but still have a problem.

I noticed Q-LED in the Motherboard indicates VGA error when rebooting after problem occured. So it might be a hardware problem.

I already sent multiple bug report to AMD, but should I contact ASRock?


Try swapping the RAM you pulled with the other RAM. Just to eliminate any RAM issue. Make sure the card is fully seated, especially in the front that the metal tabs are firmly into the case. I'm unaware of any vBIOS updates for the RX6800. I would contact AsRock after you verify the previous. It's possible your PSU is defective because that unit has capacitors in the cables. So contacting Corsair might be a good idea too. 

"It worked before you broke it!"

I swapped to other RAM and checked card is fully seated.

Also there was a spare of PCIe PSU modular cable so I replaced to it, but nothing has changed.

I will contact ASRock support, but unfortunately support desk on my region is closed for now because of Chinese New Year, so It will take time. 


Update: I swapped PSU to Silverstone SST-ST75F-P(750W) which was pulled from my old machine, but same thing happened.

It's more likely VGA or Motherboard issue.


Probably the GPU at this point, a lot of RMA's with ASRock cards. If it were the board, no card would work.

"It worked before you broke it!"

Just an update on my Asrock RX 6800 Phantom Gaming, retailer RMA'd it. Sent a replacement. All seems to be working well now. Discord, Streamlabs and freesync after about one evening of testing. Apparently it was the card but I've never seen this before. There's always a first time I guess.

For context I had tried every single option, reseating, DDU stable drivers, DDU new drivers, vBIOS, clock bracketing, new psu etc. This was the only thing that has worked. I'd inform Asrock, their support are listening if a little slow. Hopefully they'll improve in the future.

Ha, their support is ridiculously slow. Slower than AMD if one can fathom that.

"It worked before you broke it!"

I have an Asrock aswell.. Same problem... Unfortunately I bought mine used


Another guarantee crash for me is when I'm streaming to discord, the millisecond someone joins my stream.. Black screen. 


You're not wrong. Thanks for your help though @mackbolan777 and everyone else in this thread.


Yeah, exactly the ptoblem I was having. Where did you buy it second hand? You could try contacting them, your credit card company if you bought it with that or try Asrock directly?


Hey @cloudcard, did they replace it with the same card?

My retailer has sent my Phantom Gaming D to Asrock, as they haven't discovered any issues on their end... This is so so so weird now


I'm also experiencing black screens under load ever since I updated Asrock RX6800 PGD to latest vBIOS (L02).
Didn't have any issues on previous vBIOS. For days now I'm trying to get Asrock support to send me original vBIOS, and all I'm getting are some generic answers, they seem to be oblivious on the matter.

Someone on MSI forums saying that at least AMD is aware of the issue and working on the fix.

As a temporary fix I had to lower power and frequency for about 10-15%, no black screens for now.

Hope fix will come soon.


I experienced black screen before and after the new vBIOS from ASrock. But my black screen now happens when running two games at the same time usually. I can play WoW in the background and Apex actively and I crash, or WoW and another MMO like GW2. I do this fairly often, and it irritates me that I spent over half a grand on a GPU that can't even handle two games at once. Maybe the culprit is my 750W PSU? EVGA G3 750W to be exact. 


I RMA'd it and AsRock confirmed the card was defective.

Sorry for bumping but my problem is not solved - should I make a new thread or stay here?


I tried this method, using adrenaline by going tuning to Auto and undervolt, so far so good. 


Maybe it is asrock, maybe it isn’t, but I have an asrock challenger pro rx 6800, and have the same black screen issues. So for BDO the game will run for about 30 - 40 minutes and then just crash/black screen. Now when I open smite in 64-bit, it’s an immediate crash, but when I open in 32-bit, the game will run just fine, no crashes what do ever. I haven’t tried other games yet due to just finishing the build and installing those two because I play them the most


@Centered Could you please try this and check whether it crash or not?

How about when reduce Max. GPU frequency to 1905 MHz manually?

Adept I

FWIW. 2 years of black screen since the original build (followed by high fan and having to hold power button to turn off) very intermittent often happening during web browsing rarely during gaming, for me it was more when I switched from one thing to another and the video screen had to flash like alternating between tabs on a web browser, or moving from one game to another).  (b450, ryzen 5 2600, rx580, 2 monitors).   I've upgraded the bios, changed PS, changed gpu, changed ram, and new display cable.  Gone through many gpu/adrenlin drivers.  (did the amd driver clean up).   The most recent adrenalin update really got the problem going again frequently.

So I tried something different!!!!  I used the display driver for my actual monitor from the mfg (in this case dell) not the windows 2006 version that windows wanted to use.

I'm 3 days in no black screen. Now using adrenalin auto overclocked gpu setting all the time.  Maybe this is short lived.  But I've been pushing it hard having multiple pages up streaming multiple different things, trying everything that I use to avoid.

As many have suggested there are probably many different reasons for this problem.  But maybe just maybe this will fix some.

Thanks for chiming in, hopefully it helps other people, sadly it didn't help with my problem


So you see running Battlefield it doesn't crash. Reason is the game engine uses the GPU more, like a game should. Try turning the settings down in the other games and see if it makes a difference. In any case that AsRock is messed up. I play games known to be somewhat CPU intensive and don't crash at what some call "insane" clocks. Of course I'm at 1080p, so if you're pushing 1440p, it might be a problem running full on "eye candy". 4K is a known not happening very well deal unless you have an XT. I have the "AMD Insider" sales PDF on these cards. 4K you need a RX 6800 XT or better. The RX 6800 is a "half circle" for 4K meaning some support and not recommended.

"It worked before you broke it!"

FYI - after changing nothing in my system at all, swapped in the Gigabyte Windforce 6800 and 100% perfect stability.  No problems at all.  My Asrock Phantom was bad... but would still work occasionally.  Very odd problem. 


That sounds awesome

By the way, did you try to underclock the old card to see if it's stable?

Seems like that's the only temporary solution I got with mine, running below 1900MHz is okay, but the GPU is severely under-utilized that way, unfortunately, and I can feel the performance dip as well


Alright, one more update:

It seems like I can keep the card kinda stable at max clocks and fully utilized if I don't run any HW accelerated apps, or they are not on screen present: 

In fact, clocks haven't been touched, the max clock the GPU got itself to was 2225MHz, just a tad bit above the advertised 2190 "OC" advertised clock btw

This screenshot was taken a moment before I made it crash actually, what I did was I opened a Chrome tab with a YouTube video (not yet loaded in), and the moment the page loaded and the video started playing, I black screened

What I kind of forgot, I'm using Franz, which is an Electron and HW acceleration iirc, which kind of explains the previous crashes without any videos playing

I also did some clean up of any software just to make sure it's not a bluff, removed iCUE, background apps, and so on

This kind of seems like a driver problem at this point, not a hardware issue

Edit: nvm I just crashed again, screw it, I'll RMA the card, can't be arsed anymore



Dude, you have GPU tuning disabled, that needs to be on. Set the min clock to within 100Mhz of the max clock, it stops spikes. It looks like that voltage is way low, needs to be about 1.000-1.025mv, slide the power limit to max. VRAM is default and it should be set to "fast". Lastly, you might be more stable at 2100 VRAM believe it or not. Manually limit the max GPU clock to 2200 and set the min to 2100, see if that's stable after fixing the voltage issue and VRAM timing. I use driver 20.12.1 and don't have these issues and you've seen my settings.

"It worked before you broke it!"

Ah no no, I was just further testing around with/without sliders and so on, this was just yet another attempt at "what if the core clock is alright, but memory clock isn't"

I tried all sorts of underclocking/undervolting/overclocking, including setting up clocks to 100MHz difference, that ain't it, also that's a pretty scuffed solution. The card should be working at all sorts of core clocks, including going from 0MHz to 1900MHz for example, not only at max/min/med or whatever

I already RMA'd the card last week, still awaiting the provider's response on the case

It should work as intended out of the box, mine did. I purposely found that not having the rapid swing in GPU clocks and voltage gave me a huge FPS increase, lowered temps, and didn't harm stability. The changes I suggested usually iron out stability issues on unstable GPU's, which is why I mentioned it. The moving of the clocks closer is not a "scuffed" idea. It works if ~20-40+ FPS is what you're after and zero micro stutter. AMD "partner" cards all come set different, yet the same PCB is under the hood. I avoid certain companies in my builds based on years of experience in what works smoothly and what doesn't. I like staying in the 99% "it will work out of the box" category over price and other factors.

"It worked before you broke it!"

Yeah, I know. I do the same.

But in this case it is becoming more and more evident that something is to do with the drivers.

Today I will be running without them to check if it stops freezing after 7/8 hours.


I would say the card or brand of card. Mine has no issues, same basic card.

"It worked before you broke it!"

My 6800xt got black screen randomly until i upgraded my psu from 800w to 1200w.

Then all problems stopped and now all games work fine.



Anyone using aida64, this is worth a read.


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..