Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

RX 5700XT not working properly.

Hey everyone,

I recently build my first own PC and unfortunatly have some problems. Sometimes when I try to play a game my PC is not able to run it with more than just a few fps. When I restart my PC several times, it sometimes suddenly works again. I also often get the "video_tdr_failure", with the reason "atikmpag.sys". And when my system is not working properly it needs quite sometime to shut down.

My specs are: 

GPU: MSI 8gb Radeon RX 5700 XT mech oc

CPU: Ryzen 7 3700X WRAITH AM4 B (using the boxed cooler)

Motherboard: Asus PRIME X470-PRO

With a 850 Watt power supply and 16gb gddr6 Ram with 1755 MHz and Windows 10.

Pls let me know if you need something else.

I believe the problem lies with the gpu since everything worked fine with my old gpu (radeon R9 370), but I already sent in my old 5700xt and got a new one because I thought it was defect, but its still not working.
I also tried using different drivers, starting with the 19.9.2, went down some version (I can't remember every version I tried) and am currently using the 19.7.5 version, which is still not running.

I also tried switching from the new ssd to my old hdd, which unfortunatly also didn't work.

I have no idea, what I should do (not a computer genius unfortunatly) and could use some help.

Thanks to everyone in advance!

10 Replies
Adept II

Return the 5700 XT and stick with your old gpu or buy an RTX. This piece of junk isnt even near consumer ready with the whole stuff like audio stuttering in spotify, netflix etc., BSOD, System freezes or complete kills, after doing everything in my might with my setup, after removing that junk of card and changed back to my 1070 not even one of the named problems even happened once.

Journeyman III

I don't think I'll get my money back since my purchase was about 2 months ago (I tried fixing it since then) and I don't have my old gpu anymore. There has to be some kind of way to fix it...


Hi Davewe.

Which games are you trying tó play?

There is a thread here on the forums which explains alot of problems with Navi and older games.

I'll see if I can find it, maybe your problem is sort of the same, but I don't know which games you are playing.



Hey taurea,

I have the problem with every game I tried, being

Dark Soul (every title)

Wow (both)


Civilization V

Battlefront II

The thing with the lower graphic games is that those are running alright, just with about 50-70  fps and sometimes the frames collapse. But I think I should have more than 50 fps in Lol and Wow and when the system is running just fine I do have about 200 frames. 


nin, i currently have rx5700xt and i had similar problems but i fixed them and everything works ok, you don't need to give your graphics card only you need to be able to fix it, for your knowledge nvidia had similar problems two years ago and it only repaired after four months


and for your knowledge, the "atikmpag.sys" error in AMD/ATI Driver is still present for more then 5 years, maybe they'll fix it and dig it up somewhere else, so thanks for your input


haha, I write stupid things and for the last 5 years I have never had problems with atikmpag.sys, this error is caused by the browser and not by amd drivers, just change the settings and everything is ok

I understand your frustration mate, I feel it too, trust me.. But this is not helping.

Journeyman III


If you active performance monitoring with the radeon software and u make ctrl+shift+o in game, what is your % gpu ?

Adept I

AMD does not respect its consumers, do as I did, sell this................... and buy an RTX!