Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept III

Radeon VII v106 vBIOS not automatically updating

I have downloaded the v106 (64 bit) Radeon VII vBIOS from AMD and run the .exe as administrator, but it is not updating my vBIOS. A command prompt opens after I click through two Win 10 warnings, but there is no indication in the command prompt that anything was run and it closes virtually straight away. When I restart and check my BIOS in Radeon settings, it still shows the original v105 (non UEFI) BIOS. I suspect it is an issue with Win 10 (1809) rather than the BIOS .exe file, but I would in interested if anyone else had this problem, or knew how to solve it. 

12 Replies
Community Manager

What do the two Windows 10 warnings you have to click through say ?  

Have you tried using the x86 executable?


Hi ray_m,

I enabled Record Desktop in Relive and used it to capture what is occurring. I only am now seeing one Windows 10 warning. Please have a look at the attached .mp4 file.

I noticed that just before the Command Prompt closes the text 'Invalid Package.' appears.

I haven't tried the x86 executable. I would guess that I need the 64-bit version - otherwise why post two versions?


You can use the 32 bit package, it installs the exact same VBIOS, just using a 32 bit installer.

Thanks for the tip ray_m. I tried the 32 bit .exe, but got the same 'Invalid package.' result. I did see the second Windows Warning, see below. I clicked on 'More info' and then 'Run Anyway.'




I took a look at Event Viewer and found the following:

The description for Event ID 1060 from source Application Popup cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

The following information was included with the event: \??\F:\AMD RADEON\Radeon VII BIOS\amd_radeon_vii_bios_v106_x86\

And also (perhaps more importantly):

The atidgllk service failed to start due to the following error:
This driver has been blocked from loading

Adept I

I had the same issue using the 64 bit exe , I downloaded the 32 bit also called  x86  and it works just like ray_m mention.

Journeyman III

You need to restart your PC,when finished THE VBIOS update.


Hi odin_74 - thanks for the tip, but I already did this.


Interesting. I didn't check this after running the bios software, but I too still show v105 instead of 106.

Adept I

higgih01, I see what you are trying to show us now that you show the pictures. Here is how I updated my bios, I extracted the files in the zip file to a folder called vega in my main C: dir.... I then typed cmd in search windows, right click on cmd and run it as admin (Important you run as Admin to give you rights to install)....,  it will kick you to c:\windows\system32>....

Type cd\ hit enter it will send you to C:\> than you will type cd vega (the folder you created that has the new bios.exe and files) hit enter...

you should be now in c:\vega>  now type AMD_Radeon_VII_BIOS_V106.exe  hit enter it will launch the executable and flash your vega 7 to the newest bios. Remember to restart your computer after the executable is finish.

Hi rombat - thanks for the great tip. It solved it!

Executing the .exe from with a Command Prompt as admin did the trick! Many many thanks. My Radeon VII is now UEFI compliant!


Adept I

my Radeon VII shipped with bios 1.06 but experienced crashing in certain games until I downgraded the bios to v1.05