Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

Radeon VII forced reboot after black screen, during games

I'm seeing the posts about the black screen bug that appears to be plaguing the Radeon VII drivers, but has anyone experienced a sudden reboot when this happens? I'm trying to work out what might be causing it, given my system *should* be operating correctly.

What happens is, during some games, my screen will freeze for a second, display is suddenly lost, audio continues for another couple seconds then stops, then the system simply reboots itself. I'm not certain this is a driver issue, but would like to hear from anyone who's had this too. If you have, it'd be great to know what the specs of your machine are too; the comparison might help diagnose the issue.

Most recent game that had this issue was Battlefront 2 2017 after maybe 80 minutes of gameplay; unlocked framerate, ultra settings so it would have been running at full capacity. This has happened across several driver versions, but is still happening on the latest 20.1.1 driver. Not sure when it started.

My rig:
- Ryzen 7 3700X
- Sapphire Radeon VII @ stock clock/voltage* (1075mV)
- 16GB HyperX Fury DDR4 @ 3200MHz
- ASUS B450-Plus TUF Gaming
- EVGA G3 750

* I have tried undervolting to 960mV which was stable for a while, then the black screen started happening and I assumed it wasn't getting enough power, so incrementally increased the voltage again

52 Replies

Try the 19.4.3 driver.  That had the best stability for me with the Radeon VII.

Thanks for the response. I'll keep this in mind in case the 19.7.5 driver crashes; I've just installed that now and giving it a go as I heard it was good for some people.

Did you try the 19.4.1 driver? I don't know how different 19.4.3 will be, but I heard 19.4.1 was good and I've had crashes on that too.

Adept II

My Radeon VII is stable with the 19.11.3 - every version with 20up is unstable and reboots when i need the power (Gaming or COMPUTE) . 

R7-3700X&AGESA1.0.0.4B+32GB RAM+750W beQuiet DarkPro PSU+VII with standard frequencies/voltages or UV@990mV...

I sended error reports to AMD Support because of the reproducible application errors of Radeonsoftware.exe and reboots(black screen).

AND: with the 20up versions there is no Compute 2 section in the Taskmanager at the GPU section anymore.
Just Compute 0,1,3. This "could maybe" be one of the reasons the VII/the whole system crashes and reboots when there is full load on Compute units. Users with 5700XT and Vega 56/64 don´t have Compute 2 too.

With the "old" 19.11.3 the Compute 2 section is active again and i can game and compute with full power without reboots and errors. (BUT i can´t use AMD LINK because of the "new" App-Design/requirements ).

Huh, I didn't even know these stats existed. On the latest 20.2.1 driver now and similarly Compute 2 is missing. I'll try 19.11.3 again and see if unit 2 is accessible again.

Adept I

I've had numerous problems just like the one you describe through 2 distinct systems, 2 different Radeon VII cards (RMA-ed one) and many versions of the drivers... 

I've had my 3 screens blank to black or freeze (audio keeps going) then reset the displays and continue like nothing happened or alternatively crash / reset the system.

I've also have had so many BSD's that I can't count them - from 1 every hour to 2 a day dependent on which driver I'm running...

Decided to NOT install Adrenaline software and just let Windows install the default drivers (26.20.12028.2 dated Aug. 16 2019 - as reported by windows) and that's calmed the crashing to only about twice a day now...

I've reinstalled my OS from scratch ran tons of memory testing utils but still can't get a stable system - Loved the idea of this card and it's 16GB RAM for editing in Resolve but looks like AMD just produced a lemon here... Sigh...


Asus Z9PE-D8 WS MB

Dual Xeon E5-2670 v2 processors


Windows 10 Pro

Just installed 19.4.3 as suggested above and shortly after all screens went blank had to soft - reset and windows re-installed older version - had to reinstall 19.4.3

Similar experience.  With drivers post 19.5.1, my overclock settings would become unstable.  Any overclock on the Radeon VII would result in game crashes, with a "graphics device lost" error message.

I installed the upgraded software package included in driver 19.12.2 along with a clean install of Windows.  This would lead to system hangs when web browsing or just idling on the desktop necessitating a hard reboot.

I eventually rolled back to 19.4.1 using the DDU to remove the "updated" drivers.  Everything works normally.  Not a single system hang or crash.  No driver error messages when running a 200 MHz overclock either.  Everything just works.


The amount of variance in card performance with the Radeon VII is astounding. The 19.4.1 driver worked for me for about 1-2 days before crashing again. Honestly not sure about going ahead with a full Windows reinstall as it just simply shouldn't require that, I don't understand.


Hi maybe you can try the program called "whocrashed" to analyse dump that don't gives you a blue screen because of a graphic problem

when I have this type of blackscreen (but for me never had it in game , mostly it happens when I first start my computer in the morning , computer takes longer to start and then crash in the 5-10 minutes , then when it restarts everything is normal then and it doesn't crash for days)

it's allways because of the "video_tdr_failure" problem ,

as i was reading this thread , i remembered that before 2020 adrenalin my pc was booting normally, so I just reinstalled 19.11.3 (and compute 2 is back again too   ), now I will test and shutdown for 1 hour or 2 and see if next boot is problematic or not ...

maybe this "compute 2" thing is a good clue for amd to search for!

Journeyman III

I'm going to try the 19.11.3

This is stupid, it's been over a year and they can't bother to sort this out?

Adept II

AMD 2020 Edition V. 20.1.1 - Dang it's happening on this Version? I'm running that now, 
it was reported to have very little to no Problems with it... 

I guess, someone goofed with that Update... 
Correction, it was I think V.20.0.1 or V.20.1.0 or something... 
This V.20.1.1 Update is Plaguing my system, it was an Update I didn't want, but 
it Updated without me knowing... 

Here is the Release Notes for V.20.1.1 If you have any of these problems, then 
it is likely the Driver Update you Installed that caused it... 

The Radeon Software Overlay hotkey notification may sometimes be displayed during video playback in web browsers or launching some video player applications. 
Factory Reset Install may keep previous configured Profiles. This can cause mismatched Global Settings & Per Profile. 
Text Overflow in some UI Boxes such as Toast Messages may experience Language localizations. 
Some Vulkan Games can Crash when Task Switching While Image Sharpening Is Enabled. 
Web Browsers & Discord can cause Black Screens while Gaming or On Desktop.. Fix? Disable Hardware Acceleration. 

A Number of Games could be crashing or Failing to Launch... 
-Trials Rising 
-Tetris Effect 
-Atelier Ryza 
-Many Others 

Sadly, I saw not one Fix in this Release for Specifically Radeon VII GPU's... 

[/Edit]"Ya, AMD 2020 Edition kinda was not exactly my most favorite Edition, these Slider Options are not Enjoyable, I miss having the Boxes to Edit,
because If you have an X & Y Option using sliders is not going to get you even Results if your working with or trying to form a Square Box, as well
as Radeon Chill is also a problem here as well. 2019 Edition so far seems to be much better. Currently i've only been jumping Updates that have little
to no problems with them, the sad thing is? I loose Support for Games when I go back to certain Updates. If these 2019 Versions work, then the GPU
must be a good GPU, those bad Drivers aren't the GPU's fault, it's a Driver Fault."[Edit]


I have been trying out the 20.2.2 driver package and have had no issues so far.  The overclock on my Radeon VII appears to be working with no issues.  No black screens to report so far.  I do have the minimum GPU clock pushed up by 5%.

Journeyman III

I still have this issue on the 20.2.2 drivers. So far seems to be limited to Civilization V, which seems to cause it often.


Ryzen 7 2700x (no overclock)

Radeon VII (no overclock)

16 gb memory

ASUS ROG Strix B450-F


I'm stable if I run only with a single monitor plugged in. Running any more than one monitor will give me black screens randomly. I've tried many different catalyst drivers and none really seem to eradicate the issue completely. For me this includes the latest 20.2.2 update. All the troubleshooting I've done just simply points to flakey drivers.

Adept I

AMD had me to a DDU Clean/Restart with an installation of the latest drivers (20.2.2), TDRDelay modifications in the registry, disabled "Fast Startup", and doing Clean/Selective Boot tweaks (which I've already been doing). So far had a couple of hours with a game that consistently produced black screen crashes that 50/50 on a dump file being created. We'll see how my usual Friday night goes.

Thanks for your answer. I’ll try these steps to see if it helps me as well.

Adept II

So far I’ve been stable for a little while, but doing a lot of gaming on Linux. On Windows I’ve had to remove the DisplayPort cable for my VR headset. After seeing the reports of multi-monitor setups causing significant problems, I thought I’d try since that’s essentially a second monitor to the graphics card.

Seems to have helped, and I believe I’m on 20.2.1 still. So if you have multiple monitors, try reducing the count down to 1 to see if it changes your crash situation.

Adept II

To anyone who is following this thread:

I've discovered that my problem may be directly related to my Oculus Rift S, which had been plugged in and idle when not in use. The Rift S appears to be crashing my display drivers (so both displays are screwed) because the device isn't getting enough power from the USB ports on my motherboard. Unplugging my Rift when not in use appears to have resulted in my system being stable again; I managed to play through all of DOOM Eternal without a crash.

What I'm doing is getting a PCI-e USB expansion card to attempt to deliver the required power to the Rift as it's now just VR that's still crashing (latest driver 20.3.1), and I'll be testing that to see if the expansion card is the fix I need. If it does fix, the card I bought is here: 

For now though, if any of you are Oculus Rift S users, make sure the Rift is unplugged when not in use and it *should* increase system stability (at least in my experience). Even works currently with my core voltage reduced to 960mV in MSI Afterburner.

Thanks for letting us know. 

Adept I

Im following this thread. I found out that the problem was the GPU when i switched from my Radeon VII to a RX 570. The only place where i face a freeze +reboot is on League of Legends. Its insane because i play big games like Far Cry New Dawn in full detail+4k and never got even a single stutter. This card is magnificent but i cant enjoy LoL because of the random crash.  Im on 20.2.2 driver ATM.

system specs: r7 2700x 64 gb ram 3200mhz cl 16, asus x470 rog strix, nzxt hale v2 700w, 1 tb samsung sata ssd.

Amd should do something honestly, there are many places where the gpu fail, i experience one.

People say keeping a minimum frequency helps? i will try that and report back but first i have to put back the gpu on my computer and learn how to do that oc.

Adept I

thank you for posting this. I think I'm experiencing what the OP is. During gaming both my monitors will go black and loose sync, sometimes the screen will freeze for less than a second before this happens. it seems like this has been happening for the last six months but I can't be completely certain when it started. I do use two monitors, guess I'll try disconnecting one just for troubleshooting. I reinstalled windows 10 but that didn't help. This is absolutely crazy for their top of the line prosumer graphics card. at this point I'm disillusioned with AMD graphics and supporting the underdog. it seems to me Nvidia produces products that are stable and optimized right out the gate but performs less optimizations when their next generation comes out. AMD on the other hand produces products that are usually functional and not well optimized up front but will become more optimized with time and eventually surpass the Nvidia competitor. Unfortunately for buyers of the Radeon VII and the RDNA 5700 series AMD is either unwilling or incapable of fixing the Black Screen crashing. I've purchased exclusively AMD gpu's nearly ever year since they launched the 7970ghz edition but at this point I can't bring myself to continue supporting them. I do love Ryzen though.  


Set your driver to default

Uninstall your driver an install this one. 


I spoke to soon. Last night around hour 3 of WorldWarZ display's went black loosing sync and system required a hard reset. the "Who crashed" program shows crash dump analysis shows atikmdag.sys and a second error hal.dll happened at the same time. I will DDU and install the 17-9-1 driver and report back.


That’s a real shame, I was hopeful for a moment you’d got it. I managed to isolate the issue in my setup was literally just the Radeon VII, so I tried replacing it and it’s now resolved.

Not best pleased that this card has such broken drivers, but I think that’s just the reality of it. It’s not stable at the moment.


warsun‌ I DDU in safe mode and installed the 17-9-1 driver you linked, windows does not recognize graphics card. perhaps you linked the wrong driver, I don't see Radeon VII listed as supported.


if you look at my previous comment, we all have some kind of issue. let me tell you what seems to have fixed it to me. Create an specific profile in your radeon settings with the app that causes the crash, then increase minimum frequency to a 100%.

Performance>   Tuning > Add game profile* > GPU tunning > Enable GPU TUNNING+ ADVANCED CONTROL, then increase minimums to a safe spot. voltage and frequency.

*i wouldnt recommend changing this configuration globally. but as long as temps are fine there is nothing to worry.

PLEASE let me know how it goes. i havent crashed in like 3 days with this configuration.


warsun‌ thanks for the suggestion. I did try multiple driver version using DDU between them and the crashed continued, however...

*** Problem Solved***

I found this post 

I've since downgraded the bios from version 1.06 to 1.05 and I've now spent around 30 hours without a single crash.

CPU-Z showed the full bios name 016 004 000 038 011717 for the stock bios and now shows 016 004 000 030 011639.

Hey, after i commented this, i also flashed the older vBIOS (105) and its going smooth. dont get me wrong buy could be been having a strong case of programmed obsolescence?


by "programmed absolescence" I'm guessing you're suggesting overclocking. I have not changed any settings in Catylst or radeon adrenaline software at all, I've just been using the card at stock frequencies, pointless to OC if you're not even stable at stock. I do have it on a chilled loop with current glycol temperature at 4c but the black screen crashes pretty much happen at even at -30c. If it is related to a silicone stability/vcore issue then it's AMD's algorithm looking at temperature and deciding to drop the vcore through the floor, I do not believe this to be the case as typical gpu vcore is 1050mv 'ish.


by programmed obsolescence i mean, amd to release a bios destined to fail. its very unlikely but seeing how short it took them to cut the end of life of the radeon vii, i wouldnt be surprised.

that's a clever way to phrase it, I agree. I'll never understand wtf AMD constantly rolls out new features without first addressing their stability issues. I read some people say it's power play dropping the voltage to low which is responsible for these crashes. In true AMD fashion they shot themselves in the foot again by locking us out of the bios and now the community can't solve the problems for them. efin with the soft power play tables is garbage and not a permanent fix. If I set the same frequency and vcore to all states upon reboot the AMD driver will not even load. AMD Radeon = flaming dumpster fire.


I just checked my card with ATIflash and I'm running 1.06. Going to downgrade and I'll post results. I can replicate crashes real fast by plugging in 2 monitors... Thanks for the information 
Edit: So far no BSOD's but I just got a black screen on both monitor that recovered on it's own. Not even in a game just on the desktop. So I'm going to say it didn't help me. Event viewer shows: Display driver amdkmdap stopped responding and has successfully recovered.

Adept II

Another update: I since managed to confirm that the only problem in my setup was the card after trying an RX 590 with VR. This spurred me into replacing the card with an RTX 2080 super which is stable in VR gameplay.

Radeon VII drivers aren’t stable yet for me, so I guess I won’t be using mine for a while.


f--k this man, how can amd release an expensive gpu in such a shitty state, its a f-kin shame, because the card is awesome, but you cant play without worrying WHEN THE -F-ING THING WILL GIVE A BLACK SCREEN. And having the user do some heavy troubleshooting like switching gpu bios or tweaking stuff that shouldn't be needed to tweak to make it work properly.


I feel you man, this is such a strange situation. The performance is stellar, but only when it works which is far too infrequent to use on a day-to-day basis.

It had been months of troubleshooting for me, as evidenced by the date of this post, but I’d been going even before I posted this. I just got to a point where I had to do something; Oculus support suggested trying a new card, I did and it works. It’s looking increasingly like the Radeon VII was DoA, not just from a sales perspective.


I could not agree more, this is efin redicolus! The amount of time I've spent dealing with this, I'm just done with AMD Radeon. I'm so tired of leaving my squad hanging because my system crashed, and then not being able to rejoin because my spot is filled. I'm tired of running stability tests (GPU, CPU,Memory) that never crash only to have the system crash during gaming.

I'm now on driver 19.4.1, when this crashes and I'm sure it will, I will replace my Lepa G1600 watt PSU for my new Corsair HX1200 just to rule out the PSU and then RMA this POS. The frustrating thing is I just gave away my old Sapphire VEGA 64 so now I don't have a replacement GPU. I never thought I say this but when Nvidia releases the 3080ti I plan to hand over $1200 of fu$ to GPP authoritarian Nvidia and it's purely AMD's fault. I've tried everything I can think of.


You could try what i did, for now, (have passed two days only) i havent got any black screen or freezings+reboot. It might sound CLICHE but it somehow for now worked. Lets see in two weeks how it goes.

There is a new chipset update, the 2.04.

DOWNGRADE TO bios "AMD.RadeonVII.16384.190119_1.rom" (the v1.05 uefi fix)

DDU the system. reboot, install the new "amd_software_2.04.04.111" FIRST. Then reboot.

Proceed to install the newest GPU driver "Win10-Radeon-Software-Adrenalin-2020-Edition-20.4.1-Apr2"

ALL of this with the vBIOS "AMD.RadeonVII.16384.190119_1.rom" flashed with "atiflash_293" (repeat, install vBIOS before doing this process as stated.)

Once you have the GPU drivers running. GO and disable texture and tesselation.
BOTH "use Application settings". Dont let the GPU interfere with these things. Leave everything off or application default, except freesync.

Tell me how it goes. This way i didnt need to overclock and make fixed voltage/profiles for games.

Adept I


I finally installed 20.4.2 as I saw two posts about 2 guys that had no problems with their radeon VII and 20.4.2 ... And I'm pleased to confirm that it's been 3-4 days (24h/24) and no blackscreen happened, no reboot, nothing , it's seem stable for me

playing with oc (2155mhz and 1200 mhz ram)  and working with triple screen , everything seems smooth with these one

(well done ?)