Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

R9 nano black screen


Here is some context. I went cooking and when I came back my computer had a black screen, it was idling on chrome with youtube music.

When I restart the computer I see the BIOS, the turning logo of windows 10 but instead of getting my logging screen I get a black screen. Then few seconds later the screens says no HDMI out and restart automatically. After few restart, windows detects a failure and goes in recovery mode where it asks me to restart or reste my PC. I tried to reset, but nothing worked and it actually revert the reset.

I have made some testes trying to figure what is going on.

In my computer was a R9 Nano Saphire 4Go. I have a spare one and a R9 390 MSI 8Go too.

I tried to boot up with R9 390, it worked great. I check then Windows event viewer.

I have huge amout of "Display driver amdkmdap stopped responding" (event ID: 10016) and an other event ID between them (event ID: 10016).

I tried to start up with my second R9 nano, it works fine. But I don't want to use it because the whine coil is horrible on this one...

I tried to start them both, with the non-working one on my second PCIE 16 slot. I open up Device Manager, so windows was detecting the R9 Nano but it had the yellow exclamation mark. I deactivated the GPU and reactivate in the Device manager, it was saying the GPU was working. I could open Radeon Settings, MSI Afterburner was seing too the GPU but values didn't moved and could not read gpu temperature.

I tried to restart the computer with the defective R9 Nano, but it went back to black screen.

Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz
AMD Radeon (TM) R9 Fury Series
16 GB
Windows 10 Version 10.0.17134
BIOS: American Megatrends Inc.
By the way, 2 days after my return policy ended 
5 Replies

Does sound like it went bad. I'd suggest updating it to the UEFI compatible VBIOS just to rule out a corrupted VBIOS, but with it working fine with your second R9 Nano, that pretty much rules out software corruption as well.

Journeyman III

That's what I thought too.

Any tutorial or link to help me on the VBIOS? I've never done this before.



I've saved a Vbios from a working R9 nano and tried to load it up. Bios change was successful, but the problems where the same. Tried bunch of other more recent Vbios, none worked.

So I tried some cooking! Removed everything, 195°C for 10 minutes on aluminum stands. And amazingly, I nearly thought it worked! I was able to get into Windows 10 for 15-20 seconds until black screen came back.

I won't try further since I have one more, but it was definitely fun to try!

Journeyman III