Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Issues with RX6800 (reference card) - dowclocks, stuttering during gaming


EDIT: My specs are as follows:

MB: MSI B450 Tomahawk MAX

CPU: Ryzen 7 5700G

GPU: MSI Gaming X Trio RX6800

PSU: 750W

In all of the games that I have tried so far, I found I get occasional micro-stutters that seems to relate to the card regularly downclocking itself for no reason. I also noticed periods of mouse clicks (any button, tested with multiple mice and USB ports) getting completely ignored, even consecutive clicks. This also only became a problem after installing this card.

Just FYI, I bought the card used. I have no idea about the manner in which it was used by its previous owner(s).

Reading up on this, it doesn't seem to be an uncommon issue.

I set the min. frequency 100mhz below the maximum frequency in AMD Adrenalin, as recommended by most people. However, this didn't seem to do anything: MSI afterburner still shows the card going as low as 200mhz under no load.

"Stress test" in the Adrenalin software also didn't push the consumption past 120W for the card, which is very odd to me. This card SHOULD be consuming much more in max load.

I tried overclocking the CPU (though later reset due to it causing issues, like mouse clicks not registering. Didn't solve the issue anyway).

I used separate PCIe power cords, connected to a modular 750W PSU.

Any (and I do mean ANY) suggestions you can give me is highly appreciated. I have had some issues with this motherboard before, such as it refusing to boot with an HDD attached. Could a defective motherboard cause such issues?

6 Replies

It does sound like a motherboard issue when you have other problems with it, but you could try a couple of things.

Set BIOS to default and flash latest BIOS version even if you have already done that

You could try disabling integrated graphics from BIOS, because if computer is running both integrated and dedicated GPU, it might cause issues.

When you installed it, did you DDU previous drivers? Remnants of previous installation can cause issues.

You could try to fix some possible issues in files and registry. Winkey+R > type cmd > right-click command prompt > run as administrator > type the following commands

sfc /scannow (this will check and repair system files)

chkdsk /F (this will check file system - it asks to do it next time computer boots, answer yes and restart computer)

You could run this troubleshooter to fix registry issues


UPDATE: I checked the BIOS version on GPU-Z and found that one of the previous owners put a 6800XT firmware on it. I'm guessing this could also throw a wrench in the mix. I'll try reflashing to its intended firmware.



I will try flashing the MB BIOS again.

Disabling IGD was done alredy.

I did not use DDU to remove the (NVIDIA) drivers, but I will do a complete system reinstall tonight.

I will also take apart the GPU and check if the VRAM pads are still there + re-paste the die and see if it makes a difference. Although I did not notice VRAM temp spiking (I used MSI Afterburner though).


I also did sfc /scannow. It did find corrupt files but didn't yield improvement.

CHKDSK found no problems.


While I do a full cleanup, I thought it would be a good idea to reinstall the GPU BIOS as well, but I'm having trouble finding it anywhere. Do you happen to know where I could get it?


If possible, I would contact seller and demand money back. He knew what he had done and it was probably the reason he got rid of it.

It is unfortunate that model does not have dual BIOS.

I haven't done one myself, but this is the only place I know: 

Volunteer Moderator

I agree with @MADZyren. The owner knew what they had done and probably couldn't fix it themself. Hopefully the techpowerup VBIOS works.

Ryzen 7 7700X, MSI MAG X670E Tomahawk Wifi, Corsair DOMINATOR® TITANIUM RGB 2x16GB DDR5 DRAM 6000MT/s CL30, AMD Radeon RX 7900 XT, Corsair HX Series™ HX1000, Corsair MP600 PRO NH 4TB

Hey guys,

I tried multiple BIOS files on TechPowerup. There is only one BIOS for the MSI RX6800 on there, whih only comes up to me via google search. That's version


So far I tried with two separate amdvbflash versions, got "P/N mismatch" when tried to change it back.

On my third attempt, my PC froze completely. I thought I bricked it, but it restarted with GPU-Z showing the BIOS of the RX6800 XT still.

MSI might have the original BIOS file. I'll try getting it from them.

I'll also contact the owner on phone, ask him what he knows about this and how to change it back. If it doesn't work I will need to ask for money back. Meddling with the BIOS voids the warranty so he can't even fulfill that promise without paying me back.


Although, I completely reinstalled the OS and all drivers, and seems to have made a massive improvement!



It kind of sounds like previous owner maybe thought he would get more performance with XT bios if it wasn't  just a mistake, but then realized he can't even get the original back. 

Nothing wrong with making mistakes or trying things, but really low move of him to sell it knowing it doesn't work.