Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Gigabyte RX 5600 XT windforce oc random gaming black screen

I have been having problems using this gpu, some days i can play all day long without any problems, and some other days it crashes within first 10 minutes of entering a game. Audio lags, screen turns black and in a few secconds the audio shuts off and keyboard stops working, all rgb atachmentes are still on and all fans keep working, system wont respond unless i press restart.

I have run stress test for everything on my system and it seems like doing fine when doing it, no crashes whatsoever. Everything else is working fine, and it doesn't happen when i'm not gaming, i tried everything: disabling fast boot, various attempts of reinstalling drivers, checking the gpu connections to the motherboard and psu and i even reinstaled windows but it keeps happening, i am desperate and i really want this card to run, graphics cards are expensive these days and i can't just aford another one, the card is brand new i have been runing it with this problem for the past two weeks since i bought it, i have the lastest drivers (Adrenaline 20.11.2). When i restart the system this apears: "default radeon wattman settings have been restored due to an unexpected system failure".


The specs of my computer are:

  • Mother Board: Asrock B450m Steel Legend.
  • CPU: Ryzen 5 2600 (Stock)
  • RAM: XPG Spectrix DDR4 3000MHz 8Gb (x2)
  • GPU: Radeon RX 5600 XT Gigabyte windforce oc
  • PSU: Gigabyte P650 80 Plus Bronze 650W
  • Monitor: Asus TUF Gaming VG24VQ
  • Case: Eagle warrior stealth
  • SO: Win10 home x64


5 Replies

Try setting the power limit slider to its maximum, in Radeon Settings / Performance / Tuning.

See if that helps. 

The message you are getting indicates the driver is resetting and this will return Radeon Settings to defaults every time this happens. So backup your settings if you use custom settings to easily load them back in when this happens. 

Did this problem always happen or did it start after a driver update. If it worked better with an older driver you can load that older driver again. Just make sure to use the factory reset option when you load the older driver. 

The issue you have is typically power related. So tweaking the Power Limit may help but you could have a Power Supply issue. 

You can test that with OCCT from ocbase dot com and see if you PSU is dropping below 12v. It can also test your GPU and other components.

If none of that helps then I would talk to the support department for the company that made your GPU about next steps. 


It works the same no matter wich version i try (tried recomended and optional available in amd site for this card), i'll max the power limit in the tweaker to see if it helps, i'll let you know if i get any other black screen.

Regarding the stress test tool you mention i don't get significant drops in voltage when testing for power and when i stress test i can still do simple tasks totally without any problem. Value in the row labeled +12V stays between 11.83V and 12.09V.

Thank you for taking the time to reply, i hope to know more to be able to solve this problem.


It didn't work, changed it but pc keeps crashing, still doing the stress trest nothing changes, this time it happened twice with destiny 2, how else can i test the psu for any trouble related to that?

Journeyman III

I don't know if it's still an issue, I've been struggling with it for two years, it seems to have been resolved now. I got the same black screen freeze while playing games and editing videos. It didn't occur to me during the stress tests either, but I don't think these synthetic tests create the same conditions as normal use. But maybe you just need to let the test run long enough and it will come up. I even had a phenomenon with HDMI where the screen went black for only a few seconds and then everything went fine, no such problem with DP.


In this video it is suggested to try to install only the driver without the Adrenalin software. I did, it didn't help. I tried disabling the zero fan speed in the tuning section of Adrenalin to make the cooling more intensive, but that didn't work either.

I've always been suspicious of the overclock, even if it's a factory setting, whether it's overkill. So I checked if I could turn down the memory clock, but in Adrenalin you can set it higher only, not lower. The card came with this BIOS version: I downloaded version and flashed. The only practical difference between the two versions is the memory clock (1750/1500 MHz). I don't want to jump to conclusions, as I've only performed it a few days ago, but all my problems seem to have disappeared since then.


Well, since we're approaching the end of the year and I haven't had any system errors since then, it's clear that the memory clock was the problem. PXL_20231020_074911154r.jpg

Although the card is rev 2.0, i.e. 1750 MHz is the correct setting, this piece does not hold up, and this did not come up in testing (if there was a thorough test at all). It may have been originally rev 1.0, which has a factory clock speed of 1500 MHz, and was given the higher specification by mistake.