Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

athlon 3000g black screen crash problem with integrated graphics

Hi, currently I bought a gigabyte b450m wifi motherboard ready for ryzen 5000g with windows 10 64 bits, I bought a used athlon 3000g and a corsair pro rgb 8 gb 3200mhz ram memory my problem was that when I put the updated and recommended drivers of the Vega 3 integrated graphics directly from the official page doesn't install them but it always crashes to a black screen and sometimes it says directx error! I have downloaded several drivers and nothing! I have chosen to update bios and it remains the same, has anyone had this happen? how did they solve it???

2 Replies
Adept III

It sounds like you're experiencing some issues with the graphics drivers on your Gigabyte B450M motherboard with an Athlon 3000G CPU. Here are a few things you can try to troubleshoot the issue:

  1. Make sure you're downloading the correct drivers for your operating system and version (e.g., Windows 10 64-bit). If you're unsure, you can use a program like CPU-Z to identify your hardware and OS version.

  2. Try using a different driver version. Sometimes newer drivers can cause issues with certain hardware configurations, so it may be worth trying an older version of the driver to see if it works better.

  3. Check your BIOS settings. Make sure the integrated graphics are enabled in your BIOS settings, and that any relevant settings are configured correctly.

  4. Check for any conflicts with other hardware or software. Sometimes conflicts can arise between drivers or programs, so it may be worth investigating if there are any other devices or software that could be causing the issue.


I think it's option 4 since I've tried the others but it's still the same, my bios is default without changing, I've already downloaded like 3 to 5 different drivers and nothing, and I only have problems with the integrated graphics, since without them my PC works great, for me it's a problem of conflicts with the controller, which I don't know how to solve since the device manager shows me that everything is fine when I open the operating system but after it crashes a black screen, in the administrator of devices only shows me problems with vega 3