Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

7900xtx Low Performance in SteamVR and VR in general

Purchased a 7900xtx at Microcenter on launch.  Just installed it tonight.  Replaced a 6800xt.  I'm running a 5600x CPU.


When my PC boots the bios screen is green.

When I try to play steamvr (The only reason why I upgraded) the performance is terrible.

Using FPSvr I can see that I am all in the green as far as frame time.  Under 6ms.  But I'm hitting reprojection hard and cant maintain above a 70fps on my reverb g2, which runs at 90fps.

If I put the 6800 back in everything is fine.


Did I get a lemon?

1 Solution
Community Manager

Thank you to everyone for your patience whilst we worked on investigating and improving the lower than expected performance in VR for RX 7900 series graphics products. 

The 23.7.1 release notes have a fixed issue listed for VR:

Fixed Issues

  • Certain virtual reality games or applications may encounter suboptimal performance or occasional stuttering on Radeon™ RX 7000 series GPUs.

The driver can be downloaded here: AMD Software: Adrenalin Edition 23.7.1 Release Notes | AMD

View solution in original post

340 Replies

Try another port on your GPU if you havent alyready. Also, have you tried another cable? Seems silly, but maybe that's the issue. 

Community Manager

Thanks for the post. 

Please can you provide a few more details?

  • Motherboard and BIOS version?
  • Display/s used?
  • Type of cable between the graphics card and display?
  • OS Build?
  • Is CSM mode enabled or disable in the BIOS?
  • AMD Driver version?

MB: Aorus x570 elite

bios: F33h

Displays: 55” 120hrz TCL tv, Dell office monitor, HO reverb G2 VR headset

CABLES: HDMI for the TV and Monitor, DisplayPort for the headset.


AMD DRIVER FOR THE 7900x series was installed.

(it has since been reverted back so I can use my 6800xt again.)

Windows 11

I have updated the bios.

Are you running PCIe riser cable?

You'll have to disable CSM to enable Above 4G Decoding and Re-Size Bar to be able to enable SAM in Windows

IF your setup doesn't boot with CSM disabled .. then you'll have to convert your drive(s) from MBR to GPT

Also make sure you have the latest AM4 drivers installed from 

and .. make sure your Windows install is  up to date

and .. make sure you are running separate power cables from your power supply to each power input on your GPU

ThreeDee PC specs

I do use a riser cable.  And currently this card won’t fit without it.

I will look to disable the CSM, what does “Re-Size Bar to enable SAM” mean.  I know what SAM is just not the first part.

For power, each 8-pin should be a completely separate cable?  Don’t use the cable with the two 8 pin?

Though your PCIe riser cable seemed to work ok with  your previous GPU .. it could possibly be a source of issue with your new GPU ..especially if it's not a PCIe 4.0 cable

SAM explained:'s....

Running separate power cables can possibly give you a couple extra FPS as well as stability with "smoother" more consistent power delivery spreading the power load over separate rails

It kinda seems like you're hamstringing yourself in an accumulative way  

ThreeDee PC specs

I disabled CSM, added the The extra power cord.

still getting a green tint on boot up.

Thanks @ThreeDee those are some excellent suggestions. 

The PCIe riser cable may be causing an issue.

Hey so its a AMD DRIVER problem. In Steam value index a game like Alex works great. Start Sw Squad and you have Adrenalin open and when the game starts it will crash and the game will not run slow in VR. Now this happens with drives 22.12.2 up to 23.3.2 in Windows 10. A game like Elite Dangerous in windows 10 AMD drivers will crash but it will run slow in VR. Now in Win 11 it will crash every time and this is with 23.3.2.  

This is on Z690 UD AX DDR4 Bios F21cable HDMI 2.1 Monitor supports 2.1. OS win 11/win10

What makes me worry is not one driver since it came out works with those games I listed. 3080/4080? Every one of them in VR works. I have 3 weeks left to return it. 

Let every breath be your first
Journeyman III

Replying to this in hopes it will help diagnose this issue and my issue is probably relevant/the same.

I upgraded from 6800XT to 7900XTX and the SteamVR performance is much much worse compared to the 6800XT. The frametimes tend to be decent however the experience is very bad, most likely reprojection being enabled/disabled constantly or something. This is with SteamVR and a Reverb G2.

Tried my old HMD (Rift S) and there's no issues (improvement over the 6800XT). Tried SteamVR with Rift S and there's issues again, but not as bad as the Reverb G2.

5800X3D, Asus TUF X570 (bios updated), 16G 3600mhz CL14 ram, latest AMD drivers for each GPU, tried CSM both enabled and disabled, tried DOCP off/on, tried BAR/SAM off/on, reinstalled Windows (a few times), Corsair RM850x.

We are looking into the performance of VR, appreciate your patience. 

I am also experiencing issues. Quest Pro over AirLink OR Virtual Desktop. Upgraded from RTX 3070. Same issues as others, benchmarks, stress tests and 2d games all perform great, no heat problems, great 3dmark scores, RDR2 maxed out 120fps. But my VR games are unplayable, struggles to hit framerates even with lowering settings. Even games where I hit stable 90fps with no reprojection there are stutters, jitters and makes it unplayable. I am glad its on the teams radar and look forward to some improvements.

Are you still looking or did you already gave up??? NO VR FIX in the new patch. Disappointing as F.

Have there been any driver updates to address VR performance?

This is whats sad.. no offense to Matt but we know what the replay will always be. Here we are March 27 2023 and Matt post was 12-16-2022. I just saw this so.. yeah its very clear its a driver problem.. it might be something they can not fix. 

Let every breath be your first

I am experiencing the exacts same thing.  I have a G2, went from a 6800xt to a 7900xtx expecting a decent bump in performance and instead I’m getting 60-70 fos even though the frame time is 2-6ms and everything is in the green.

massive reprojection.  I hope it’s fixed soon or I’m going to move to team green.

Adept II

cool down everyone, it takes some time to get a decent driver update...sadly..

Yo.  I spent $1000 on a new GPU and $200 on a new PSU.  I drove 3 hours to a microcenter and stood in line in the cold.  Yes all my choice but the idea that my entire steam vr library is unplayable is unacceptable.

This is so far not been an issue with the 4080.  I'm just saying.

I had a 6950XT with crashing problems running 1440p at 240hz.  AMD support kept telling me it was my system that was the problem.  After dumping a few hundred $$$ more trying to fix a problem that didn't exist with my pc,  I decided to just buy Nvidia.  7 months later they came out with a fix.  I know what I would do if I were you.  Just saying...


Edited:  to be fair, at least they told you they are aware and working on it.  I didn't get that luxury.

should be aware "to be fair" that nvidia has problems too regurlarly , and solving YOUR problem doesn't solves everyone trying to make think nvidia would be a solution ... i had once a 1080ti and outside games it was a pain in the *** because of poor driver quality on other subjects (and a lot of subjects)

Same here. I gave AMD a chance and their just **bleep** on my hand while I reached it, with 1200€. Disappointing.

I'm running Win11 with 7900xtx and HP Reverb G2 headset, and VR is usually working fine for me for the most part. Performance is generally better than the Geforce 1080 GTX I was using before. The main issue I've noticed is the AMD drivers or the graphics card seems to have a conflict between my Acer Predator display and the headset. So, Windows gets confused which display has which refresh rate or settings, and Windows is trying to treat the two displays as the same thing sometimes. Both these displays are using the two DisplayPort ports, plus I have two other monitors connected to the USB-C port using an HDMI-to-USB-C 2-to-1 connector. I don't seem to have any issues with the two secondary displays. 

I do occasionally have an issue where I try to start the VR and Mixed Reality Portal claims it can't start at 90Hz, which I'm pretty sure is related to the headset/monitor conflict. Then if I change the setting to let Windows decide the VR refresh rate, all my screens go black and the system seems to lock up. 

If you're running an insider build of Windows 11, there are currently some significant problems with WMR headsets unrelated to the video cards. Things like Youtube VR videos play super choppy at like 1 fps, or there's no audio when using VR websites. Not sure if these issues are present in the public release of Windows.

I'm also on W11 with G2, and just upgraded from 108)Ti to 7900xtx but I have serious issues with VR. I wonder how you managed to run it properly. In most of the games, when I move my head, it is stuttering even under the steam VR home screen, the text is not clear, or blurry. I had a decent FPS loss in VR when I compare it to 1080ti. Current;y the quality of the performance is so bad that I can't play as it is shaking. It only looks OK under the Mixed reality default room. Outside of Steam VR, MSFS is also shaking even on its main menu in VR. For non-VR games, the card is flawless!

If you have the original V1 G2 reverb headset and original power cable , it was substandard and known issues. if still in warranty request a version 2 cable.   i had to buy mine.   the V1 cable on the g2 reverb causes blackouts and even more regular on a x570 board , i had this issues. a bios update and there is a firmware update on HP website specifically for the G2.  this will help with the black outs. 

Update to this: I did a fresh install of Win10 on a clean drive because VR works properly in Win10, and all my performance problems went away. Outside of VR everything runs a ton better than the 1080 now. Inside of VR, everything runs great without issue. I did still have the screen blackout issue, but not nearly as bad, and I was able to fix it by turning off the VR headset and turning it back on. Turns out this was an issue with the AMD graphics card and should be fixed in the latest drivers. I haven't seen the issue since I updated the drivers.

also openxr is a better bridge to run when using 7900xt at tht moment i have found , get much better fps. 

I saw where you are using the usb c to drive to monitors.  I planned to try to drive 3 1080p monitors, but outside of your comment, I can not find a single ref to the display capability.   I was about ready to send the card back after all the bad reviews.  Can you expand on the usb c multi monitor capability?  thanks!

I have some problems on my 7900 XTX. When i boot the Computer with the Valve Index (DisplayPort)  and my Monitor (HDMI 2.1) plugged in the Windows Screen doesn't show up on the Monitor. The second problem if i fire up SteamVR the GPU Usage goes up to 60% sometimes the usage jumps to 75%, even if i do nothin in SteamVR Home at it is only around 150% Supersampling and on 90hz. The Games do also not work most of them, exept Half Life Alyx, AMD Please do fix these VR Issues on the next driver update. The Games that didn't work are Dirt Rally 2.0 VR, Assetto Corsa VR and Elite Dangerous in VR. This is what i have tested so far. I can also provide a DxDiag.txt if you need it. I'm running a fresh install of Windows 11.


I'm glad that it fixed your issues with the reverb but for me it's not the same problem.

same here, but openxr is a better third party app that bridges WMR and Steam VR as windows is pathetic at  doing this , gives you much more frames and a better to tool see how many frames your getting per second. 


i am playing Elite dangerous on Openxr as you dont need the controller at 90 fps 


i have noticed locking you frames to 60fps seriously reduces latency issues . 


even in ED i am only using around 36% Vram . so much head that cant be accessed, they will attempt to tell you its CPU bottle neck but this is pure rubbish, its  driver issue. 

06 JAN 23

Received my 7900 XTX yesterday and straight out of the box encountered the issue with no display on my monitor if the Valve Index was connected at boot time; this was after installing the full Adrenalin package of software/drivers. I was most upset to say the least!

Anyway, after finding it only happened when the index was powered up on boot, this is how I rectified the issue:

Re run the Adrenalin driver install as though you were having to repair it. However, choose to Factory Reset and only install the "Drivers", nothing else i.e. not the full Adrenalin package.

This has worked for me and since reinstalling as stated above has worked flawlessly, hope this helps. 

*Windows 10 64-bit

I've tried your suggestion but in SteamVR the GPU Utilization is at 60% with 150% SteamVR Supersampling in 90hz mode. Dirt Rally 2 in VR refuses to start.

By the way i've made a 3d mark port royal benchmark before my new windows 11 installation and i've had around 14600 Points with the Power Color Hellound Custom card. With the fresh installation of Windows now i have 13800 Points. I have the same OC and Undervolt Settings tested that was suggested by the Adrenalin Software. After the new Win11 installation the Adrenalin Software was telling me exact the same. Whats wrong then?

today i've tried the new driver 23.1.1 but Dirt Rally 2.0 in VR doesn't work.

I've also tried skyrim vr and fallout 4 vr not working both of them (shows an Application Error Message). Microsoft flight simulator is also not working. i tried to launch the game, started a flight. then launched steamvr and it runs like 10 seconds and then windows freezes. half life alyx is working and euro truck simulator 2 also.

I could fix the problems with F1 22 and Dirt Rally 2.0 in VR you have to disable fullscreen mode for the game. go to Documents/MyGames/Dirt Rally 2.0 or F1 22 open hardwaresettingsvr in the section <resolution width="3840" height="2160" aspect="normal" fullscreen="0" vsync="0" refreshRate="119" multisampling="off" supersampling="1" taa="1" />


make sure fullscreen is set to 0 save the file voila it boots.

Microsoft Flight Simulator isn't working in VR even if i set the Game not to Fullscreen on the Monitor.