cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

USB Disconnecting then reconnecting randomly - Ryzen 5600X - B450M

My USB's randomly disconnecting and reconnecting, i tried latest bios 3802 which has "AMD AM4 AGESA V2 PI 1.2.0.7" and 3211 which has "AMD AM4 AGESA V2 PI 1.2.0.3 Patch C" i tried this one because people said it's stable but it's not helped, still same problem.

I delete my USB Host Controllers, mouse and keyboard drivers then restarted pc, not helped.

I turn off "Allow the computer to turn off device to save power" from USB properties, not helped.

I disabled "USB selective suspend setting" from power options, not helped.

I connected my:

Razer Deathadder V2

Razer Blackshark V2 USB 7.1 on Front Panel of Computer Case (Corsair Spec Alpha Case)

HyperX Quadcast S

HyperX Alloy Origins 65

Ugreen Bluetooth Dongle

Sometimes extra connecting my Wheel or Hard drive.

Screenshot_3.png

I do not know why i'm getting this problem, maybe about usb bandwith then i should buy PCIE USB Port.

I'm thinking about Razer Synapse maybe Razer Synapse can be cause this problem, it's trying to synchronize with game and changing colors by game situation.

There may also be conflicts between hyperx products and razer software. I will delete razer synapse and I'm going to use it like this for some time.

My Specs:

W11 PRO

RYZEN 5 5600X

ASUS TUF GAMING B450M-PRO II

CORSAIR VENGEANCE LPX 16GB 2666MHz ---- D.O.C.P Open

ASUS GeForce GTX 1070 8G Founders Edition

Thermaltake TR2 S 80PLUS 700W

0 Likes
20 Replies
Vynski
Forerunner

You mentioned uninstalling your USB host controllers then restarting. You need to download your chipset drivers from ASUS for your motherboard and reinstall the chipset drivers. Don't rely on Windows drivers. You will probably find that your 3.2 USB ports will have 3rd party drivers and they should be in the chipset. I did not see them isolated in an individual download.

When you installed the Razor Synapse, I'm assuming those are the drivers for the DeathAdder mouse. Uninstall them first and install your ASUS chipset drivers then restart. Then install your DeathAdder drivers. and restart.

0 Likes

Which one is the best chipset drivers from Asus or AMD site ?, because i installed chipset driver from AMD site, now as you said i installed from Asus site, Asus's is older.

*edit : I installed chipset driver from asus (version 3.10.22.706) then installed Razer Synapse but driver provider looks microsoft not razer.

0 Likes
DimkaTsv
Miniboss

Download HWINFO. Lauch HWINFO. Run some memory intensive task (for example Prime95 --> Large FFT), look at bottom of HWINFO live report if there are WHEA errors.
Even though there should not be even single one at 2666 (1333) mHz

0 Likes

Running test from prime as you said.Screenshot_4.png

0 Likes

Not this report (this is system HW report)
I meant last line in sensor report. It will be LONG list of bunch of parameters in real-time

0 Likes

I did not get WHEA error yet, still running test; I don't experience disconnections very often, but it just randomly disconnects. Prime95 has been running for 2 hours.

Today, while i'm playing overwatch 2 problem happened while in game fight then i alt tabbed it's happened again, i cheched reliability monitor there is no error.

Screenshot_1.png

0 Likes

Could the keyboard cause such a problem?

0 Likes

If your keyboard requires two usb ports and the mb's power supply to those ports is weak yes it can cause stability issues.

USB disconnects are a well known problem with the latest am4 chipsets and AGESA 1.2.0.7 contains their solution to that and the persistent fTPM issues they've had since AGESA 1.2.0.4.

0 Likes

No, my keyboard is hyperx it has single usb. Is there any solution of that, usb ports disconnect especially when playing the overwatch game.

0 Likes

Also my USB drivers driver date looks like 21-Jun-2006 (microsoft), they're not getting update after i update chipset drivers.Screenshot_5.png

0 Likes
ardankyaosen
Challenger

For upgrading your USB drivers, you could try:

https://www.snappy-driver-installer.org/

0 Likes
ThreeDee
Miniboss

Make sure you have the latest AM4 chipset drivers installed from AMD.com

I don't recommend ANY 80PLUS (White) power supplies and recommend going with a quality 80+ Gold or better rated PSU. Might help, might not .. but good to do regardless. USB ports dropping could potentially be a power issue

A different issue, but my wife's setup was having issues with driver timeouts and symptoms that clearly showed that something was wrong with her little RX 550 2GB GPU (3700x,B550m Phantom Gaming 4, 2x16GB 3200,Win11.. Thermaltake RGB 500wtt 80Plus PSU)

500wtt's was plenty of power for her little setup ..80plus white? ..should be fine, right?

I swapped out her 80Plus (White) power supply with a 600wtt 80+ Gold and all issues automagically disappeared

anyways, like I said .. PSU swap might help, might not ..but good to do regardless

|5900x w/Noctua NH-D15 2x140mm Fans|x570 Taichi|4x16GB RGB Oloy 3600 CAS16 w/1:1 FCLK|Gigabyte Gaming OC 6800 16GB|HX1200 1200wtt 80 + PLATINUM|Nighthawk Z-RGB Case|8x120mm RGB Fans|Win 11 Pro|
0 Likes

I'm starting to think it has to do with the power supply just like you.

0 Likes

Screenshot_2.png

0 Likes

I got this error: Error setting traits on Provider {8444a4fb-d8d3-4f38-84f8-89960a1ef12f}. Error: 0xC0000001

same time with disconnect reconnect problem, then 5 minutes later usbs disconnected reconnected again but did not get Kernel-EventTracking error, i checked time when i got error its same time.

Hmm... Then step by step...
1) Try doing DISM /Online /Cleanup-Image /RestoreHealth, then after this sfc /scannow --> Reboot. Unlikely that it will fix stuff, but who knows.

2) Try cleanly reinstall GPU drivers (Personally use 2x AMD Cleanup passes, then 1x DDU pass). Also likely won't help, but who knows...

3) Try doing Windows In-Place Upgrade . . . Basically as Windows reinstall, but it will save all programs and settings you had. It may fix some deeply hidden issues.

If it also won't help
4) Try disconnecting USB devices one by one and looking if behaviour will repeat. If issues will stop after some specific device being plugged off, then return other devices (except one after which issue was resolved) back and check again. If behaviour won't change ---> That device you had unplugged is a culprit. Can be bad cable, or bad software for this device, who knows.

You can actually directly google this one as you wrote...
But why the F*CK i cannot write stuff you already wrote above? And this is not a single case of such thing happening for me btw. . .

DimkaTsv_5-1669779274779.png

0 Likes

I already google it about error then i wrote here, tried almost all solutions like https://msft.today/error-setting-traits-on-provider-8444a4fb-d8d3-4f38-84f8-89960a1ef12f-error-0xc00... , and from the other sites where people open subject and not thinking its about windows because I just did a clean install.

Sometimes its not letting you post it, first post it without which text gives error, then edit post and paste which gaves error.

0 Likes

I removed all USB devices, only did not remove bluetooth dongle to conmect different mouse. When i connect Hyperx Quadcast S and Razer Blackshark V2 at same time (did not connect other usb devices and restarted pc when i connect a usb and connected one by one) this Kernel EventTracking problem shows up. When i remove one device like headset then restart problem is gone. HyperX has jack input for Speaker or headset. For each one its adds HID compliant headset to device manager these devices driver name HidTelephonyDriver.inf

I can not add screenshot getting blocked from site.

0 Likes

Only my mouse started to disconnect reconnect now it happened while normal usage not ingame, while im hanging in internet suddenly it stopped not a disconnect reconnect problem light gone its turned himself off; changed my mouse now using another one. I'm going to try in game and check out disconnection problem stopped or not.