cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

fuziongxp
Journeyman III

YouTube videos flicker with Freesync enabled

So this Friday I installed the new driver (18.1.1) for my RX 570. Since then (I didn't see it before), with Freesync enabled, YouTube videos start to flicker after a while. If I turn Freesync off it doesn't occur anymore. In games (at least in Fortnite and LoL), there are no flicker issues with Freesync enabled. I'm using the AOC G2460VQ6 at 75 Hz. Also going back to the old driver,

flickering still occured. Any solution with this?

0 Likes
18 Replies
fuziongxp
Journeyman III

Just to add, if I run the monitor at 60Hz, there is no flickerung issue with Freesync at video playback.

0 Likes

What happens if you have vsync off, freesync on and limit the frames to 60?

0 Likes

You mean in games? Like I said there are no flicker issues in the two games I play.

0 Likes

No in your video playback (or anything that has frames you might be having trouble with). Sometimes people are getting frames above their freesync range. Freesync won't work outside the limits set by your monitor manufacturer. Limiting the frames to be within helps, and setting to the native refresh rate means then freesync only has to take care of the dips bellow. I don't know if you are or aren't or got something else going on. Just thought I'd offer something to try if you hadn't already. Good luck!

0 Likes

Yes, setting the refresh rate of the monitor to 60Hz solves the problem. I also found out that disabling hardware acceleration in Chrome does it, too, but leads to an overall unsmooth experience while surfing.

Is there no other way to solve this? Is there any way to limit the frames to 73 or so like the Frame Rate Target Control in the Radeon settings in games does?

I am kind of disappointed now with the hardware I have because I don't understand why not even playing back YouTube works properly with the 'hightest' settings my hardware is capable of.

0 Likes

I wish I knew, I was just assuming that how you have it set to gaming would apply to video acceleration and playback. Maybe it doesn't? Hopefully one of the engineers that really understands this stuff will answer. I just knew that using that combination/hybrid like setting of setting a fixed upper limit and letting freesync take care of the low dips worked great for me. I was having a completely different issue with the first 2 adrenaline driver myself that caused me to have to turn off hardware acceleration in Chrome and the 18.1.1 drivers fixed that. It really is amazing how some things get fixed and others break driver to driver. I think the variables are way larger than I can comprehend. Glad we have these smart people to figure it all out! Hope you find a fix. Please post if you do either way. I for one want to know how this works and what fixes it.

0 Likes
mack0y
Elite

Probably when the screen is flickering, the refresh rate of the monitor is continuously going from the highest refresh rate to the lowest and back up.  So in your case, unless you changed the range, going from 75 down to 35 and back up to 75 continuously resulting in the flicker.  Can you check the real time refresh rate from the monitor and see if this is what's happening?

RX 5700XT
0 Likes

Ok how can I do that?

0 Likes

Not sure about your monitor but from my monitor's OSD (Viewsonic XG2401), I select information and can see the refresh rate change in real time.  Maybe it's the same for your monitor if you open the OSD and select 'Extra' menu and check if the V.frequency changes.

Do you have more than 1 monitor connected?

RX 5700XT
0 Likes

Unfortunately there's no real time refresh rate in my OSD and atm I have only one monitor connected.

0 Likes

Does it flicker only when the video is in full screen mode or also when it is not?  Does it also flicker when playing 1080p60 videos?

RX 5700XT
0 Likes

Seems only to be affecting full screen mode and also when playing 1080p60.

0 Likes

Try to disable browser hardware acceleration if it not already disabled.  Does it happen on every web browser?

RX 5700XT
0 Likes

Yes if I disable hardware acceleration in Chrome the flicker disappears but then normal surfing starts being lagging a little bit so that's not an option for me as well as turning down the monitors refresh rate to 60Hz. If there is no other way to solve this problem without turning off hardware acceleration or bumping down the refresh rate I am going to return the monitor and get another one without Freesync.

0 Likes
kingfish
Volunteer Moderator

You can right click on the video while it is playing, and uncheck the 'use hardware acceleration' box on the screen that appears. This will not affect the browser.

Hello! I know this post is so old but I figured out a solution which may be helpful for future researchers. In Radeon Adrenalin Software, Google chrome or any browser that you want to use can be added as a game. You know you can set Freesync or or off for any spesific game on that menu. That solved my problem.

0 Likes
Jasonmc72
Journeyman III

I allso get the flickers with freesync enabled

 

0 Likes

I do get flickering in some games but not youtube.

It only happens with this combo:

Freesync enabled at monitor
VSYNC Off at game level
Freesync On at Adrenalin

I change Vsync On for the game that do flicker and its solved. It still does the freesync, I can see it thru the real time screen refresh rate. Could be a game bug or driver bug...