cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

aaronspe
Adept I

ubuntu 22.04 & driver amdgpu-install_22.10.2.50102-1_all.deb

I have a completely new install of ubuntu 22.04 & have updated. Yet when I go to install amdgpu-install_22.10.2.50102-1_all.deb I get the following output:

The following packages have unmet dependencies:
 apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed
 grub-efi-amd64-signed : Depends: grub-efi-amd64-bin (= 2.06-2ubuntu7)
                         Depends: grub-efi-amd64 or
                                  grub-pc but it is not going to be installed
 init : PreDepends: systemd-sysv
 libudev0 : Depends: libudev1 (>= 183) but it is not installable
 rocm-llvm : Depends: python but it is not installable
             Depends: libstdc++-5-dev but it is not installable or
                      libstdc++-7-dev but it is not installable
             Depends: libgcc-5-dev but it is not installable or
                      libgcc-7-dev but it is not installable
             Recommends: gcc-multilib but it is not going to be installed
             Recommends: g++-multilib but it is not going to be installed
 util-linux : PreDepends: libudev1 (>= 183) but it is not installable
 xserver-xorg-amdgpu-video-amdgpu : Depends: libudev1 (>= 183) but it is not installable
                                    Depends: xorg-video-abi-24 but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

 

I am completely new to ubuntu, but I thought ubuntu was supported. Anyways, I'm just trying to get Blender 3.2 with HIP support running on my Vega64 card. Any help figuring out exactly what I need to do to get the needed software installed is much appreciated.

16 Replies
aaronspe
Adept I

Got it down to this. Deadsnakes python3.8 was installed so I'm a little surprised that it is still trying to install python. 

The following packages have unmet dependencies:
rocm-llvm : Depends: python but it is not installable
Depends: libstdc++-5-dev but it is not installable or
libstdc++-7-dev but it is not installable
Depends: libgcc-5-dev but it is not installable or
libgcc-7-dev but it is not installable
Recommends: gcc-multilib but it is not going to be installed
Recommends: g++-multilib but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have exactly the same problem. Is it the case that AMD released broken drivers?

Confirm. The same issue here

Same thing..

 

Clean Fresh install of 22.04 and can't install amd drivers.  Definitely looks like they released a broken package.  Anybody have any fixes for it?

Same. Fresh install of Ubuntu 22.04. Updated. Tried running amdgpu-install and getting numerous 'unmet dependencies' errors, one of which is python, and then failing to install.

nasgowl
Journeyman III

I have exact same problems... i can't solve it too

0 Likes

AMD released drivers with broken dependencies for rocm. ROCM developers dropped support(temporary for unknown time period) for ubuntu 22.04.

To solve this they can add their own repository with python 3.8 and libstd or use more recent version of those software, but it released as is.

There was 0 comment from AMD crew about Linux drivers quality after 22.20-22.20.1 release.

You may want to ask developers why they done so.

Here opened issue at Github:

https://github.com/RadeonOpenCompute/ROCm/issues/1730 

https://github.com/RadeonOpenCompute/ROCm/issues/1713 

PS. I want to thank developers of this package https://aur.archlinux.org/packages/opencl-amd

grmat, johnnybash, Christopher Snowhill, binex-dsk and George Sofianos

Those people saved my day and nerves.

thank you for informations

0 Likes

You may be interested in this:

Qanatoz_0-1659171939895.png

Qanatoz_1-1659171954319.png

I won't test this one, because it is pointless in virtual machine. I use Arch based solution.

https://github.com/RadeonOpenCompute/ROCm/issues/1713#issuecomment-1193100466 

https://github.com/RadeonOpenCompute/ROCm/issues/1713#issuecomment-1193332549 

0 Likes

Does anyone tried installation method provided by jacodt?

0 Likes
kapqa
Adept I

i noticed that whenever would upgrade from earlier edition of Ubuntu to a higher one, there is a problem with AMDGPU,

specifically, when one wants to install a newer .deb file for the graphics card driver repository from AMD.

eg. from 20.04 to 22.04 for Radeon 550X,

would go from 22.10...deb (installed and working) to 22.20 . deb (would ask if replace the information: yes)

but then, it would fail to find the necessary packages.

sudo amdgpu-install --opencl=legacy
Hit:1 http://it.archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://it.archive.ubuntu.com/ubuntu jammy-updates InRelease
Get:3 http://it.archive.ubuntu.com/ubuntu jammy-backports InRelease [99,8 kB]
Hit:4 https://ppa.launchpadcontent.net/deadsnakes/ppa/ubuntu jammy InRelease
Get:5 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Hit:6 https://repo.radeon.com/amdgpu/22.20/ubuntu jammy InRelease
Hit:7 https://repo.radeon.com/rocm/apt/5.2 ubuntu InRelease
Fetched 210 kB in 1s (230 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package clinfo-amdgpu-pro
E: Unable to locate package opencl-legacy-amdgpu-pro-icd

 

Hello, I have also met this problem with the location of these packages, and it can be solved with the activation of the proprietary Radeon repo, which was disabled in my case.   

0 Likes
sylvaing
Journeyman III

Hello,

after having installed a 6500 XT graphic card on my PC, I am also having trouble with the installation of the drivers. If the general installation is ok, it is impossible to have a complete support of the HIP and of the RocM, and the installation of a part of the files for this support fails. I have encountered this problem with Ubuntu 20.04.5, Ubuntu 22.04.1 and OpenSUSE 15.4. Because of this bug, Blender 2.93 does not recognize the 6500 XT for the OpenCL render with Cycles (which worked perfectly with my old RX 570) and also Blender 3.3 does not recognize the graphic card for the HIP render with Cycles. With Windows 10, Blender 3.3 recognize the card and the HIP render works normally, but as I usually work with Ubuntu, I would like that this problem to be solved as quickly as possible.

gerritd
Journeyman III

Well, I've bought a RX 6800 yesterday and I am trying to get the proprietary drivers installed since. Using Ubuntu 22, which should be supported, but clearly is not. Is that some kind of joke? Can't you provide an installer that actually installs the driver so people can run Doom Eternal with Raytracing support?

If the accessibility/quality of the driver does not change, the next card I buy will be from Nvidia again.

0 Likes


@gerritd wrote:

Well, I've bought a RX 6800 yesterday and I am trying to get the proprietary drivers installed since. Using Ubuntu 22, which should be supported, but clearly is not. Is that some kind of joke? Can't you provide an installer that actually installs the driver so people can run Doom Eternal with Raytracing support?

If the accessibility/quality of the driver does not change, the next card I buy will be from Nvidia again.


You should do that!

I have tried to post a solution to this issue THREE TIMES NOW. It was removed every time without communication. Probably because I linked external sources like repositories or AMD's own download page.

Shame on AMD, really. Instead of destroying your community you should listen. To your customers!

PS: search for "hipGetDeviceCount error with AMD gpu #1122". You will find the solution there. AMD installer for 20.04 needs a whole lot of extra dependencies.

Thank you, I will try that later, I think I've found the site. Shame you aren't allowed to post the solution here.

Since "Installer for 20.04" seems to be technically the correct name, AMD shouldn't call it "Installer version 22.20 for Ubuntu 22.04 and 22.04.01"

0 Likes