Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Ryzen 3 3200g Linux


I just bought a Ryzen 3 3200g APU to build a Linux PC for my uncle. ZEN + Vega in an APU was nice on specs but it does not run on Linux at all. I tried with both A320 and B450 chipsets.

I've tried kernels from 5.0 to 5.5 with no luck. Always a BSOD or similar.

Manjaro XFCE/KDE/i3, Ubuntu MATE, Linux Mint MATE, MX Linux AHS. Bleeding edge or stable distro it doesn't matter, they are all unusbale.

I've also tried to boot 2 separate SSD with full working installations of Manjaro with Full AMD Open Source Drivers and Propietary AMDGPU Pro from an existing Ryzen 5 3600 + RX 580 setup. Kernel 5.4 and 5.5. In Ryzen 3 3200g they all fail to load X.

This method runs fine with the Open Source installation if I switch the SSD from Ryzen 5 3600 + RX 580 to an older FX6300 + R9 280x.

This APU Ryzen 3 3200g is a dead end as of now. It reminds me of an A10-7970 I bought years ago and it's been used as an expensive cyberpunk paperweight, but not as expensive as this luxury Ryzen 3 3200g Paperweight for your Linux environment.

Please give Linux support for all of your hardware.

I'll be glad to test any improvements.

4 Replies
Journeyman III

Don't know mate, I recently brought my first PC Ryzen 3 3200g and Linux is running just fine.

As I am using this pc for Programming stuff, I choose Linux for my First OS.

I tried 4 different distros (Elementary, Pop Os, Manjaro KDE, and Gnome), they all run fine.

Make sure you clean install it. (wipe whole HHD).

Here's are my Specs

Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A
Desktop: GNOME 3.36.5 Distro: Manjaro Linux
Type: Desktop System: Gigabyte product: A320M-H v: N/A serial: N/A
Mobo: Gigabyte model: A320M-H-CF v: x.x serial: N/A
UEFI: American Megatrends v: F51 date: 04/28/2020
Topology: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics
bits: 64 type: MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 28759
Speed: 1703 MHz min/max: 1400/3600 MHz Core speeds (MHz): 1: 1744 2: 2290
3: 2002 4: 2739
Device-1: AMD Picasso vendor: Gigabyte driver: amdgpu v: kernel
bus ID: 07:00.0
Display: x11 server: 1.20.8 driver: amdgpu,ati unloaded: modesetting
resolution: <xdpyinfo missing>
OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.1-3-MANJARO LLVM 10.0.1)
v: 4.6 Mesa 20.1.5 direct render: Yes
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel bus ID: 07:00.1
Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel bus ID: 07:00.6
Sound Server: ALSA v: k5.8.1-3-MANJARO
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel port: f000 bus ID: 06:00.0
IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Local Storage: total: 931.51 GiB used: 82.65 GiB (8.9%)
ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0
size: 931.51 GiB temp: 37 C
ID-1: / size: 915.60 GiB used: 82.65 GiB (9.0%) fs: ext4 dev: /dev/sda2
Alert: No Swap data was found.
System Temperatures: cpu: 35.5 C mobo: N/A gpu: amdgpu temp: 16 C
Fan Speeds (RPM): N/A
Processes: 295 Uptime: 42m Memory: 5.81 GiB used: 2.38 GiB (40.9%)
Init: systemd Compilers: gcc: 10.1.0 Packages: 1417 Shell: Bash v: 5.0.18
inxi: 3.1.05


Hi! Do you where I can find drivers for kali or debian? I also use 3200g

Thanks in advance!

Journeyman III

I'm having the exact same issues with the same APU.

Journeyman III

I'm having the exact same issues with the same APU. I can't even install Windows 10.