Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Radeon settings version and Driver version do not match. Please try again after updating to latest version(s).

I'm getting this message as a text pop-up, and AMD settings do not run (it is impossible to run due to the error):

"Radeon settings version and Driver version do not match. Please try again after updating to latest version(s)."

... whenever I try to open AMD settings after installing any driver past 18.2.2 .

R9 290X on Windows 7 x64.

I am not installing relive, and I am not installing anything except AMD settings and driver (no HDMI audio, no ACP application, no bethesda launcher, etc.).

I have tried:
Clean install using amd driver
Clean install after DDU
Rolling back to 18.2.1 (settings work fine)
18.2.3 (settings broken)
From 18.2.1 directly to 18.3.1 (settings broken)
From 18.3.1 "no clean" downgrade to 18.2.2 (settings work fine).

Basically, settings work fine on 18.2.1 and 18.2.2 but break on 18.2.3 and 18.3.1 consistently.

I'm at a loss.

Win7 x64 is updated fully with windows update etc.

Let me know if you have any ideas on what to check, or is it broken for everyone, and nobody is saying anything???

190 Replies

Install the full version...don't pick and choose what part of the download you think is important.

Clean Install AMD Graphics Drivers


Shouldn't be necessary.

I've upgraded AMD drivers 20+ times before, and always install settings and driver only, don't need the other crap.

I'll give it a try tonight, regardless, and see if it makes a difference at all.

As far as "clean install," I already did that after DDU as I mentioned above.  Exact same result.

Adept II

SHU_1Y1Moa.jpgall time same results... something went wrong and nobody monitor it...

Report this to AMD using this link > Email Form  and include screenshot.


I did report, before some action taken I have generate error report  from Radeon controllpanel.

If you find any related to radeon settings, it may help to include those in your report.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T.. it can be (!!!!!) in windows errors reporting when it is the internal notice from AMD programme... sorry but something is wrong with installer some "coders" did c:\ windows instead %systerm% or other basic mistakes. I managed to install drivers manually and the previous version of Radeon settings but still have this error in installation of report creator and uninstaller, idiocy...SHU_YMjnmr.png

Sorry but all wrong going is cause some people, not nature...

Have seen this in another thread, AMD 17.11.1 ##ID_STRING16## folder start menu

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..


I have very similar specs to you but only difference is the GPU I have is a AMD RX 5500,  I have tried every possible guide forum topic or youtube guide but am having no luck I had an RX 570 before and never had an issue with my radeon settings not opening and this is frustrating now. Can someone please point me in the right way? I did play with the registry as suggested by a guide for fixing the driver version not matching but still no luck, I'm just gonna end up putting my RX 570 back in if it doesn't fix anyone know if this is also related to any type of hardware bottleneck too? Thanks for any help in advance!


Silly question here, when you ran DDU, did you boot to SAFE MODE to run DDU. If you didn't I highly recommend you do that. Next did you clean your registry after running DDU and before running the Clean Install of 18.3.2 again? If not run ccleaner and clean the registry. You may need to run the routine a few times until it comes up with no errors found.

Good Luck!


If people spent days to fix it like me, use this all old tricks, those who are less experienced just go to Nvidia...

You are assuming this is a widespread issue. My R9 290 on Windows 7 has no issue at all. How do you explain that? Nothing points to the drivers as being a issue (except for 2 people).

Windows 7 not the number one cause of installation with Win7 and Win8.1. Number two would be third party controllers. Asus,Afterburner,Trixx, etc. Number three reason is sitting in front of the keyboard.


... I was not lucky and installed version which you removed from distribution and all than was wrecked... this was 18.1.2 and something has been changed in my system, and yes I am sitting in front of my screen and I see you talking like king ruler of the world... and there is more than 2 ppl, and one you had already kicked from this discussion: procivitas. So make some distance to yourself as the guru, and try to get to point. I know that all are I...ots except you, but...

You are always allowed to vote with your dollars, but I have nVidia products too and spend time in their forums. There too you will see the same advice of using DDU from safe mode to fix driver installation irregularities. As they say, you can lead a horse to water, but you can't make it drink.

I wish you the best of luck, I've got nothing left to offer.

Adept II

Finally got some time to try this weekend, uninstalled AMD drivers, rebooted to safe mode, uninstalled AMD drivers with DDU.

Reinstalled 18.3.2.  It installs fine, no errors.  Reboot, MSI Afterburner detects 18.3.2 is installed fine.

Control panel gives the exact same error as in pitkoz' screenshot.  However, the difference for me is that the window doesn't even draw underneath, so it's just a popup.  If I click "ok" it closes.  Repeatedly trying to open it opens a "contentless" window (transparent, so you can see the desktop underneath) with a "ghost frame" around it, no "X, _, O" icons to even close it, and it cannot be closed (by clicking on RADEON SETTINGS on the taskbar and "close").  The error popup doesn't happen anymore.

The irony is I can't report the issue since the issue reporting happens through the settings control panel...  which doesn't draw/open xD .

Someone suggested to check that in the registry RadeonSoftwareVersion is all 18.3.2 here:  Radeon settings version and Driver version do not match. Please try again after updating... | guru3D...
I checked and mine is indeed 18.3.2. everywhere, so that's fine.

The issue isn't isolated to "two people."  There have been threads popping up here and there, and on guru3d as well.

My .net framework is latest, I have visual c 2017 (latest).  All my visual c runtimes are updated to latest, windows updates are updated to latest, I've been using computers since the early 90s, etc. etc. etc.

My "feeling" is something was either compiled with a wrong (older?) .net version, there's some .net version bug with windows 7 x64 on particular systems, or there's some visual c++ version dependency mismatch between win10 and win7.

Anyway, this is continuing to be extremely annoying and I can only hope it's fixed in the next driver release.

For now, since there is no working solution for me, I'm going back to 18.2.2 which is the last version which works perfectly for me.

You should open a support ticket so they know about the bug. They won't know about it from here.Email Form 


pokester wrote:

You should open a support ticket so they know about the bug. They won't know about it from here.Email Form

Well, a tech suppport engineer from AMD (ray_m) replied on my thread, so one would expect them to be aware of these issues by now.

Radeon Adrenalin v18.2.3 won't install the Radeon Settings tool

The email support is more useless than most of the replies on these threads.


You may still want to put a ticket in. Unless he specifically said he'd forward it to the driver team. They are support engineers, I don't believe (unless mistaken) they are on the driver team. I see those guys recommend the support tickets too. I agree it would be nice to think that is what happens. I know this they act faster when they get several reports of the same issue.

Did that a couple weeks ago anyway, gave up after the 3rd reply.


It certainly looks like from what I have seen over the last couple months. That while the new drivers have growing pains (to say the least) those pains are definitely hitting some of the older cards way harder. It's a shame that if they can't get a handle on this. That they can't just split the driver, and have wattman free driver for the older cards, that works. Hey I love wattman so far, but if it wold fix everyone's issues to shelve it till they get it right for everyone. That'd be okay too!

Hey 18.3.3 is out now! Maybe some luck with this one!

Same problem. Someone on the Guru3D forums quickly identified the ucrtbase.dll that's crashing Radeon Settings after I posted a link to my thread here with the error report (a user here also forwarded my post to ray_m, for the record):

Radeon Adrenalin v18.2.3 won't install the Radeon Settings tool

Radeon Adrenalin Edition 18.3.2 Drivers Download & Discussion | guru3D Forums

Back to v18.2.2...

Yes, I can confirm that 18.3.3 does not fix the issue.  The exact same problem remains.

I'm not sure if there's a visual c runtime problem or what, but it persists through 4 driver version releases now.

Back to 18.2.2 for me as well.

When you say you have fully updated you have your choice set like so?

The optional updates contain the most important updates for AMD drivers.

I'd love the issue to be as simple as this, but as I mentioned above, everything's updated.

In fact, I even went through all visual c redists and made sure they are updated as well (the 32-bit as well as the 64-bit version).  Those do NOT come through windows update.  This list helps:

They already were up to latest when this discussion began - as well as the .net runtime which I think the drivers use as well, which is up to the latest version - 4.7.1 (that one does come through windows update).

This is what happens when people install every "update" Big Brother Microsoft tells them to install:

Windows 7 Suffers ‘Total Meltdown’ Thanks To Microsoft’s Meltdown Patch

" As if the Meltdown and Spectre CPU flaws weren’t bad enough on their own, Microsoft was somehow able to make the flaw even worse on Windows 7. According to Swedish security researcher Ulf Frisk, the fix that Microsoft provided to Windows 7 computers for the Meltdown flaw, which could allow attackers to read kernel memory at a speed of 120 KB/s, would now allow attackers to read the same kernel memory with a speed of gigabytes per second. "

You will definitely have issue with the AMD drivers if your .net is not up-to-date, and those are often optional installs. Good advice!

This has NOTHING TO DO with Windows updates, just ignore replies like that. Also, DO NOT let Windows automatically download and/or install updates for you. You should also remove the updates that introduced telemetry and other Cancer 10 spyware features in Win 7 SP1. I've posted a partial list here and a custom script you can use to uninstall them:

How To Uninstall Microsoft's Spying Updates From Windows 7/8 - [>NF<] Noobs Forever Game Servers - F...

You can find similar lists on various other sites where far more knowledgeable people use to post:

How to remove Windows 10 upgrade updates in Windows 7 and 8  - Page 30 - Windows 7 Help Forums

Remove telemetry updates for Windows 7 and 8.1 · GitHub

To make sure data collection by Microsoft is disabled, you should also turn OFF the Windows Customer Experience Program:

first thing I do on a Windows install!

pedro-nf please, I lost some of this links for mod of win7 can you from your treasury post me links on priv the comprehensive list of them. Funny as when was trying to backup system on win7 before failed many times installation of drivers, when restored win7 is now not doing backup progressive on user files, I lost some recently made and edited files... MS is invading us more and more on Win7.

You mean the links to articles and posts on how to remove the Windows 7 telemetry and spyware updates? They're on my post right above yours.


pedro-nf yes, but you mentioned that they are not all ... I will have to check them this weekend. Today tomorrow and friday too busy with real things LOL,

and will post you what is missing...

Adept III

I used to consider myself a fanboi of AMD's CPU division, at least until they decided to collaborate with Microsoft's desperate efforts to shove Cancer 10 down our throats by not realeasing Ryzen drivers for Windows 7. I've only ever used AMD CPU's since my first K6-2 in 1999, even when there were far better alternatives by Intel. But I almost cried when AMD bought that trash company that was ATI, I always hated their cards and drivers and history seems to keep repeating itself in this case. The only reason I would even consider recommending an AMD GPU is if you're cryptomining too. For gaming, never - don't even think twice and just go NVIDIA. Better cards, better drivers, far better support team and even far more knowledgeable users on their forums.

I had many good AMD cards 4850, 4870, 6870, 7850, 7950  every one was great with near zero issues. This RX 580 has been a challenge. But overall is running fairly well now. I wish it were the same for all.


Well, you probably don't play any games that use older OpenGL versions like Wolfenstein: Enemy Territory (I still run a server for that game). AMD seems to run older OpenGL versions over some kind of compatibility layer, and even the lowest end NVIDIA card will max out that game's engine, while even the highest end AMD card will go under 40 FPS often. NVIDIA's support for all OpenGL versions is and has always been simply perfect. I used to have a 7950, but on a separate rig for cryptomining only.


I actually played Wolfenstein: ET alot and never an issue. I have not played it however in many years, so no idea if it works now or not. But I do play all the current Wolfenstein games, I don't think those are Open GL though, I did play the new Doom in Vulkan and it was awesome. I have not looked to Open GL much in recent years. But years ago, I absolutely agree nVidia had the better OGL drivers, they may still have that I just have no experience to comment. I can tell you I played Open GL Doom 3 BFG edition on the HD 7950 2 years ago and it played well, how it would compare to the green team, I don't know, but I was not unhappy with it. I am not saying in the least AMD doesn't have issues currently, just that I had some pretty good luck with their cards until, recently.


pokester wrote:

I have not played it however in many years, so no idea if it works now or not.

I'm pretty sure it's been MANY years. Again, even the lowest end NVIDIA card will run ET way better than a same generation high end AMD/ATI card for the last 10 years at least. The same applies to other games that use the id Tech 3 engine - AKA the Quake III Arena engine - like MOHAA, COD, Star Trek Voyager: Elite Force, etc.

Adept III

I managed to find a workaround that fixed it for me. My problem was a little different - with the BOTCHED drivers (18.2.3 and later), Radeon Settings crashed during loading and never even finished loading. Also, its icon wasn't installed on the system tray, only on the Start Menu and on the desktop context menu. You may wanna give it a try though:

EDIT: don't know how to link to a specific post on this lousy Jive platform, so just go to the bottom of the page to see my post with the workaround.

I have had the missing tray thing before too. An uninstall and DDU from safe mode and reinstall has always fixed that for me. CCC would do the same thing before that from time to time.

The issue I have had since the replacement of CCC, with Radeon Settings, is that it is incredibly laggy. You click on a tab and it took all day to respond or would just lock. I wrote it off for years as my processor is maybe too week. When this same thing happened on a new machine i7-7700k fresh install. I knew it wasn't me. I think it may be all the games I have installed that cause the lag. Not sure why they have to bury the Global Settings tab in with the game profiles anyway. Seems to complicate it for lots of people. Why not just make it a Main Tab?

Thanks, for the advice. I really appreciate it when anyone responds trying to help.