Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Problem downloading Linux 18.20 drivers for Ubuntu 18.04

This official release channel seems to be unstable:

Radeon™ Software for Linux® 18.20 Release Notes

Attempting to download the Ubuntu 18.04 drivers results in a failed download sometimes (seems random, not based on net quality) when it nears completion. When the file does manage to download it is not in a format readable by tar and running unix file command shows the type as 'data' instead of 'XZ compressed data' as the command shows for the 16.04.4 drivers downloaded from the same page.

5 Replies

Downloaded Ubuntu 18.04 version 18.20 in my computer.

Used 7-Zip which is free to download and use. Extracted file to "TAR" file. Used 7-Zip again to extract files and created a folder  "amdgpu-pro-18.20-606296" . Trouble is I don't see any .EXE file to run driver installation. Don't know how to install drivers in Linux OS.

can't attach folder because it is over two hundred megabytes big. So, Download the Ubuntu 18.04 file. Unzip using 7-Zip to create a new "TAR" File. Then unzip that to the normal installation folder mentioned above.


Hello elstaci,

I tried to download the 18.04 drivers from a Win 10 machine and still found the results consistent with a corrupt file being served, that is an error upon (attempted) un-archiving.

Windows / 7zip test - Album on Imgur

As for why there's no .EXE, that is because the installer is supposed to run on Linux and .EXE is a windows-only format... To install on linux look for a file ending in .sh and try to run that.

If you could please upload your valid archive to a large file sharing service such as so that I can access it I would greatly appreciate it! If your upload speed is low can you at least give me the MD5 hash of the archive so that I can verify if I'm getting the same file as you?


Okay, downloaded Ubuntu 18.04 again and using 7-Zip uncompressed the file to "TAR". Then using your link I uploaded the file on "NOFILE.IO".  I tried to upload the Uncompressed "TAR" file but I couldn't upload the entire folder as a whole rather all the files in the folder. So, I deleted the upload to and upload the "TAR" file instead.

Here is the link to download the file from NOFILE.IO: (The file will delete itself after one week).

Note: nice website for uploading large files for free. They said they will be making it a Paid website in the future. I bookmarked the site. Thanks for the info on the uploading site.

Journeyman III

I have the same problem.

tar -Jxvf amdgpu-pro-18.20-606296.tar.xz

xz: (stdin): File format not recognized

tar: Child returned status 1

tar: Error is not recoverable: exiting now

xz-utils is already the newest version (5.2.2-1.3).

Tried to download in Windows 10 and decompress but 7zip said that this is not an archive.


I Re-Downloaded the Ubuntu 18.04 Tar.xz file and unpacked it to the original .TAR file.

Click on this link to downloaded the unpacked .Tar.xz file. It is free to download.

Will be on this site for only 30 days;:

Once you downloaded the .TAR file install it normally in Linux Ubuntu.