Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Issus with installing 19.5.2/19.6.1 on Windows 10(1903)

When I'm trying to install Radeon 19.5.2/19.6.2 it's crashing my entire system and pc is getting stuck while trying to boot. Although it works fine in 1803.

1 Solution
Adept I

Guys!! Its fixed, (well for me atleast) 
Install the latest 19.7.1 optional drivers. Everything works well now! Finally!
I did a clean install so would recommend that.

View solution in original post

166 Replies
Adept II

Please share more details about you'r system, what gpu etc.


Is your Win10 receiving an AMD driver update via Windows Update?

For me I have the driver version of AMD 26.20.11010.1002 and I can say that it is perfect (great improvement in performance)!



Adept I

got the same issue, stuck with the WU driver for now. will try other versions

hows the performance with the WU drivers?

also let me know if u find any working version.



Adrenalin 19.4.3 worked for me, also do you have hyper-v enabled? 19.5.2 works if I have it disabled.

yes, I have windows hypervisor platform disabled.


You need close memory-integrity in Windows Defender.


Wait, memory integrity?


OK, so I just disabled AMD-V, reinstalled the latest driver and still not working.

Adept I

Same here. My system is now unable to boot completely. Not even in Safe mode.

A8 with R5, HD 8500 M on Win 10 64bit, 1903 May update.

After installing 19.5.1 all games started lagging. Then i got this 19.5.2 and it crashed the system during install. I received something like "Windows shutdown itself to protect itself".

I restarted, removed all drivers using DDU. Then disabled Win update. Retried install of 19.5.2. It succeeded this time but after restart it's not booting. Finally, after backups, I did a clean install of Win10 without internet. No display drivers were installed. Ran 19.5.2 install first again. Crashed again. After force install, again bootloop. Now, doing clean install again. So, as Adrenaline was the only installation, it is the culprit.

Thanks AMD for wasting my weekend amd not doing testing  drivers on legacy devices.

Hold up, that's what I use. A8-6410 to be exact.

Also I can boot into safe mode even with the driver installed.


Safe boot uses the Microsoft VGA driver.


Oh yeah... my bad 


Make sure fast start is disabled in windows. Please note that if you cannot see the option in the window, that it still might be enabled. I had disabled it in the past, then some updated enabled it behind the scenes.

From admin window command prompt:

Turn on hibernate:

   powercfg /h on

Turn off hibernate:

   powercfg /h off

Turning hibernate on will allow you to see the option if it is hidden, and you can verify that it is off. Then immediately turn it off again. Of course, no need to do this if you can already see the option.

How to Enable or Disable Fast Startup

Deciding whether to bother with Fast Startup actually takes longer than turning it on or off. First, open up your power options by hitting Windows+X or right-clicking your Start menu and selecting Power Options. In the Power Options window, click “Choose what the power buttons do.”

power options

If this is the first time you’ve messed with these settings, you’ll need click “Change settings that are currently unavailable” to make the Fast Startup option available for configuration.

available options

Scroll to the bottom of the window and you should see “Turn on fast startup (recommended),” along with other shutdown settings. Just use the check box to enable or disable Fast Startup.  Save your changes and shut down your system to test it out.

fast startup

If you don’t see the option at all, it means hibernation is not enabled on your machine. In this case, the only shutdown options you’ll see are Sleep and Lock. The quickest way to enable hibernation is to close the power settings window and then hit Windows+X and open Command Prompt (Admin). At the Command Prompt, type the command:

powercfg /hibernate on

After turning hibernate on, run through the steps again and you should see both the Hibernate and Fast Startup options.


It's not good to have Fast Start On?

Adept II

Oh, I thought it just me.

Anyway, the real problem I had is the screen seems to got stuck in the boot loader, because when I press Space, Windows thinks that I already at the login screen.


yeah same .. the screen gets stuck while booting windows i think.


Do you have the ability to plug a secondary monitor in? The login screen may have jumped to the other output. 

Adept II

Hi guys. There is an old laptop Lenovo ideapad 110-15ACL AMD A6-7310 APU with AMD Radeon R4 Graphics + discrete AMD Radeon R5 M430 2gb., RAM 8 Gb, ssd 240 Gb.
Until 1903, all driver versions worked fine. After installing 1903, the laptop only works with the old v.21.19.512.0 (21.03.2017) drivers from the Lenovo website.
But if I disable a discrete card in BIOS, then I can install any, even the newest driver. When installing any AMD Video driver,  Win10 1903 is loading, but a black
 screen and an empty taskbar. If you install the old driver v.21.19.512.0 (21.03.2017) from the Lenovo website or turn off the discrete card, it works super.
What could be the problem? Why do all new drivers work for 1809, but not for 1903? What could be the problem?

Adept I

Thanks to all for trying to help. I clean installed Win10, 3 times till now and none of the driver works. Not even WHQL certified versions. It just fails to boot. Also, I managed to go in Safe from recovery disk (regular doesnt work even if it uses VGA - my system never reaches there). I restored, used DDU and reinstalled any available version back to 17th. Nothing works.

Only version which is working is 2015 version. If I update it using Windows then it updates to 2016 version and again Window doesn't boot.

Now, I am thinking if Windows 10, 1903 update is culprit. It might have changed something which is not compatible with AMD legacy devices.


Adept II

Don't know if this will answer any questions, but....

AMD RAID driver incompatibility

Microsoft recently confirmed that installing Windows 10 May 2019 Update could fail if the device is using certain versions of AMD RAID drivers.

A problem with certain AMD Raid driver and Windows 10 May 2019 Update may cause stability issues.

As per the support document, the problem is associated with AMD RAID drivers that are older than Microsoft recommends users to get this or newer version of the drivers to install Windows 10 version 1903.

You can always install the update via Media Creation Tool, but Microsoft is against this solution as it may cause unexpected issues.

If you use the Update Assistant tool, the process of installing the new update fails immediately after it scans the system.


What this has to do with Radeon?

Guess you've all read the list of current upgrade issues that MS put out. and no doubt there will be new ones added on next C.U..

Perhaps your current specs are not yet fully compatible, this happens every new 6 monthly version where those that force install it run into issues on older spec, people on new spec systems are also finding quirks/bugs but can mostly find workarounds. 

By all means, if you find a definite bug that can be reproduced by users, report it to the amd driver team 'Report Issues Online'.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Adept II

My only deal to solve this for now is to install the drivers from HP's support page.

Driver version: 15.201.1101.0 Rev.A


Yes that version is working. Only thing is, it is too old. Far cry 3 is not running properly. Borderlands giving me lags never seen before. Batman Arkham is not even launching. I guess i am stuck with Minecraft. That still works flawless. 

Adept II

yeah i am also using the drivers provided in the manufactures website..they are working fine...


Just install 19.5.1 in your AMD folder. It works fine:

  1. First boot into safe mode. If you wait until your computer tries to boot then press the reset button (perform this action 3 times), it will bring up the recovery console after the third boot attempt.
  2. Use the startup options to get to safe mode.
  3. Then get into device manager, right click on the display adapters and uninstall them (delete the driver too)
  4. Reboot. Your computer will now boot into normal windows.
  5. Then run the AMD cleanup utility (google "amdcleanuputility-x64.exe"). This will remove the adrenaline software and give you a clean slate for an install.
  6. reboot.
  7. Then finally change to your C:\AMD folder using windows explorer and chose the 19.5.1 driver folder. 
  8. Click Setup and install as normal. 
  9. Reboot and enjoy and wait for 19.5.3.

So just extract the installer's contents into a folder and it should work fine after using the installer right from the folder?


To be clear I'm talking about installing 19.5.1. NOT the bad driver which is 19.5.2. 

Adept II

I'm facing the same issue with an Acer laptop. It has an R7 M265. Before the update to 1903 it was running fine but since then the installation of Radeon Software 19.5.x results in a black screen with the mouse pointer. No way beyond that.

I've booted into safe mode, removed everything with the AMD driver cleanup utility and DDU and rebooted. For a while this seems to work, however, without the ability to add my second monitor, which is connected via HDMI. But while I am working, in the background windows is downloading and installing the "latest AMD driver". And then, same thing: black screen. 

When I again reboot into safe mode, clean up and boot into system and then install Radeon software 19.5.2 again it says installation was successful and that I should reboot. After reboot the system gets stuck at the screen with the circling dots. I did this repeatedly, various times trying to get my system running again, and two or three times this black screen would finally show the login page and windows seemed to function normally, but when I would open Radeon settings it said that no AMD driver is installed or not functioning properly. Going in circles.

The only solution was to go back to the previous windows version. :-(

19.5.2 is beta. You mean your windows update is attempting to install a beta driver? That doesn't seem right. I installed 19.5.1 which is the WHQL driver. Meaning it's the latest OFFICIAL release. My windows update doesn't attempt to download 19.5.2 at all.


I already tried 19.5.1. It doesn't work. The same was working previous to Win10 1903 update.

MS is also confirming that latest update actually broke AMD support for many devices. They are still collecting feedback and reports for that. None of the drivers will help other than WHQL from MS update library. In our case it is 2015 version.

Today, I received KB4497935 fix, I am unsure if it addresses the issue.


I don't know, which version Windows downloaded automatically, but whatever it was, that didn't work either. It resulted in the same black screen. Version 19.5.2 came out a day after I installed Win10 1903. First, I had updated to 19.5.1 but as that didn't work with the same problems as described I tried 19.5.2 the next day. However, nothing seemed to work and the combination of Windows 1903 and AMD drivers rendered my computer unusable. Only the standard Windows VGA screen driver let me see anything, but that one didn't recognize my second monitor. Alas, I had to revert to the previous Windows installation where everything is working fine.

Why does updating AMD drivers and/or Windows always have to be such a pain? :-(