cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

set1
Adept I

I cant active Vulkan Api

Hello. I have a phenom II system which is x4 965 BE with HD 7850 1 GB graphic card and using Windows 10 x64. I am usind gpu driver version 20.3.1 and yesterday bought a game called as "World War Z" and I cant select Vulkan Api from graphic settings of game. Normally game has ability with Vulkan Api. Can you help me for how can I activate my Vulkan driver for my Gpu? As I read that my Gpu is suitable with Vulkan Api but I dont know how can I activate it. Can you help and advice please? Thanks in advance... 

0 Likes
16 Replies
mstfbsrn980
Grandmaster

Re: I cant active Vulkan Api

You don't have to activate anything for Vulkan API to work effectively. Uninstall the installed display driver using DDU and Windows Safe Mode and perform a clean driver installation with Windows Normal Mode. Trying an old driver or trying clean installation might fix the problem. Old drivers for you are there... https://www.amd.com/en/support/previous-drivers/graphics/amd-radeon-hd/amd-radeon-hd-7000-series/amd... 

elstaci
MVP

Re: I cant active Vulkan Api

Before uninstalling your AMD driver, download GPU-Z and verify that Vulkan and OpenCL for your GPU Card is not enabled. If it isn't then do as mstfbsrn980 suggested.

AMD Driver is what enables Vulkan and OpenCL on your GPU Card. GPU-Z should show Vulkan and OpenCL boxes marked with a check mark.

Here is mine on my Nvidia GPU Card:

set1
Adept I

Re: I cant active Vulkan Api

Very thanks for the answers and advices. My Gpuz is attached. As you can see that my OpenCL and Vulkan is enabled. After saw this information, I tried another game which is capable with vulkan api which is "Strange Brigade" and It works with Vulkan Api without any problem. I tried several old drivers already such as 19.4.2 and 19.11.1. After I return back to 20.3.1 again. At the moment only World War Z is not working with Vulkan. I cant choose it from the settings menu. Only Directx 11 is showing. What should be the problem?vulkan.jpg

elstaci
MVP

Re: I cant active Vulkan Api

The current AMD driver is enabling Vulkan and OpenCL on your GPU card.

The problem is not AMD Driver but rather that specific game. I suggest you open a Thread at the game's Forum.

World War Z does run on Vulkan. Check AMD Radeon Settings to see if there is any settings related to Vulkan or DirectX.

Look at World War Z config file and see if Vulkan is disabled.

The specs for a Sapphire GPU card shows the following for Vulcan and OpenCL and OpenGL:Sapphire HD 7850 Dual-X 1 GB Specs | TechPowerUp GPU Database 

elstaci
MVP

Re: I cant active Vulkan Api

Here are the last patches for World War Z: Focus Forums 

Many involves Vulkan fixes.

mstfbsrn980
Grandmaster

Re: I cant active Vulkan Api

- Disable Radeon Image Sharpening. I know from my own experience that this feature is causing problems with Vulkan API.
- Back up and delete these regedit paths and try running the game with Vulkan API.

HKEY_CURRENT_USER\Software\Khronos\Vulkan\ImplicitLayers
HKEY_LOCAL_MACHINE\Software\Khronos\Vulkan\ImplicitLayers
HKEY_LOCAL_MACHINE\Software\WOW6432Node\Khronos\Vulkan\ImplicitLayers

These paths must be deleted while Steam or Epic is running. Because store applications reorganize these paths at launch.

- If the game displays an error window, maybe you will share it...

elstaci
MVP

Re: I cant active Vulkan Api

Make sure you backup the Registry before deleting any keys in case you have problems or create a Restore point.

This Gaming website has very good information about WWZ and technical Information to help troubleshoot the game: https://www.pcgamingwiki.com/wiki/World_War_Z 

Here is where World War Z configuration file is located at:

Windows:

C:\Users\(Username)\AppData\Local\Saber\WWZ\client\storage\

(You need to replace USERNAME by your actual user name in Windows)

Maybe if you upload WWZ Configuration file,  MSTFLBSRN980 or others Users can take a look at it and see if there is anything preventing Vulkan from being enabled.

elstaci
MVP

Re: I cant active Vulkan Api

From the link from the gaming website Technical FAQ: Focus Forums 

set1
Adept I

Re: I cant active Vulkan Api

Dear Elstaci thanks for the informations. I checked games forum and yes you are right many fixes were made with new patch. Against your advices I made things at below;

Checked Amd Radeon Software but I coudnt see any setting related to Vulkan Api.

Checked games config file which name is video.dat and opened with notepad but couldnt see anything related to Vulkan api too. Tried some video options to enable or disable as (0-1) but every start of game, this config file returns to default values.  

At the other hand yes you are right that this problem is not Amd driver issue but rather that game. I tried some Vulkan games too and they are all working with Vulkan and I match with directx performance and nearly 15% performance increase at Vulkan side. Impressive!

Now I am trying to figure out why World War Z is not working with Vulkan. May be I also try very old version of game with download from torrents to see what was the original version with Vulkan Api. May be new fixes broke Vulkan for specific Gpu's.