cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

PojaAnti
Journeyman III

Fortnite FPS Drops, Stuttering when Using DX11/12 and Performance Mode

Hey! we have issue with drivers to play fortnite (performance mode). 

With dx12 i can play solid 200fps lock but with performance mode it’s 70 fps. We need new drivers for AMD to play it correctly. Thank you!

BE63593F-F946-49D1-B0E4-D365E96E4E62.png

Specs: 

3600x, 16gbram, radeon rx5700xt.

 

291 Replies
Sniikz9k
Journeyman III

have the same problem with a rx 6700 xt

Sniikz9k
Journeyman III

I have the same problem with the Rx 6700 xt. Did you find the problem or is it due to AMD drivers?

UserAguman
Journeyman III

Performance Mode in Fortnite runs on DirectX11.

Multi-threaded rendering is disabled in this mode so that's why you're experiencing framerate drops as this will make your Ryzen processor mostly utilize one of its core.

Performance Mode was designed for players who have low-end computers. You won't benefit from using this mode, it's better to run your game on DirectX12 with multi-threaded rendering enabled.

Thats right but there is another thing that seems weird to me

I have really bad FPS drops on Performance mode on a 5700 XT sometimes even to the 70s when im looking at Lazy Lake the FPS seems locked there. I found out that my hardware isnt even utilized that much. The CPU and GPU are sitting at 30% and none of the 12 Threads of my Ryzen 5 3600 @ 4.3 GHz is utilized over 80%. And if I change the use Feature Level (ES31) to false my FPS are significantly higher (Im talking about double the FPS) but then you cant choose the 3D meshes. So it is definitly an optimization problem bc the hardware is bored while playing but the FPS are dropping.

sajjadcool
Journeyman III

yeah having to same problem stable fps on dx12 and bad fps on dx11 and performance i want my refund why did i bought a amd gpu give me my refund you dont know how many years i saved my money for to a gaming pc and cant even play a game

Stjauts
Adept I

Please fix this !!! performance mode is unplayable

This problem exitsts a long time. From my opinion it comes only with AMD CPU and AMD GPU. Same GPU with Intel Cpu does not dropping frames.

so you think getting a Nvidia GPU will fix it?

I do not play fortnite but having the same issue with armored warfare. AMD GPU + CPU FPS hard FPS drops. Same Card with Intel CPU no FPS drops in this game. AMD Cpu + Nvidia Card (1070 TI) no FPS drops in this Game.

I have a RX 6600 XT. A friend of me had exactly the same experience with a RX 6800 XT.

Yep, still isn’t fixed. I guess i need to buy NVIDIA.

Cuz NVIDA doesn’t have problems with that.

daki777
Journeyman III

I have a power color rx 6600 xt with the same problem

0 Likes
flyxytk
Adept III

AMD you need to fix this or at least report it to epic games. As this Video shows even the latest amd stuff is pretty bad in fortnite dx 11 and PM

0 Likes

Hi did you found any fix?

Unfortunately not really. But I found a way to make it somewhat playable. My 5700XT downclocked in Fortnite to about 800 mhz. Locking the clock to 1900mhz didnt work, the clock still spiked down which resulted in more stutters. The somewhat solution I found was disabling power saving things in the cards bios, which brings the risk of bricking the card. For me it worked tho. Now I can lock my clock to 1900 mhz in Fortnite and it stays there stable. I still get drops to 90 fps but its far rarer than before. 

If you want to do it, youll find a tutorial here. If you have done it create a profile for fortnite in wattman where you lock the clock at almost max speed, as seen in the video. You may want to create a custom fan curve because the card gets a bit warmer because it stays at the clock youve put in as long as the game runs. If you want to do it do it at your own risk. Allthough the chance of bricking your card is very very low, if you mess something up it still can happen so be cautious!

Thanks for all the posts. We are aware of this and are investigation. Please track this thread for future updates. I'll update the thread when I have more information to share.

I play with directx 12 custom graphics, the latest fortnite update messed up with performance but i founded a trick. Now im play 280 fps 300 fps with amd gpu. I have turned the ray tracing on and save, restart the game, disable ray tracing save and restart the game again.

Thanks, boss, that helped quite a bit.

But I still hope they fix it soon. 

I bought an rx 6600 XT yesterday instead of my 1060 6gb and honestly I didn't help myself at all as far as fortnite

0 Likes

@Dejva1999 

the problem is going on since a year

some makeshift fix were found, but amd still didnt do anything about it

I really don't understand anymore.
When I set my graphics settings to high my fps are like this : https://ctrlv.cz/VgKp , https://ctrlv.cz/O4aW
and when I set my graphics settings to low or medium, my fps are : https://ctrlv.cz/yx3g , https://ctrlv.cz/zj3s
Can someone please explain this to me ?

0 Likes

@Dejva1999 

it has to do with the game which are "heavy" on cpu instead of gpu
dx11 also more rely on cpu rather than gpu

when on dx11/cpu heavy, the amd gpu enter in some kind of mode in wich it turn itelsf off in order to save power. amd gpu are advertised for their low energy consumption, and it's the problem

0 Likes

And you think this is gonna get fixed? Because, I don't want to play on high settings, I was used to performance mode on my 1060 and there it was all perfectly fine, but here it doesn't work at all.

0 Likes

@Dejva1999 

I have no idea but doubts.


0 Likes

it is the same issue of blinking/flickering/black windows. When AMD gpus are in idle or very low usage, gpu cycle goes to zero and you have fps drops or other problems (look mhz with adrenalin overlay ALT+R during game). In this forum you can find some solutions by using third independent party applications but it is not a solution, just a risky workaround (set cycle 0 of 2d and 3d not to zero but to 500 mhz) as you have to override gpu bios/firmware.

I find first complainings about this issue in 2013 forums... in 2022 we are here talking to the same thing. AMD do nothing about it and this is a worst than the issue itself.

@DocT 

"(set cycle 0 of 2d and 3d not to zero but to 500 mhz)"

can you provide a link please ?

0 Likes

@Adamkd 

| igor ́sLAB | PC e componenti Recensioni & Notizie (igorslab.de)

click on MorePowerTool. The latest version is 1.3.10, read instructions accurately as it is not an easy process.

Before doing the entire procedure and flashing bios, I suggest you to just try to delete deep sleep state by creating registry entries with this method (always using MPT and its SPPT feature):

Re: 6800xt Clock speed problems (downclocking) - AMD Community

0 Likes

@DocT 

thanks

but already did that with no improvment

0 Likes

at this point you should edit your bios and change clock frequencies until you don't find the right ones for Fortnite. For me (rx6700xt) power0: 300 power1:800 solved the issue. But every system is different.

By the way, as it is a long procedure with a high risk to mess your GPU, I would suggest you to wait some new updates of Fortnite ( I am sure AMD won't solve that problem in next drivers). Performance mode is still in beta and they are developing it mainly with Nvidia.

0 Likes

@DocT 

will i be able to play on Dx11/performance mode if I do it ?

0 Likes

Experiencing same issue as listed above. 5700 XT and getting crazy stutters. Yes DX12 will run better but the input delay is terrible. Would really appreciate you looking into this issue. 

delete

 

 

 

0 Likes

Matt, can we get an update on this? A lot of people are having Fortnite problems, myself included.

been a month and still no update... this should have been looked into months ago, yet one of the most popular games and we still cant play it with a stable fps on good hardware. its just a joke, yea dx12 exists but its still very inconsistent 

We are still looking at the issue, I don't have any further update. I'll update the thread once that changes.

Regarding using the performance mode. As that is listed as beta by the game, I would not suggest usiing it and would use either DX11/12 depending on which currently works best with your setup.
0 Likes

@Matt_AMD 

please read the thread

it's not the fortnite performance mode which causes this issue since many games are concerned.

it happens with DirectX11 ( in fortntite performance mode runs dx11 )

i can only play using directx 12 but yet i still need to use trick in order for the game to "work"

0 Likes

You'd have thought AMD would be going all out to fix this issue with Fortnite being one of the most popular games currently. Literally been trying to get a 6600xt for ages to complete my new system, finally get one and I was getting better performance from my GTX 980 from 7 years ago. Unbelievable. 

i mean, cant blame amd for all the fault their, should have looked into the stats and performance of the card you got before getting it. making sure their were no issues with big seller games and what not. if you do no research to see how the card holds up is it really amd's fault? also, they've been looking into it, its been fully acknowledged as an issue by amd now. just give them some time to search and find the cause of the issue and fix it. otherwise switch back to the 980 for now if you want the better performance for now?

@ttocchi

i did make research before buying, and the test on youtube never told about this issue

also it wasnt fully acknowledged by amd since they tell it affect performance mode while it in fact affects dx11, dx12, and performance mode(which works on dx12)

there are some work around on dx12 but the gpu is fare from being fully exploited

firstly, it affects dx11, not dx12, performance mode runs through dx11. they acknowledged the issue stating they were looking into it. dx12 runs fine for the most part. you might occasionally crash or have a stutter but its still much more playable then dx11. 

0 Likes


it affects dx12 too

many videos and messages were posted about it

if the game works fine with you then great but go fanboying elsewhere please

 

0 Likes