cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

brain29
Journeyman III

Cant install tr4 chipset driver amd-chipset-drivers_18.10_feb error 173 ????

Can't install the new drivers for tr4 says I don't have a Amd graphics card .. WTF

can't find a clean uninstall for the chipset either

0 Likes
1 Solution

There is a bug in AMD Chipsets that prevents it from installing on a AMD motherboard with a Non-AMD GPU Card installed. I have the same problem but there is a workaround for it. This is the Thread that explains all the problems people are having with this issue but it does give a workaround fix in being able to install AMD Chipsets on a AMD motherboard with a Non-AMD GPU card installed: https://community.amd.com/message/2843147?q=Raid%20chipset .

Sometimes updating the BIOS and Motherboard (if it is Intel) Chipsets helps with newer AMD Drivers to install correctly.

View solution in original post

0 Likes
8 Replies
goodplay
MVP

One for amdmatt

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 7000s 2tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes
brain29
Journeyman III

nobody? is it an Asus zenith problem ? could it be the same reason why Asus blames AMD for bad AGESA 1.0.0.4 code ?

0 Likes
genrabbit
Adept II

Can't install it on my Gigabyte x370 motherboard either. No error messages. Just hangs. No install window/Progressbar or anything

0 Likes
elstaci
MVP

Need to provide more information on your computer setup. Are you using a AMD or Nvidia GPU card? Are you trying to install RAID chipset or just the regular AMD chipset?

0 Likes

I have a AMD Radeon 480 card. F21. latest non Beta Bios

0 Likes
brain29
Journeyman III

I'm trying to install either non of them work

I'm wondering if they listed the wrong chipset for tr4 x399 the Last one that works for my board is 9.0 (it still works) but it then jumps to 17 then 18 (new ones don't work) - kind of a weird number skew

I have an nvidia gpu but that shouldn't matter for a chip set I have a very old amd card that gave the same error when I stuck it in

0 Likes

There is a bug in AMD Chipsets that prevents it from installing on a AMD motherboard with a Non-AMD GPU Card installed. I have the same problem but there is a workaround for it. This is the Thread that explains all the problems people are having with this issue but it does give a workaround fix in being able to install AMD Chipsets on a AMD motherboard with a Non-AMD GPU card installed: https://community.amd.com/message/2843147?q=Raid%20chipset .

Sometimes updating the BIOS and Motherboard (if it is Intel) Chipsets helps with newer AMD Drivers to install correctly.

0 Likes
brain29
Journeyman III

Would love to install an updated uefi for Asus amd x399 if Asus made one - but they blamed amd for buggy AGESA that knocked out half the ram channels for everyone. So for the past 2 months they have just been saying stay tuned.

thanks for the fix CHIPSETBUILD=true worked for me .. I guess Asus blaming amd might not be so far fetched

0 Likes