Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Can not acess additional settings in Amd Radeon Adrenalin

This is my Amd Radeon settings


This is where I used to open the additional settings


My problem is that the game Path of Exile from Steam, doesn't use my dedicated graphic card but only uses the Intel integrated graphic card. I have tried launching the game through the Radeon settings but it didn't work.

The only real solution that worked for me was to let Windows automatically search and install the grapic drivers, it would install an older version of the Radeon Settings that allowed me to use the addtional settings interface. This works, but causes words in the game to ocassionally be in the wrong colour(green) or not appear at all.

I was looking around for a fix to this and the only thing i could find from 2017, is to downgrade the drivers and go back to the 17.1 version.

Is still that the only solution? Or is there another way?


Hp Pavillion Windows 10 64-bit; Processor Intel i7-6500u CPU 2.50GHz


If more details needed ill be here to answer

5 Replies

The 'Radeon Additional Settings" was eliminated some months ago. Everything is contained in the control panel/Radeon settings  now.


Ok, then how do I run my game with the dedicated graphic card?

My game appears on the Radeon settings but when i launched it, it doesnt use my Radeon card.

If everything is contained there how am i suppose to use it?

In Alternate graphics the game is there, it say it was used but is not. I checked througth the Task Manager and the Radeon graphic card use is 0 while my Intel igpu is doing everything.

Where is this "control panel/Radeon settings?


There is a lot of information here > Radeon™ Software Help Center | AMD

Use the built in monitor to see which graphics is being used..not task manager.

Configuring Laptop Switchable Graphics on a Windows® Based System

Yes, that exists. I already did that, all of that; Choose the game, choose high performance. I also went and looked in the Task Manager Performace Tab and no, it still doesn't use the Radeon graphics, even so, I dont need to use anything to see that the dgpu is not being used since the game fps is super low.

I gave up honestly, went back to 17.1.1


I know is the same thing, same options just different UI, it should work in the 18.2.1 Adrenaline something but it doesn't for me. In the 17.1.1 it works. I get usage of my Radeon card verified by the Task manager, the built in monitor of AMD and the game runs better.

I don't know if is a problem with Steam games or something but it's a shame. I'm trying to make it work with AMD here but is not easy and Im starting to think is not worth it.

Thanks for the answers anyway.


Just to confirm, your Windows power settings are set to High Performance, correct?