cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

ritchie
Adept I

AMD ReLive interfering with Ctrl + Shift + [letter] shortcuts in other apps

I was having issues with my Visual Studio and Notepad++ because a commonly used shortcut stopped working. Ctrl+Shift+L is a delete line shortcut. ReLive doesn't use this exact shortcut but it seems to capture and block the shortcut from passing to other apps - even when ReLive is disabled/turned off (but still installed).

ReLive Settings.PNG

I raised this issue with Microsoft thinking it was an issue with VS2017

If you disable the 2 ReLive background processes: AMD ReLive: Desktop Overlay and AMD ReLive: Host Application - in that order otherwise they restart

processes.PNG

As soon as that is done, Ctrl+Shift+L will work again.

Please fix, otherwise ReLive will have to be uninstalled.

1 Solution

Hi,

Since my original post I actually found out how to disable the shortcut but didn't post anything here because there was little interest in this issue (apart from one unhelpful reply ). However, you seem to be genuinely just as annoyed as I was, so hope this helps.

You need to go to Gaming > Global Settings > Performance Monitoring > Toggle Performance Logging Hotkey

You will see this is bound to Ctrl + Shift + L (so the shortcut is used - just buried).

To remove the shortcut (not an obvious process at all!) you need to click the Toggle Performance Logging Hotkey button, it will then ask to enter your hotkey, you then press delete - that is Del (not backspace, not esc or anything else - the Del key).

ReLive Removed Hotkey.PNG

Congratulations, you now have now removed that annoying shortcut and can use ReLive if you so wish.

God knows what I've ended up logging because of this hotkey.

View solution in original post

22 Replies

You know you can click on any of those hotkeys and reassign it to whatever you want.

0 Likes

As said above, the exact shortcut isn't even used. ReLive is intercepting ALL Ctrl + Shift + [any letter] key combos and interfering with other applications' shortcuts.

0 Likes

That does not happen with mine.

0 Likes
aubergine
Adept I

There has already been a few update releases since the original post in this thread, yet this problem persists.  The only solution appears to be to wholly uninstall the drivers package.  Whether you install the full Adrenalin Edition or the AMD Minimal Setup version, and opt to *not* install the AMD ReLive,  the AMD ReLive: Desktop Overlay and AMD ReLive: Host Application are still installed, are running as active processes, and still function to: as ritchie says above, "As said above, the exact shortcut isn't even used. ReLive is intercepting ALL Ctrl + Shift + [any letter] key combos and interfering with other applications' shortcuts."

Follow up:  I installed the Adrenalin Edition 18.5.2 Optional version and chose this time to *not* install the System.  Either this is the work around, or AMD has actually addressed the issue in this optional release, but neither the AMD ReLive: Desktop Overlay nor the AMD ReLive: Host Application are running.  I restarted my system twice to be sure.  I was also never given the option to check/uncheck the install ReLive which may be for the reason I chose to not install the System.

0 Likes

Hi,

Since my original post I actually found out how to disable the shortcut but didn't post anything here because there was little interest in this issue (apart from one unhelpful reply ). However, you seem to be genuinely just as annoyed as I was, so hope this helps.

You need to go to Gaming > Global Settings > Performance Monitoring > Toggle Performance Logging Hotkey

You will see this is bound to Ctrl + Shift + L (so the shortcut is used - just buried).

To remove the shortcut (not an obvious process at all!) you need to click the Toggle Performance Logging Hotkey button, it will then ask to enter your hotkey, you then press delete - that is Del (not backspace, not esc or anything else - the Del key).

ReLive Removed Hotkey.PNG

Congratulations, you now have now removed that annoying shortcut and can use ReLive if you so wish.

God knows what I've ended up logging because of this hotkey.

Just went through the painstaking process of creating an account for this site just to tell you thanks for posting the solution. I already spent quite enough time trying to track down the program itself but finding this setting and how to clear out the shortcut (instead of entering another one) would have taken forever!

Again, much appreciated!

Thank you! I had an issue with google chrome, where ctrl-shift-o wasn't opening the bookmarks, or doing anything else. It was only today that it started opening what I thought was a random gpu statistics overlay that I looked for something else causing the issue... this was the first google result that came up, and it worked perfectly!

Now I find that all I need to do is to go to Preferences and uncheck the Show Overlay box.

0 Likes

Glad to hear this has been helpful to some people. I occasionally get emails of thanks from this post.

I have since upgraded my computer and got an NVIDIA GPU. That's one way to fix this issue...

0 Likes

I wholeheartedly appreciate that you posted this very clear explanation of how to fix this.  Thank you so much!  I too had to create an account to make sure you get the kudos you deserve for it.

0 Likes

Thank you for posting this. I was so frustrated after installing this software and couldn't use ctrl + shift + S to "Save As".  Appreciate it. 

0 Likes
aubergine
Adept I

Thank you for the follow up.  This has been a thorn in my side for weeks.  I'll try this on the next update.  You've been a big help from the initial post simply by opening this thread.

kurzedmetal
Journeyman III

I totally didn't waste 3 hours today trying to figure out this... I'M REALLY PISSED.

I think the worst offender on this is registering TWO global hotkeys on windows and actually not triggering any popup, notification or any kind of user feedback when I actually press the key CTRL+SHIFT+L and CTRL+SHIFT+O combos anywhere. It's totally freaking silent.

I remember having a similar issue with the "Radeon Overlay Hotkey" a long time ago, but at least that generated the freaking Overlay while in a game.

niksac
Journeyman III

Thank you for explaining how to fix this.

Please update the app, AMD!

Rj1024
Journeyman III

As of 2021 July, we have a Use Hotkeys toggle function on top as you can see in below picture, that will enable or disable all the hotkeys in one go. So thankfully AMD fixed the problem.

Rj1024_0-1626121425840.png

 

0 Likes
jul_dave
Journeyman III

*** FIX ***

This problem is fixed with version 19.12.2 (relased on dec 4th 2019).

simply go to settings, click the 'Hotkeys' tab and deselect all hotkeys that contain the ctrl+shift combo.

you can also reassign the hotkeys if you wish.

0 Likes

Even after disabling all hotkeys, CTRL+SHIFT+R triggers the radeon software.. Are you experiencing this as well?

0 Likes

I was experiencing this too, the actual fix is opening registry editor and deleting (or modifying) keys' data (the registry path is Computer\HKEY_LOCAL_MACHINE\SOFTWARE\AMD\DVR)

Once you are done with modifying registry, log out or reboot your pc

Naturally, I meant only the registry keys that contain actual key combinations, I would not recommend changing any other. I deleted all the registry keys that have a combination specified in Data column, and so far it didn't break anything (apart, of course, for the combinations not working with amd software anymore)Untitled.png

No

0 Likes
qjake
Journeyman III

I created an account just so that I could post about how utterly stupid this is. My Ctrl+Shift+C and Ctrl+Shift+E shortcuts were simply not working, and not doing anything.

In case anyone's wondering, AMD updated their software, which now looks like this:

pastedImage_1.png

There was no Ctrl+Shift+C or E on this screen. I deleted all of the shortcuts anyway, but I still couldn't use the shortcuts.

I even submitted an issue to Microsoft thinking that their new Edge release had a bug in it preventing me from using Ctrl+Shift+C: Ctrl+Shift+C Developer Keyboard Shortcut Doesn't Work - Microsoft Community 

The only resolution was to:

  1. Delete all registry keys from the post above that contain any mention of a keyboard shortcut (I found the ones for Ctrl+Shift+C and Ctrl+Shift+E here).
  2. Stop the AMD External Events Utility service.
  3. Set the AMD External Events Utility service to disabled so that it doesn't start up again.
  4. Kill all AMD processes running on your machine.

Then my keyboard shortcuts in other applications (Edge, Visual Studio) started working again.

AMD, if you're reading this, never take over keyboard shortcuts without the ability to change/remove the bindings, and ALWAYS show some sort of feedback when the shortcut is pressed. I cannot express how frustrating this is for people! How did this pass QA?!

I made an account  to say thanks. Also here's some pics incase anyone else gets stuck.

1. Make changes to registry at the location you specified Computer\HKEY_LOCAL_MACHINE\SOFTWARE\AMD\DVR

pastedImage_1.png

2. Stop the process

pastedImage_2.png

3. Set the service to not start on boot and reboot PC

pastedImage_3.png

0 Likes