Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

7900XTX issues with video projector


I just got my 7900XTX that I mainly use on my 3840x1200 monitor and everything works fine. But I also have my 1920x1080 video projector plugged into my graphic card for movies, etc... When I turn it on, the resolution on my projector doesn't scale to its native resolution, instead it appears like compressed 3840x1200 on a 1980x1080 screen: I have the full length of the screen but only half of its height. To be clearer: my 3840x1200 wallpaper is displayed in its entirety on my projector which shouldn't be the case. And as its forcing display of this large image on a smaller screen, only half of my height screen is used. I never had any issue with my old graphic card so I tried to figure it out.

I checked Windows settings and it's all good (both "screens" have the right resolution), checked Adrenalin and here again the resolutions are both good. I finally checked the signal received by my video projector and it's 1920x1080 60Hz.

I really don't get why the resolution didn't scale on my projector so I also tried to unplug my main monitor (3840x1200) to force my graphic card to finally scale a 1920x1080 signal on my projector as it was the only monitor left but instead I had a black screen that disappeared only when I plugged back my main monitor. I also tried to set both resolutions at 1920x1080 but it was even worse: screens were "blinking" for a solid 20s before fusioning both screens (even if Windows is set to extend and not duplicate). Whatever I was trying never worked.

I spent 2 hours trying out things yesterday without any success, do you guys have an ideas? I guess its the drivers but who knows at that point!


Geoffrey (french guy hoping he didn't made too many mistakes)


CPU Ryzen7 1800X

Windows10 Family

GPU Sapphire 7800XTX Nitro+ (drivers version 22.12.2)

Main monitor Asus ROG XG43VQ

Video projector BenQ W2000

7 Replies
Adept I

Yes, it's probably caused by drivers because I have the same problem with my FHD LG TV. It happened to me after installing Adrenalin drivers (tried on both clean Windows 10/11). Plugging the HDMI cable into the motherboard works perfectly fine.

Asus X670E HERO - 7950X - XFX 7800 XTX (drivers version 22.12.2)

Adept I

Is it hard to reproduce the bug?

Adept I

Nah it happens every time. Couldn't make my projector work correctly even once.


Seems like Alpacalps found a solution. It's interesting that 4 weeks old post didn't get any response from AMD. Also, they didn't mention the problem at drivers known issues section.

Thanks a lot for the share but unfortunately I can't make it work. With the latest drivers (23.1.1) all I got is black screens with my 2 screens so I can't get the multiple displays settings.

Journeyman III

Inside of Radeon software and in the overlay I can't get a reading on my fps. It doesn't matter if I'm on my desktop or playing a game. I never get a reading. It just says FPS: N/A, but every other metric works fine.

Journeyman III

It sounds like you're experiencing a resolution scaling issue with your video mini projector for iphone when using it alongside your 3840x1200 monitor. This could be due to different display settings or GPU scaling settings. Here are some steps you can take to troubleshoot and potentially resolve the problem:

  1. Check Display Settings:

    a. Right-click on your desktop and select "Display Settings."

    b. Ensure that your projector is recognized as a separate display and not being mirrored with your primary monitor.

    c. Set the resolution for your projector to its native 1920x1080 resolution.

    d. Make sure the display mode is set to "Extend" or "Second screen only" rather than "Duplicate."

  2. GPU Scaling Settings:

    a. Open your graphics card control panel, which is typically accessible by right-clicking on your desktop and selecting an option related to your GPU (e.g., NVIDIA Control Panel or AMD Radeon Settings).

    b. Look for scaling settings or display settings. Ensure that GPU scaling is enabled and set to maintain aspect ratio.

  3. Windows Display Settings:

    a. In Windows Display Settings, scroll down to the "Scale and layout" section and check if there's a "Change the size of text, apps, and other items" setting. It should be set to 100% for the projector display.

  4. Advanced GPU Settings:

    a. In your GPU control panel, look for advanced settings or custom resolutions. You might need to create a custom resolution profile for your projector if it's not detected correctly.

  5. Update GPU Drivers:

    Ensure that your GPU drivers are up to date. Sometimes, driver updates can resolve compatibility issues.

  6. Restart and Test:

    After making these changes, restart your computer and test the projector again.

If these steps don't resolve the issue, it could be helpful to provide more information about your graphics card and the operating system you're using for more specific troubleshooting guidance. Additionally, make sure your projector supports a 1920x1080 resolution and check its user manual for any specific settings related to aspect ratio and scaling.